none
Erreur sur le déploiement d'une webpart via VS 2010 RRS feed

  • Question

  • Bonjour,

    J'ai un projet VS2010 pour sharepoint 2010 tout marcher bien mais j'ai voulu changer le nom de ma webpart.

    Il se génére très bien mais pour le déploiement j'ai ce message d'erreur et je n'arrive pas à trouver où ce fichier est configuré.

    Ajouter une solution: Une erreur s'est produite lors de l'étape de déploiement 'Ajouter une solution' : Fichier introuvable : C:\Projets\MyWebPart\bin\Debug\MyWebPart.wsp.

     

    Merci d'avance


    tazamorte
    • Déplacé Hengzhe Li mardi 21 février 2012 07:00 merge forum (Origine :Développement Sharepoint 2010)
    mardi 18 janvier 2011 14:58

Réponses

  • Merci pour la réponse j'avais déjà essayer cette procédure et cela n'a pas marché pour une raison inconnu l'information resté dans la solution.

     

    J'ai trouvé une solution de contournement hier soir très simple qui a consisté à supprimer la solution VS2010 et la recréé puis ajouter les projets et cela a marché du 1er coup.

     


    tazamorte
    jeudi 20 janvier 2011 09:03

Toutes les réponses

  • Visual Studio commence par retirer votre package avant de le déployer, et il vous indique certainement une erreur, soit parce qu'il tente de retirer un package qu'il ne trouve pas, soit parce qu'il tente de déployer un package qu'il ne trouve pas.

     

    Dans votre solution VS2010, ouvrer le dossier Package et double cliquez sur Package.package.

    Modifiez la propriété Name en "MyWebPart.wsp". Recompilez et redéployez. Votre déploiement devrait fonctionner.

    Retirez ensuite votre solution (uniquement retract) et modifiez à nouveau le propriété Name comme il vous convient. Déployez de nouveau.


    Sébastien PICAMELOT - http://blogs.developpeur.org/gribouillon

    jeudi 20 janvier 2011 08:40
    Modérateur
  • Merci pour la réponse j'avais déjà essayer cette procédure et cela n'a pas marché pour une raison inconnu l'information resté dans la solution.

     

    J'ai trouvé une solution de contournement hier soir très simple qui a consisté à supprimer la solution VS2010 et la recréé puis ajouter les projets et cela a marché du 1er coup.

     


    tazamorte
    jeudi 20 janvier 2011 09:03