none
Menu Unit Test grisés RRS feed

  • Question

  • Bonjour

    Quand je lance mes Unit Tests quelque soit les résultats les menus liés au UT sont grisés et je ne peux les relancer.

    Je suis obligé de fermer la solution puis la r'ouvrir pour relancer mes tests.

    Comment régler ce problème ?

    Merci

    Bernard


    Bernard Bouree

    jeudi 29 juin 2017 15:20

Réponses

Toutes les réponses

  • Bonjour Bernard,

    Est-ce ceci que vous avez?

    Si c'est le cas, veuillez supprimer le projet Test Unitaire de votre solution et réintégrez-le.

    Si ce n'est pas le cas, faites-le moi savoir.

    J'espère que j'ai bien répondu à votre question.

    Si c'est le cas, n'hésitez pas à mettre ma réponse en réponse à votre post

    Vous pouvez me suivre sur Twitter : https://twitter.com/NordineMhoumadi


    Download my NEW FREE application MCP PREPARATION in the Windows 10 Store for preparing your Microsoft Certification or test your skills in Microsoft Technologies;

    • Marqué comme réponse BernardBouree vendredi 30 juin 2017 07:09
    • Non marqué comme réponse BernardBouree vendredi 30 juin 2017 08:20
    jeudi 29 juin 2017 16:46
  • Bonjour Nordine

    Merci. Cela a marché.

    Bernard


    Bernard Bouree

    vendredi 30 juin 2017 07:09
  • Nordine

    Le problème revient régulièrement! 

    Est-ce un bug ?

    Quelques fois je suis encore obligé de fermer la solution.

    Pourquoi ai-je également un test non exécuté ?

    

    Merci

    Bernard


    Bernard Bouree

    vendredi 30 juin 2017 08:20
  • Bonjour

    En cherchant sur le web j'ai trouve ceci:

    In order to determine the error you have to do this

    1. Open the Visual Studio command prompt
    2. Change to the directory where the binary output of your test project is.
    3. Type mstest /testcontainer:The.Name.Of.Your.Test.Assembly.dll

    At the bottom of the output you will see the following text

    Run has the following issue(s):

    Mais j'obtiens "Aucun tests à exécuter" !!

    Or j'en ai 23 dont 10 qui ne s"éxécutent pas ??

    Merci pour votre aide.

    Bernard


    Bernard Bouree

    vendredi 30 juin 2017 12:48
  • Bonsoir Bernard,

    Veuillez essayer les solutions proposées sur ce lien : https://stackoverflow.com/questions/25304425/visual-studio-2013-doesnt-discover-unit-tests


    Download my NEW FREE application MCP PREPARATION in the Windows 10 Store for preparing your Microsoft Certification or test your skills in Microsoft Technologies;

    vendredi 30 juin 2017 22:24
  • Bonjour

    Aucune de ces solutions ne fonctionnent.

    Je crois avoir trouvé.

    Certains de mes tests sont buggés mais Unit Test ne les signalent pas comme tels!

    Une fois le bug réglé le test peut être exécuté.

    Pas très convivial!

    Merci

    Bernard


    Bernard Bouree

    samedi 1 juillet 2017 16:04