none
Impossible d'exécuter les applications compilées avec Visual Studio 2015

    Question

  • Bonjour,

    J'ai réalisé une application en C# sous Visual Studio 2015 et je l'ai compilée normalement (au départ en Debug, puis en Release). Tant que je l'exécute au sein de l'environnement Visual Studio, il n'y a aucun problème elle fonctionne parfaitement, mais dès l'instant où j'essaie de l'exécuter directement depuis le fichier exécutable (tant celui situé dans bin\Debug que celui dans bin\Release) il ne se passe rien. L'explorateur windows semble charger (vu que le curseur passe en mode chargement) mais l'application ne se charge jamais, pire encore, il m'est impossible de charger quoi que ce soit d'autre, obligé de redémarrer l'explorateur windows.

    Cela n'arrive pas qu'avec cette application mais avec toutes les applications C# que j'ai développée, même en créant un projet vierge et en tentant de l'exécuter, le même problème survient.

    Que faire pour régler ce problème ? Merci par avance

    jeudi 16 juin 2016 15:51

Réponses

  • Après recherche j'ai trouvé la solution à mon problème. L'antivirus Avast! intègre un processus appelé "DeepScreen" (qui fait globalement la même chose que SmartScreen sur Windows) et qui interfère grandement avec les applications développées sous Visual Studio. Si vous avez le même problème que moi, alors désactivez "DeepScreen".
    jeudi 16 juin 2016 18:32

Toutes les réponses

  • Après recherche j'ai trouvé la solution à mon problème. L'antivirus Avast! intègre un processus appelé "DeepScreen" (qui fait globalement la même chose que SmartScreen sur Windows) et qui interfère grandement avec les applications développées sous Visual Studio. Si vous avez le même problème que moi, alors désactivez "DeepScreen".
    jeudi 16 juin 2016 18:32
  • Bonjour,

    Avez vous essayé d'exécuter votre application en tant qu'administrateur ? Click droit sur l'executable puis "exécuter en tant qu'administrateur".

    mercredi 20 juillet 2016 09:35