none
autoriser le protocole net.tcp WCF RRS feed

  • Question

  • Bonjour à tous,

    J'ai développé un service web WCF utilisant le binding NetTcpBinding, tout fonctionne très bien lorsque je teste mes services sur le serveur IIS7 en local, j'ai activé WAS de manière à autoriser l'utilisation du protocole net.tcp, bref tout fonctionne bien!
    Le problème est le suivant: j'ai souscris chez mochahost pour héberger mon service web et me suis assuré avant de le faire que WAS était bien activé chez eux. J'ai donc déployé mon application mais j'obtiens l'erreur "net.tcp protocol not supported" et je ne vois pas du tout quoi faire.
    En effet, lorsque j'ai déployé le service web en local il a fallu que j'autorise le protocole net.tcp au niveau du gestionnaire IIS mais là dans ce contexte je n'ai pas accès à cette option et je ne sais pas du tout comment remédier au problème...

    Si quelqu'un pouvait m'aider..!
    Merci par avance,
    damien
    lundi 15 février 2010 15:39

Réponses

  • Bonjour,

     

    De votre description, je comprends qu’il s’agit d’un problème d’administration du serveur et pas un problème avec le service web. Avez-vous essayé de contacter votre hébergeur pour remédier ce problème ?

     

    Cordialement,

    Alex


    Alex Petrescu - MSFT
    • Marqué comme réponse Alex Petrescu jeudi 18 février 2010 09:59
    mercredi 17 février 2010 13:05
  • Bonjour,

    Je confirme, seul l'hébergeur peut activer cette option.

    Cordialement
    Gilles TOURREAU - MVP C# - Architecte .NET/Consultant/Formateur
    • Marqué comme réponse Alex Petrescu jeudi 18 février 2010 09:59
    mercredi 17 février 2010 21:46
    Modérateur

Toutes les réponses

  • Bonjour,

     

    De votre description, je comprends qu’il s’agit d’un problème d’administration du serveur et pas un problème avec le service web. Avez-vous essayé de contacter votre hébergeur pour remédier ce problème ?

     

    Cordialement,

    Alex


    Alex Petrescu - MSFT
    • Marqué comme réponse Alex Petrescu jeudi 18 février 2010 09:59
    mercredi 17 février 2010 13:05
  • Bonjour,

    Je confirme, seul l'hébergeur peut activer cette option.

    Cordialement
    Gilles TOURREAU - MVP C# - Architecte .NET/Consultant/Formateur
    • Marqué comme réponse Alex Petrescu jeudi 18 février 2010 09:59
    mercredi 17 février 2010 21:46
    Modérateur