none
Connexion à des données dans une base de données Access : fournisseur OLE DB manquant RRS feed

  • Question

  • Bonjour,

    Je souhaite créer une application Windows Forms qui utiliserait une base de données Access.

    J'ai un problème pour ajouter la source de données à mon projet : j'ai suivi la procédure pas à pas cf. https://msdn.microsoft.com/fr-fr/library/ms171893.aspx § "Créer le jeu de données pour un fichier .accdb" puisque j'utilise une base Access 2013.

    A l'étape 8, on demande de choisir le fournisseur "OLE DB pour le moteur de base de données Microsoft Office Access 12.0"... Mais ce choix n'est pas disponible dans la liste déroulante !

    J'ai pensé résoudre mon problème en installant le "Moteur de base de données Microsoft Access 2010 redistribuable"... pas mieux !
    J'ai cherché sur le web : rien vu à ce sujet...

    Quelqu'un aurait-il une idée ?

    D'avance merci,
    Cordialement,
    Bob

    jeudi 31 mars 2016 22:17

Réponses

  • Bonjour, Bob,

    Je vous invite à tester les solutions proposées dans le thread en bas :
    'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine
    Je vous remercie par avance de votre retour.

    Cordialement,
    Teodora


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    lundi 4 avril 2016 12:24
    Modérateur
  • Bonjour, Bob,

    Je vous invite à tester les solutions proposées dans le thread en bas :
    'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine
    Je vous remercie par avance de votre retour.

    Cordialement,
    Teodora

    Bonjour, Teodora,

    Merci pour cette réponse.

    C'est dans l'un des derniers posts que j'ai trouvé l'indice qui m'a permis de résoudre mon problème : 

    "Visual Studio is only available as a 32-bit application. If you try to connect to Access from within Visual Studio, you must have a 32-bit version of ACE installed."

    J'avais bien téléchargé et installé le "Moteur de base de données Microsoft Access 2010 redistribuable" (cf. Microsoft) ... mais j'ai un système 64bits, je m'entêtais donc à installer la version 64bits, et rien n'y faisais !
    J'ai installé la version 32bits et, miracle, tout fonctionne !

    Merci encore,
    Cordialement,

    Bob.


    COrdialement, Bob33700

    dimanche 10 avril 2016 17:26

Toutes les réponses

  • Bonjour, Bob,

    Je vous invite à tester les solutions proposées dans le thread en bas :
    'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine
    Je vous remercie par avance de votre retour.

    Cordialement,
    Teodora


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    lundi 4 avril 2016 12:24
    Modérateur
  • Bonjour, Bob,

    Je vous invite à tester les solutions proposées dans le thread en bas :
    'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine
    Je vous remercie par avance de votre retour.

    Cordialement,
    Teodora

    Bonjour, Teodora,

    Merci pour cette réponse.

    C'est dans l'un des derniers posts que j'ai trouvé l'indice qui m'a permis de résoudre mon problème : 

    "Visual Studio is only available as a 32-bit application. If you try to connect to Access from within Visual Studio, you must have a 32-bit version of ACE installed."

    J'avais bien téléchargé et installé le "Moteur de base de données Microsoft Access 2010 redistribuable" (cf. Microsoft) ... mais j'ai un système 64bits, je m'entêtais donc à installer la version 64bits, et rien n'y faisais !
    J'ai installé la version 32bits et, miracle, tout fonctionne !

    Merci encore,
    Cordialement,

    Bob.


    COrdialement, Bob33700

    dimanche 10 avril 2016 17:26