none
Problème d'url de mon site internet Azure RRS feed

  • Question

  • Bonjour,

    Je viens de lancer sur Azure un site internet. une fois le changement de DNS effectué, j'ai bien:  www.monsite.fr

    Le soucis, c'est que lorsque je passe de page en page, l'url ne bouge pas, et reste figé sur www.monsite.fr et ne se redirige pas vers une adresse de type www.monsite.fr/PageDetail/test/

    Pourtant, sur l'url d'origine de mon service d'azure, j'ai bien: http://visiteol-front.cloudapp.net/annonce-immobiliere/Vente/Maison/SALLEBOEUF/2000016397465

    J'ai le même soucis avec deux autres sites. Est-ce une option à configurer dans Azrue ou dans mon projet? Quelle est cette option et ou la trouver ?

    J'utilise Windows Azure. Mon pojet est un WebRole (dans la section "Services de cloud"). Mon site web est codé en c# MVC.

    Je vous remercie d'avoir prêté attention à ma demande et j'espère avoir une solution assez rapidement pour ne pas perdre le référencement obtenu via l'ancien site dans google.


    mercredi 30 juillet 2014 10:50

Réponses

  • Bonjour,

    Ce n'est pas un problème avec Azure, mais avec votre hébergeur de nom de domaine. Apriori vous avez opté pour un système à la "Redirection Web", si vous afficher la page de votre site vous verrez un "IFrame" contenant l'url vers cloudapp.net.

    Vérifiez les options de votre redirection web (souvent il y a un mode visible/invisible qui corrigerais votre problème), ou alors modifiez votre domaine pour que votre hôte "www" pointe sur votre site Azure.

    Cordialement,


    Yan Grenier

    • Proposé comme réponse Aurel Bera vendredi 1 août 2014 08:17
    • Marqué comme réponse Aurel Bera lundi 4 août 2014 07:28
    mercredi 30 juillet 2014 16:43
  • Bonjour,

    Effectivement, c'était un problème de mon hébergeur dns qui n'avait pas fait le bon type de redirection

    • Marqué comme réponse Aurel Bera lundi 4 août 2014 07:28
    vendredi 1 août 2014 08:25

Toutes les réponses

  • Bonjour,

    Ce n'est pas un problème avec Azure, mais avec votre hébergeur de nom de domaine. Apriori vous avez opté pour un système à la "Redirection Web", si vous afficher la page de votre site vous verrez un "IFrame" contenant l'url vers cloudapp.net.

    Vérifiez les options de votre redirection web (souvent il y a un mode visible/invisible qui corrigerais votre problème), ou alors modifiez votre domaine pour que votre hôte "www" pointe sur votre site Azure.

    Cordialement,


    Yan Grenier

    • Proposé comme réponse Aurel Bera vendredi 1 août 2014 08:17
    • Marqué comme réponse Aurel Bera lundi 4 août 2014 07:28
    mercredi 30 juillet 2014 16:43
  • Bonjour,

    Effectivement, c'était un problème de mon hébergeur dns qui n'avait pas fait le bon type de redirection

    • Marqué comme réponse Aurel Bera lundi 4 août 2014 07:28
    vendredi 1 août 2014 08:25