locked
Les versions de Silverlight sont-elles programmées à ne plus se lancer ? RRS feed

  • Question

  • Nous venons de constater que les versions de Silverlight 4.0.51240 et inférieures ne peuvent plus se lancer sans demander une mise à jour. Même en répondant non à la question de la mise à jour, le composant Silverlight ne veut pas lancer l'application.

    Pour la version 4.0.51240, celle-ci fonctionnait encore en avril 2014.

    Existe-t-il une date programmée dans les versions de Silverlight empêchant tout lancement sans mise à jour et existe-t-il un contournement à celà ?

    Merci par avance pour vos réponses.

    jeudi 12 juin 2014 21:56

Toutes les réponses

  • Bonjour

    Normalement Silverlight doit fonctionner. Il y a un message d'erreur  dans l'observateur d'évènements?

    Bien cordialement,


    Aurel BERA, MSFT
    MSDN Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE.
    S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    vendredi 13 juin 2014 07:09
  • Bonjour,

    Merci de me répondre si promptement.

    J'ai regardé le journal des évènements, mais je n'ai aucune trace en rapport avec le composant Silverlight.

    Il ne s'agit pas d'une erreur, mais d'un message du composant Silverlight demandant à se mettre à jour : "Mise à jour de Silverlight

    Cette page nécessite une version plus récente de Silverlight. Voulez-vous installer la dernière version à partir du Web Silverlight ?

    Oui / Non"

    La page web hébergeant notre application Silverlight n'a pas été modifié depuis avril. La version minimum passé par l'attribut minRuntimeVersion est bien cette version. J'ai essayé avec une version plus ancienne ou sans ce paramètre, et cela ne change rien. Le message est toujours présent. Et répondre "non" ne permet toujours pas de lancer l'application Silverlight.

    Je ne trouve pas d'autres explications pour le moment que le composant lui-même ait une limite de temps et force une mise à jour.
    Or, notre client, qui est un des grands leaders de l'énergie en France, possède cette version sur certains postes et bien entendu nous avons besoin dans moins de 10 jours de l'application Silverlight. Le service SI de ce grand groupe français indique qu'il n'aura pas le temps de déployer une mise à jour d'ici là.

    Donc si quelqu'un a une explication et une solution, je suis preneur.

    Merci d'avance pour vos réponses.

    vendredi 13 juin 2014 08:52
  • Bonjour,

    Pourriez-vous svp  mettre la valeur AutoUpgrade à false et reconfigurer le minRuntimeVersion ? Cela pourrait a priori résoudre le problème.

    Bien cordialement,

    Fabrice JEAN-FRANCOIS

    vendredi 13 juin 2014 09:26
  • Bonjour,

    Malheureusement, les deux paramètres AutoUpgrade à false et minRuntimeVersion ne changent pas le comportement. Le composant Silverlight cherche à se mettre à jour.

    vendredi 13 juin 2014 10:23
  • Pouvez-vous faire un petit teste :  si vous installez la version Silverlight 4 4.0.60531.0  ( KB 2512827) il fonctionne?

    Bien cordialement, 


    Aurel BERA, MSFT
    MSDN Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE.
    S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    vendredi 13 juin 2014 11:13
  • Ca fonctionne très bien avec la version 4.0.60531.0.

    Par contre ca ne fonctionne pas avec la version antérieur 4.0.60129.0 mais ca fonctionne avec la version 4.0.60310.0.

    vendredi 13 juin 2014 11:57
  • Petit up, pour savoir si quelqu'un aurait une réponse.

    Merci par avance.

    lundi 16 juin 2014 15:07