none
Probleme Navigation Webbrowser RRS feed

  • Question

  • Bonjour,

    Je developpe avec visual basic 2013 express et je rencontre un probleme lors de la navigation avec le controle webbrowser. Celui affiche plusieurs pages sur des sites differents sans problemes notables, mais il ne parvient pas à naviguer sur une page particuliere. Il me renvoie sur une autre page n'ayant aucun rapport avec la page souhaitee. J'ai fait le test depuis chrome, on arrive bien a la bonne page. Y a t il un nombre maximale de pages que le webbrowser peut ouvrir ? (J'en ouvre environ un dizaine avant que le probleme ne survienne).

    Quelques exemples de pages ouvertes sans soucis :

    http://www.allocine.fr/film/fichefilm_gen_cfilm=18598.html

    http://www.allocine.fr/film/fichefilm-18598/casting/

    http://www.allocine.fr/film/fichefilm-18598/photos/

    http://www.cinemapassion.com/jaquettesdvd/Il-faut-sauver-le-soldat-Ryan.php

    et la page qui pose le probleme :

    http://www.allocine.fr/film/fichefilm-18598/photos/detail/?cmediafile=21084634

    le webbrowser me renvoie sur la page

    http://www.allocine.fr/film/fichefilm_gen_cfilm=18598.html

    Avez vous une petite idee de ce qui peut se passer ? (quand on teste la page http://www.allocine.fr/film/fichefilm-18598/photos/detail/?cmediafile=21084634 depuis chrome par exemple on arrive bien dessus, j'avais pense a une eventuelle redirection mais cela ne semble pas etre le cas...)

    Merci de votre aide

    Thierry

    lundi 12 janvier 2015 08:47

Réponses

  • Bonjour merci de votre reponse, Je pense solutionner le probleme autrement. J'interdit la navigation apres le chargement de la page http://www.allocine.fr/film/fichefilm-18598/photos/. Je n'ai plus qu'a effectuer mon traitement depuis cette page.....c 'est un peu de la "bricole" mais ca va fonctionner.... En attendant de me pencher sur le probleme des Headers que je ne connais pas du tout.
    lundi 12 janvier 2015 10:10

Toutes les réponses

  • Bonjour,

    C'est peut être le site Allocine qui vous renvoi (et même certainement) vers une autre page. Essayez de charger cette page avec un header différent. (Il y a une signature de la méthode navigate ou vous pouvez spécifier vos header).

    Copier par exemple ceux de Chrome


    Richard Clark
    Consultant - Formateur .NET
    http://www.c2i.fr
    Depuis 1996: le 1er site .NET francophone

    lundi 12 janvier 2015 09:53
  • Bonjour merci de votre reponse, Je pense solutionner le probleme autrement. J'interdit la navigation apres le chargement de la page http://www.allocine.fr/film/fichefilm-18598/photos/. Je n'ai plus qu'a effectuer mon traitement depuis cette page.....c 'est un peu de la "bricole" mais ca va fonctionner.... En attendant de me pencher sur le probleme des Headers que je ne connais pas du tout.
    lundi 12 janvier 2015 10:10
  • Fiddler est un outil intéressant pour connaitre les Headers 
    https://www.blackbaud.com/files/support/guides/infinitydevguide/Subsystems/inwebapi-developer-help/Content/InfinityWebAPI/coUsingFiddlerCreateHTTPRequest.htm
    mercredi 21 janvier 2015 10:53