none
[IIS] HTTP Error 404. The requested resource is not found. RRS feed

  • Question

  • Bonjour,

    Je suis actuellement en train d'essayer d'héberger une application ASP.Net chez moi à l'aide d'un serveur IIS.

    Tant que je reste sur le réseau local, pas de souci.

    Mon application est lancée est j'arrive à y accéder en entrant dans mon navigateur <nom_du_serveur>/<nom_de_l_application>

    Le souci est lors des tentatives d'accès depuis internet.

    En effet, j'ai bien attribué un nom de domaine à ma connexion, qui est régulièrement mis à jour grave à un client no-ip.

    En essayant d'envoyer un ping sur ce nom de domaine, ce dernier me retourne bien l'IP de ma connexion.

    J'ai également fait la redirection de port nécessaire sur ma box pour rediriger les requêtes du port 80, vers mon serveur.

    Mais un problème survient lorsque j'essaye de rentrer l'URL suivante dans mon navigateur : <nom_de_domaine>/<nom_de_l_application>... Le retour m'affiche le message suivant : HTTP Error 404. The requested resource is not found.

    Il me semble que le problème vient bien de IIS et pas autre chose.

    En effet, j'arrive sans souci à accéder à un serveur Wamp en utilisant le même nom de domaine. [Il est à présent arrêté, c'était juste pour le test. L'erreur ci-dessus s'affiche quand le port 80 est bien utilisé par IIS et pas une autre application]

    Donc en toute logique, ça ne semble pas venir de mon pare-feu, ni de ma redirection de port, ni de mon nom de domaine.

    Merci d'avance pour votre aide.

    Cordialement.

    samedi 15 février 2014 14:52

Réponses

  • Bonjour à tous,

    J'ai enfin réussi à résoudre mon problème.

    Je n'ai aucune idée de si toutes les modifications faites ci-dessus ont été utiles ou non du coup.

    Le problème venait de l'emplacement de mon application dans l'arborescence de mon IIS.

    Référez vous à la partie 3 de mon premier screen du précédent message.

    On peut voir que mon WsDbMozart est situé en dessous du DefaultWebSite dans l'arborescence.

    En plaçant mon application à la racine des sites, j'ai pu y accéder directement.

    Merci en tout cas à Aurel et Gilles qui auront pris le temps de m'apporter leur aide, elle m'a permis de bien mieux comprendre le paramétrage et le fonctionnement d'un IIS.

    En espérant que ce thread aidera d'autres personnes tout aussi tête en l'air que moi.

    Cordialement.

    mardi 18 février 2014 10:35

Toutes les réponses

  • Bonsoir,


    J'ai malgré tout continué d'avancer dans mes recherches, mais je me retrouve bloquer à un nouveau point.

    Bon, dans un premier temps, si jamais quelqu'un ayant le même problème lit ce message, voici les deux liens qui m'ont permis d'avancer :

    MSDN.Microsoft  & IIS.Net

    Manifestement, je m'étais trompé dans le diagnostique de mon précédent message.

    Le problème ne vient pas de mon IIS, mais de mon application ASP.Net.

    Pour publier son application sur le net, il faut définir ce paramètre au sein du projet. [=Premier lien]

    Le second lien est un répertoire d'erreurs potentiels lors de ce déploiement.

    Et c'est d'ailleurs là que je bute :

    En effet, lors de la tentative de connexion, le test de validation me sort une erreur 401 : ERROR_USER_NOT_ADMIN

    Alors, je sais, effectivement, cette erreur est présente dans le répertoire d'erreurs du second lien.

    Cependant, même après avoir suivi les préconisations pour résoudre ce problème, j'ai toujours la même erreur.

    Il faut savoir que mon IDE visual studio est sur la même machine que le serveur IIS.

    La machine distante est donc la même que la machine locale.

    J'ai bien un utilisateur A faisant parti du groupe MSDepSvcUsers [Oui, oui, avec la casse, on fait les choses bien, même si il me semble que la casse n'est pas prise en compte sous Windows ☺]

    Des personnes ont des idées ?

    Cordialement

    samedi 15 février 2014 18:50
  • Bonjour,

    Avez-vous bien installer et configurer ASP .NET dans IIS via l'utilitaire "regiis_aspnet -i" ? Avez vous essayé d'accéder à une page ASPX classique ? HTML ?

    Cordialement


    Gilles TOURREAU - MVP C#
    Architecte logiciel/Consultant/Formateur Freelance - P.O.S Informatique
    Blog : http://gilles.tourreau.fr - Suivez-moi sur Twitter
    - MCPD : Enterprise Developper / Windows Developper 3.5 / ASP .NET 3.5/4.0
    - MCSA : SQL Server 2012
    - MCITP : SQL Server 2008 Developper
    - MCTS : ADO .NET 3.5 / SQL Server 2008 Developper / Windows Forms 3.5 / ASP .NET 3.5/4.0 / TFS 2010 / Windows Azure

    dimanche 16 février 2014 22:20
    Modérateur
  • Bonjour Gilles,

    Effectivement, j'ai bien la version 4.5 du framework .Net installé sur mon serveur.

    En revanche pour ce qui est d'essayer d'accéder à une page ASPX ou HTML classique, j'ai le même problème : J'arrive à afficher la page par défaut de IIS tant que je reste sur le réseau local, mais dès que j'essaye d'y accéder depuis le net, j'ai la même erreur 404.

    Cordialement.

    lundi 17 février 2014 08:14
  • Bonjour

    Voir la dernière réponse dans ce thread:
    http://forums.iis.net/t/1200986.aspx?Question+about+accessing+site+from+internet+404+erro

    Cordialement,


    Aurel BERA, MSFT
    MSDN Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE.
    S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    lundi 17 février 2014 09:25
  • Bonjour Aurel,

    Merci pour ce lien, j'ai bien exploré les différentes pistes qui sont soulevées, mais j'ai toujours la même erreur.

    N'étant pas sur d'avoir tout compris aux explications fournies dans ce thread, je vais détailler dans ce messages les actions mises en places :

    - Pour le firewall : Je l'ai désactivé le temps des tests

    - IIS Configuration : Pour la configuration des restrictions, la liste était vide. J'ai ajouté l'IP local du serveur et l'IP publique à la liste des restrictions du site... Et j'ai redémarré le serveur, ainsi que visual studio. [Ne marchant toujours pas, j'ai également testé d'ajouté ces filtres d'autorisation au pool d'application et au serveur]

    - Make sure that the requested resource is at the location that the URL points to. : Là, j'ai un doute.

    J'ai renseigné les différents champs de l'assistant de la manière suivante, mais je ne sais pas si ce sont les bonnes informations :

    Serveur : http://<nom_de_domaine>

    Nom de l'application : <nom_de_l_application>

    URL de destination : http://<nom_local_du_serveur>/<nom_de_l_application>

    Sachant que la chaine des caractères renseigné dans l'URL de destination est celle renseignée dans mon navigateur pour accéder à l'application sur le réseau local

    - Review the URL that you open in the Web browser. : Elle est bonne et accessible

    - Make sure that no custom filters or modules restrict access to the file that you want to browse, : J'ai checké les propriétés du dossier de projet, ce dernier était en lecture seule, j'ai sorti cette restriction et accordé les droits en contrôle total à l'utilisateur Windows utilisé pour la publication. Côté IIS, il y a une règle d'autorisation, c'est un mode autoriser pour tous les utilisateurs. Au niveau des modules, tout est laissé par défaut. Je n'ai rien checké d'autre.

    Quelques informations supplémentaires :

    - Le nom du profil pour la publication est différent de toutes les autres informations [Nom de domaine, nom de l'application, nom du serveur, etc etc], je ne sais pas si ça a un impact.

    - J'ai vu dans les configurations de IIS une option intitulée : "Règles de création WebDAV"... Y aurait-il quelque chose à faire de ce côté là ?

    C'est ma première expérience sur IIS, donc effectivement, je fais plus que tâtonner...

    Cordialement.

    lundi 17 février 2014 10:21
  • Dans la config IIS, les liens qu'est que vous avez pour le port 80 ?
    Ici vous avez des détails :
    http://technet.microsoft.com/FR-FR/library/cc731692(v=ws.10).aspx
    Assurez-vous que le port 80 accepte tous les IP :

    IIS accepting IP

      Cordialement,


    Aurel BERA, MSFT
    MSDN Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE.
    S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    lundi 17 février 2014 10:41
  • Aurel,

    Oui, effectivement, j'accepte toutes les IP sur le port 80.

    Et le Host Name est renseigné par la chaine de caractère <nom_de_l_ordintateur>

    lundi 17 février 2014 10:55
  • Essayez de vérifier les logs dans C:\inetpub\logs\LogFiles et les partages avec nous.

    Quelle version IIS utilisez-vous?

    Voir aussi cet article:  http://support.microsoft.com/kb/315122

    Cordialement,


    Aurel BERA, MSFT
    MSDN Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE.
    S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.




    • Modifié Aurel Bera lundi 17 février 2014 12:47
    lundi 17 février 2014 12:43
  • Aurel,

    Vous trouverez à ce lien une archive contenant les fichiers de log de mon serveur : http://paf.im/4voKB

    En ce qui concerne le lien que vous m'avez spécifié, j'étais déjà tombé dessus lors de mes recherches, mais je ne l'avais lu qu'en travers pour deux raisons :

    - Je suis sur une version 8.0 de IIS

    - Je ne trouvais aucune informations sur mon gestionnaire IIS et qui était indiquée sur l'article.


    lundi 17 février 2014 13:25
  • Je vois erreur 404.0 qui signifie Introuvable.

    N'est pas claire pour moi si la page default IIS retourne erreur en local aussi que via internet.

    Assurez-vous que ASP.NET est bien configurée de fonctionner avec IIS :

    http://www.iis.net/learn/get-started/whats-new-in-iis-8/iis-80-using-aspnet-35-and-aspnet-45

    (Ou la solution que Gilles vous a proposée)

    Cordialement,


    Aurel BERA, MSFT
    MSDN Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE.
    S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    lundi 17 février 2014 14:13
  • Aurel,

    Je ne comprends vraiment pas.

    J'ai à nouveau testé l'installation avec l’utilitaire regiis_aspnet -i que m'avait indiqué Gilles, et l'utilisation de cette commande me retournait que le .Net 4.5 était déjà installé.

    J'ai donc suivi le tutoriel que vous m'avez fourni, et ma configuration semble pourtant déjà matcher avec les indications du tutoriel.

    Je joins à ce poste différents screens montrant les configurations clefs de mon serveur. N'hésitez pas à me le signaler si j'en ai oublié certaines :

    1) Activation des services .Net 4.5

    2) Activation des fonctionnalités IIS. [Je ne me sers pas du FTP pour l'instant]

    3) Console de management IIS. J'ai bien tous les pools indiqués et l'icône qui indique que mon application est bien reconnue comme tel.

    Je tiens à préciser que ces cases étaient déjà cochées avant d'ouvrir ce thread. Le serveur a été redémarré plusieurs fois avant les tests et les fonctionnalités ont été correctement ajoutées me semble-t-il

    Et voici les résultats de ma configuration :

    1) En accès local

    2) En accès exterieur

    Je ne sais pas si quelques détails sur l'application peuvent aider à trouver de nouvelles pistes de solutions :

    Il s'agit d'un projet ASP.Net qui ne contient qu'un Entity Data Model d'une petite base de données tournant sous MySQL.

    Il a pour but d'être passé en référence de service à un autre projet Windows Phone.

    Cordialement

    lundi 17 février 2014 15:48
  • Le HostName dans la config des Site Bindings doit rester vide.

    Cordialement,


    Aurel BERA, MSFT
    MSDN Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE.
    S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    mardi 18 février 2014 06:38
  • Bonjour à tous,

    J'ai enfin réussi à résoudre mon problème.

    Je n'ai aucune idée de si toutes les modifications faites ci-dessus ont été utiles ou non du coup.

    Le problème venait de l'emplacement de mon application dans l'arborescence de mon IIS.

    Référez vous à la partie 3 de mon premier screen du précédent message.

    On peut voir que mon WsDbMozart est situé en dessous du DefaultWebSite dans l'arborescence.

    En plaçant mon application à la racine des sites, j'ai pu y accéder directement.

    Merci en tout cas à Aurel et Gilles qui auront pris le temps de m'apporter leur aide, elle m'a permis de bien mieux comprendre le paramétrage et le fonctionnement d'un IIS.

    En espérant que ce thread aidera d'autres personnes tout aussi tête en l'air que moi.

    Cordialement.

    mardi 18 février 2014 10:35