none
Problème d'icone RRS feed

  • Question

  • Bonjour,

    Sous Windows 10, VS 2019 Community dernière version. Je travaille sur une appli de bureau WPF et je veux lui attribuer une nouvelle icone.

    Pour ce faire j'ai ajouté un nouveau fichier icon à l'appli mais j'ai été incapable d'en construire si ce n'est pixel par pixel.

    j'ai donc ajouté un fichier icon existant et je l'ai modifié. Ce fichier comporte deux icônes : l'une en 16 x 16 4 bits BMP et l'autre 32 x 32 8 bits BMP. Je n'ai modifié que l'image 32 x 32 8 bits BMP. Là ça marche.

    Mon appli est générée dans son répertoire Debug / Release avec son icône qui s'affiche dans l'explorateur Windows. 

    Je créé maintenant un raccourci de l'appli dans ce répertoire. Il apparaît là aussi avec l'icône correcte. Lorsque je glisse ce raccourci sur le bureau, c'est là que le problème arrive : l'icône sur le bureau n'est pas la bonne. Par contre, si j'arrête Windows et que je le redémarre, l'icône correcte s’affiche aussitôt sur le bureau ! J'ai répété cette opération plusieurs fois, c'est toujours le même scénario.

    Merci de me dire où est le problème et comment le résoudre.

    D'une manière générale la création de fichiers d'icônes n'est pas simple du tout. Faut-il le faire bit à bit ou existe-t-il une autre possibilité ? 

    J'ai tenté de copier une image réalisée sous Photoshop dans une image d'icône de même taille mais le coller n'a pas fonctionné.

    Cordialement



    Alain

    jeudi 25 juin 2020 15:09

Réponses

Toutes les réponses