none
Insérer une formule dans une cellule Excel au moyen du code VBA

    Question

  • La ligne VBA suivante :
    ActiveCell.Formula = "=SOMME(B1:B3)"

    aboutit à la saisie suivante :
    =somme(B1:B3)
    mais le message d'erreur suivant est affiché dans la cellule. : #NOM?

    La formule n'est donc pas reconnue par Excel à la suite de la saisie par VBA; alors que si je double-clique dans la cellule en question, suivi immédiatement par la touche ENTER : le nom de la formule s'écrit en majuscule et le calcul est effectué.

    Que dois-je faire pour que les formules saisies par VBA soient immédiatement fonctionnelles ?

    Merci d'avance de votre aide.

    samedi 21 avril 2018 16:53

Toutes les réponses