none
sql server compact edition RRS feed

  • Question

  • bonjour

    j'ai convertit une base de données sql server (mdf) vers une autre qui utilise sql server compact edition (sdf)avec l'outil data port wizard

      la conversion fonctionne bien mais une des tables semble être de grande taille, a la fin de la conversion cette table pèse 300 mo

    au lancement de management studio et/ou data port console il me dit que la taille de la table est plus grande que la taille autorisé ,j'ai trouvé sur msdn que la taille max est de 4 giga

    je ne comprend pas ou est le problème

    une idées svp?

    merci


    • Modifié Amine008 lundi 23 janvier 2012 13:44
    lundi 23 janvier 2012 13:43

Réponses

  • Effectivement cela ne semble ne rien avoir à faire avec une limitation intrinsèque de SQL Server sur une table mais plutôt avec un réglage mis en place à la première connexion sur le fichier base de données.

    Dans SSMS 2005, si je choisis SQL Server Compact et que je clique sur le bouton "Options", je vois dans l'onglet "Propriétés de connexion", une "Taille maximale de base de données" à 128 Mo par défaut. Cela donne quoi si vous mettez une valeur qui convient à votre cas ?

     


    Please always mark whatever response solved your issue so that the thread is properly marked as "Answered".

    lundi 23 janvier 2012 16:36

Toutes les réponses

  • Bonjour,

    De préférence, merci de toujours citer le message d'erreur EXACT même si il est en anglais (cela évite parfois des problèmes d'interprétation).

    Je me demande par exemple si cela ne serait pas plutôt la limite par ligne de table (8060 octets) et comme SQL Server Compact gère NVARCHAR au lieu de VARCHAR cette limite peut-être atteinte plus vite ?


    Please always mark whatever response solved your issue so that the thread is properly marked as "Answered".
    lundi 23 janvier 2012 14:15
  • Re

    voici l'erreur sur management studio


    ------------------------------
    INFORMATIONS SUPPLÉMENTAIRES :

    La taille du fichier de base de données est supérieure à la taille maximale configurée pour la base de données. Ce paramètre prend effet uniquement lors de la première connexion de base de données simultanée. [ Required Max Database Size (in MB; 0 if unknown) = 0 ] (SQL Server Compact ADO.NET Data Provider)

    ------------------------------

     

    en effet les données sont en VARCHAR,mais même après un cast le problème persiste


    • Modifié Amine008 lundi 23 janvier 2012 15:22
    lundi 23 janvier 2012 15:09
  • Effectivement cela ne semble ne rien avoir à faire avec une limitation intrinsèque de SQL Server sur une table mais plutôt avec un réglage mis en place à la première connexion sur le fichier base de données.

    Dans SSMS 2005, si je choisis SQL Server Compact et que je clique sur le bouton "Options", je vois dans l'onglet "Propriétés de connexion", une "Taille maximale de base de données" à 128 Mo par défaut. Cela donne quoi si vous mettez une valeur qui convient à votre cas ?

     


    Please always mark whatever response solved your issue so that the thread is properly marked as "Answered".

    lundi 23 janvier 2012 16:36
  • Ok sa marche bien :)

    mais actuellement j'ai un autre problème,dans les données originaux j'ai deux colonnes de type datetime,après la conversion vers database compact les données sont tous "NULL",le type reste bien datetime

    il s'agit d'un probleme de conversion ou de sql database CE?

    merci


    • Modifié Amine008 lundi 23 janvier 2012 16:55
    lundi 23 janvier 2012 16:55
  • Je dirais plutôt un problème à la conversion ? Je ne sais pas si ce produit permet de voir ce qui est fait exactement...

     


    Please always mark whatever response solved your issue so that the thread is properly marked as "Answered".
    lundi 23 janvier 2012 17:39
  • y a t'il un autre moyen de convertir une base de données mdf vers une base de données sdf?

    mais comme j'ai dit ,uniquement les datetime les autre variable fonctionne bien

    merci encore

    lundi 23 janvier 2012 19:00
  • Bonjour

    effectivement c'est un problème de conversion,j'ai utilisé une version plus recente de l'outil et tout marche bien

    problème résolu

    Merci beaucoup


    • Modifié Amine008 mardi 24 janvier 2012 09:13
    mardi 24 janvier 2012 09:13