none
[RESOLU ]Problème de migration base 2003 vers 2007 RRS feed

  • Question

  • bonjour,

    Si je n'ai eu aucun problème pour convertir mes bases 2003 vers 2007, je bute sur l'une d'elle.

    Lorsque je l'ouvre, je reçois le message : L'expression Sur chargement entrée comme paramètre de la propriété de type évènement est a l'origine dune erreur.
    Un problème est survenu durant la communication entre Microsoft Office Access et le serveur OLE ou le contrOle ActiveX

    J'ai eu beau vérifier que les noms d'objets appelés dans les sub sont corrects, je ne vois rien.

    Avez-vous une idée d'où vient le problème car je voudrais éviter de refaire ma base ?

    merci d'avance pour votre aide.


    dimanche 24 juillet 2016 08:53

Toutes les réponses

  • Bonjour,

    Je ne peux que répondre par des questions car votre exposé n'est pas assez précis.

    • A quel moment survient ce message ?
    • A l'ouverture de la base ?
    • Si oui, que fait la base aèu démarrage ?
    • Si non, quel formulaire ou procédure est concerné par ce message ?
    • Avez-vous vérifié les références (VBE/Outils/Références)

    Argy

    lundi 25 juillet 2016 14:34
    Modérateur
  • Bonjour et merci pour votre réponse.

    le message apparaît à l'ouverture du formulaire principal (qui s'ouvre quand même) mais aussi à l'ouverture de tous les autres formulaires.

    Finalement n'ayant pas trouvé de solution, j'ai recréé une base nouvelle dans laquelle j'ai fait un copie/coller de tous les objets et après quelques ajustements, tout fonctionne bien maintenant.

    Ce qui m'épate ici c'est que j'ai migré une bonne quinzaine de bases et c'est la seule qui a posé problème.

    La particularité dans celle-ci est qu'elle utilise une table liée, mais bon, après avoir réinitialisé de bon chemin, ça aurait du fonctionner ??

    je vais déclarer ce sujet RESOLU.

    bonne journée

    lundi 25 juillet 2016 14:44