none
Cristal Report : Sous rapport vide RRS feed

  • Question

  • Bonjour,

    j'utilise CR avec Visual studio 2010 en VB, et j'ai un problème de génération de rapport qui utilise 2 sous rapports et 3 requêtes (une pour le rapport, et une par sous-rapport).

    voici mon code :

      Dim SourceRapport AS DataTable
            Dim curRapport AS String = ""
            Dim Report AS New ReportDocument()
     
                    curRapport = Application.StartupPath + "\\Editions\\OPERATIONSPAROF.rpt"
     
                    Dim SousReport_1 AS New ReportDocument()
                    Dim SousReport_2 AS New ReportDocument()
     
                SourceRapport = P_AccesBD.CreDataTable(P_Requete)
                Report.LOAD(curRapport)
                Report.SetDataSource(SourceRapport)
                    Report.OpenSubreport("OPERATIONSPAROF-NOMENCLATURE.rpt").SetDataSource(P_AccesBD.CreDataTable(ClRqAction.EditionOPERATIONSPAROF_NOMENCLATURE(FOperationsParOF.CurOF_Edition)))
                    Report.OpenSubreport("OPERATIONSPAROF-GAMME.rpt").SetDataSource(P_AccesBD.CreDataTable(ClRqAction.EditionOPERATIONSPAROF_GAMME(FOperationsParOF.CurOF_Edition)))

    J'ai tenté de créer des liens avec click droit > "Changer les liens du sous-rapport" mais je n'arrive à rien de concluant

    Mes 3 requêtes renvoient un ID (toujours le même pour les 3 requêtes et pour chaque ligne) et divers champs.

    Le plus étrange c'est que même pour les en-tete de champ dans mon sous-rapport les utilisant (vous savez, quand on met un champ dans la section détails, une en-tete se crée dans la section en-tete de page), j'ai un vide. j'ai seulement les traits de mon tableau.

    Quelqu'un saurait m'aider?
    mardi 25 septembre 2012 07:45

Réponses