none
Erreur 401.1 sur un site sharepoint RRS feed

  • Question

  •  

    Bonjour,

     

    J'ai installé Sherpoint service 3.0 sur un serveur Windows 2003 et configuré un site selon le model de base "site équipe".

     

    Je n'ai aucun problème d'accès à ce site via l'interne : http://nom_serveur. J'arrive donc à m'authentifier avec un user de l'AD.

     

    Parcontre de l'externe j'ai une erreur 401.1.

     

    J'ai bien configuré la partie "Mappages des accès de substitution" avec un url public, donc ça devrait fonctionner.

     

    Si je vais dans la configuration IIS et que je désactive "Authentification Windows intégrée" et que j'active et configure "Authentification de base" avec mon nom domaine; ça fonctionne !!! J'accède  à mon site Sharepoint avec mon users de l'AD.

     

    Vous avez une idée sur le problème ?

     

    Merci  

    dimanche 24 février 2008 18:42

Toutes les réponses

  • Bonjour

     

    Quand vous accéder à votre site depuis l'extérieur, êtes vous sur le même domaine ou bien un autre ? Y a-t-il un reverse proxy pour gérer les connexions entrantes ? Celui ci pourrait avoir du mal à passer la bonne identité (utilisez-vous vous même un proxy avec authentification ?)

     

    Essayez de vous connecter avec Firefox, si vous avez plusieurs authentification à fournir (proxy + AD), vous aurez devriez voir plusieurs popups d'authentification.

     

    lundi 25 février 2008 22:41
  • Merci pour ta réponse !

     

    Finalement j'ai fait d'autres tests:

     

    J'ai désactivé l'option de sécurité IIS "Authentification de base" et réactivé l'option "Authentification Windows Intégrée" seulement (comme l'install d'origine).

     

    J'essaie de nouveau l'accès avec mon url public, mais cette fois j'ai ajouté le nom de mon "domaine Windows" au username (nomdomaine\username)  ... Ca fonctionne !!

     

    À l'origine mon problème était avec url public, à l'externe comme à l'interne. Mon authentification était invalide et après trois tentatives d'accès IE me revoie l'erreur 401.1.

     

    J'ai un autre SharePoint, sur un serveur test et dans le cas de celui-ci je n'ai pas a insérer le nom de domaine.

     

     

    Merci

     

     

     

     

    mardi 26 février 2008 00:41