none
Modifier memory limit RRS feed

  • Question

  • Bonjour,

    J'hesite çà déposer cette demande sur SQL server ou ASP.NET.

    Je travail avec SQL Server 2000 et ASP.NET framework1.1.

    Sur un site j'ai un probleme "Exception of type system. out of memory exception was throw".

    Je pense que ce problème se produit car l'ordinateur n'a pas suffisamment de mémoire pour terminer l'opération demandée. J'aimerai donc augmenter memoire limit.

    - je dois intervenir au niveau SQL Server, ou IIS?

    - Comment je fais pour d'abord vérifier la mémoire limit

    - Ensuite comment je l'augmente.

    merci pour votre aide.

     

    mardi 6 septembre 2011 12:48

Réponses

  • Bonjour étant donné le message d'erreur c'est clairement du côté IIS / ASP.net qu'il y a manque de mémoire.

    Après vous ne dites pas si SQL Server est installé sur la même machine, dans le doute je dirais que oui.

    Dans ce cas il est possible de limiter la mémoire utilisé au niveau de SQL Server:

    • Connectez vous sur l'instance SQL Server
    • Executez la commande suivante :

    sp_configure 'show advanced options', 1
    RECONFIGURE
    GO
    
    sp_configure 'max server memory', xxxx
    RECONFIGURE
    GO
    
    sp_configure 'show advanced options', 0
    RECONFIGURE
    GO
    
    

    Où xxxx est la taille maximum que vous souhaitez laissé à SQL Server en MégaOctets, celà dépend de la mémoire totalle disponible sur la machine. Partez sur moitié / moitié par exemple.

    Il n'est pas nécessaire de redemarrer l'instance pour que le paramètre soit pris en compte. Par contre si le problème persiste je vous conseille de le faire, car la libération de mémoire sous SQL Server 2000 n'est pas aisé.

    Il est aussi possible de modifier cette valeur dans Enterprise Manager, dans les propriétés de l'instance.

    Dernier point assurez vous que vous avez bien patché cette instance, et aussi de passer à une version plus récente, SQL Server 2000 n'est plus supporté par Microsoft et les nouvelles versions gèrent bien mieux la mémoire.

    Bonne journée.


    Christian Robert - MVP SQL Server - Microsoft Certified Master - SQL Server 2008
    Blog : http://www.sqlnco.ch
    Groupe des Utilisateurs Francophone de SQL Server : http://www.guss.fr
    mardi 6 septembre 2011 13:44

Toutes les réponses

  • Bonjour étant donné le message d'erreur c'est clairement du côté IIS / ASP.net qu'il y a manque de mémoire.

    Après vous ne dites pas si SQL Server est installé sur la même machine, dans le doute je dirais que oui.

    Dans ce cas il est possible de limiter la mémoire utilisé au niveau de SQL Server:

    • Connectez vous sur l'instance SQL Server
    • Executez la commande suivante :

    sp_configure 'show advanced options', 1
    RECONFIGURE
    GO
    
    sp_configure 'max server memory', xxxx
    RECONFIGURE
    GO
    
    sp_configure 'show advanced options', 0
    RECONFIGURE
    GO
    
    

    Où xxxx est la taille maximum que vous souhaitez laissé à SQL Server en MégaOctets, celà dépend de la mémoire totalle disponible sur la machine. Partez sur moitié / moitié par exemple.

    Il n'est pas nécessaire de redemarrer l'instance pour que le paramètre soit pris en compte. Par contre si le problème persiste je vous conseille de le faire, car la libération de mémoire sous SQL Server 2000 n'est pas aisé.

    Il est aussi possible de modifier cette valeur dans Enterprise Manager, dans les propriétés de l'instance.

    Dernier point assurez vous que vous avez bien patché cette instance, et aussi de passer à une version plus récente, SQL Server 2000 n'est plus supporté par Microsoft et les nouvelles versions gèrent bien mieux la mémoire.

    Bonne journée.


    Christian Robert - MVP SQL Server - Microsoft Certified Master - SQL Server 2008
    Blog : http://www.sqlnco.ch
    Groupe des Utilisateurs Francophone de SQL Server : http://www.guss.fr
    mardi 6 septembre 2011 13:44
  • Merci beaucoup pour cette réponse.
    mardi 6 septembre 2011 14:15