none
Reporting Services : Erreur 503 RRS feed

  • Question

  • Bonjour,

     

    Voilà un problème qui me pollu depuis plusieurs semaines et qui se trouve sera réglé en 2 seconde avec votre aide.

     

    La configuration est la suivante :

    - Server Windows Server 2003  SP1 sur un domaine. le serveur n'est pas controleur de domaine.

    - SQL SERVER 2005 SP1

     

    Le service reporting server utilise le compte NetWorkService

     

    Dans IIS ou sur IE sur le serveur, pas de problème. Le site Reports s'affiche correctement et il est possible de lancer le générateur de rapport.  La publication depuis visual studio 2005 de rapport fonctionne.

     

    Mais dès que l'on passe sur un poste client, il devient impossible de lancer le Générateur de rapport ou de publier un report via VS 2005, par contre pas de problème pour en afficher.

     

    voici le message d'erreur qui est renvoyé :

     

    Code Snippet

     

    INFORMATIONS SUR LA VERSION DE LA PLATEFORME
     Windows    : 5.0.2195.262144 (Win32NT)
     Common Language Runtime  : 2.0.50727.42
     System.Deployment.dll   : 2.0.50727.42 (RTM.050727-4200)
     mscorwks.dll    : 2.0.50727.42 (RTM.050727-4200)
     dfdll.dll    : 2.0.50727.42 (RTM.050727-4200)
     dfshim.dll    : 2.0.50727.42 (RTM.050727-4200)

    SOURCES
     Url de déploiement    : http://z3r7500c/ReportServer/ReportBuilder/ReportBuilder.application

    RÉSUMÉ DES ERREURS
     Un résumé des erreurs est fourni ci-dessous. Les détails de ces erreurs sont indiqués plus loin dans le fichier journal.
     * L'activation de http://z3r7500c/ReportServer/ReportBuilder/ReportBuilder.application a provoqué une exception. Les messages d'erreur suivants ont été détectés :
      + Échec du téléchargement de http://z3r7500c/ReportServer/ReportBuilder/ReportBuilder.application.
      + Le serveur distant a retourné une erreur : (503) Serveur non disponible.

    RÉSUMÉ DES ERREURS DE LA TRANSACTION DU MAGASIN DE COMPOSANTS
     Aucune erreur de transaction n'a été détectée.

    AVERTISSEMENTS
     Aucun avertissement n'a été émis pendant cette opération.

    ÉTAT DE LA PROGRESSION DE L'OPÉRATION
     * [07/05/2007 12:07:12] : L'activation de http://z3r7500c/ReportServer/ReportBuilder/ReportBuilder.application a commencé.

    DÉTAILS DE L'ERREUR
     Les erreurs suivantes ont été détectées au cours de cette opération.
     * [07/05/2007 12:08:12] System.Deployment.Application.DeploymentDownloadException (sous-type inconnu)
      - Échec du téléchargement de http://z3r7500c/ReportServer/ReportBuilder/ReportBuilder.application.
      - Source : System.Deployment
      - Trace de la pile :
       à System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)
       à System.Deployment.Application.SystemNetDownloader.DownloadAllFiles()
       à System.Deployment.Application.FileDownloader.Download(SubscriptionState subState)
       à System.Deployment.Application.DownloadManager.DownloadManifestAsRawFile(Uri& sourceUri, String targetPath, IDownloadNotification notification, DownloadOptions options, ServerInformation& serverInformation)
       à System.Deployment.Application.DownloadManager.DownloadDeploymentManifestDirectBypass(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, SubscriptionState& subState, IDownloadNotification notification, DownloadOptions options, ServerInformation& serverInformation)
       à System.Deployment.Application.DownloadManager.DownloadDeploymentManifestBypass(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, SubscriptionState& subState, IDownloadNotification notification, DownloadOptions options)
       à System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut)
       à System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)
      --- Exception interne ---
      System.Net.WebException
      - Le serveur distant a retourné une erreur : (503) Serveur non disponible.
      - Source : System
      - Trace de la pile :
       à System.Net.HttpWebRequest.GetResponse()
       à System.Deployment.Application.SystemNetDownloader.DownloadSingleFile(DownloadQueueItem next)

    DÉTAILS DE LA TRANSACTION DU MAGASIN DE COMPOSANTS
     Aucune information disponible sur la transaction.

     

     J'ai tenté d'utiliser différents compte sur le reporting services, j'ai modifié les fichiers .config, j'ai ajouté des utilisateurs partout ou c'était possible, et rien n'y fait.

     

    Donc si vous avez une idée pour m'aider, je suis preneur,

     

    Par avance merci.

     

     

    lundi 7 mai 2007 10:10

Toutes les réponses

  • J'ai solutionné mon problème.

     

    En fait cela venez du paramétrage de Internet Explorer et des informations disponible dans le DHCP.

     

    Si vous rencontrez ce problème désactivez la case "Détecter automatique les paramètres de connexion" dans les paramètres réseau de l'onglet Connexions du menu Outils.

    mardi 15 mai 2007 08:13