locked
Application ne répond plus RRS feed

  • Question

  •  

    Bonjour,

     

    Nous avons une application qui a été developpée sur un pc XP avec VS 2002 et le framework 1.1

    Cette application à été mise sur un share de notre file server. Lorsqu'on exécute cette application depuis des postes vista  l'application ne démarre pas. Les client ne sont pas dans le même domaine. Les clients ont les framework 1, 2 et 3 installés. Nous avons un message comme quoi l'application ne répond pas. Les droits des framework à été mis à full trust pour la zone intranet.

     

    Je ne vois pas d'ou provient le problème.

    Est-ce qu'il y a une protection supplémentaire pour les pc équipé de vista?

    Du point de vue des protocoles et port faut-il en ouvrir pour que le chargement puisse s'effectuer?

    mardi 18 mars 2008 20:22

Réponses

Toutes les réponses

  • Si je me souviens bien de mon expérience antérieure, ce n'est pas à cause de Vista, mais plutôt que l'on ne peut pas rouler un exécutable qui se trouve sur le réseau. Vous n'aurez pas le choix de copier localement l'éxécutable pour que tout fonctionne.

     

    mercredi 19 mars 2008 11:36
  • Le problème c'est ces même application fonctionnent sans problème dans un autre domaine avec des client XP. Les deux domaines sont des asbl différentes avec une architecture réseau différente. Je ne vois pas d'ou cela peut provenir d'autre que de vista mais je ne sais pas quoi!!!!

     

    Je ne sais pas si la situation est clairement exposer.

     

    Merci de vos réaction

     

     

     

    mercredi 19 mars 2008 20:10
  • Bonjour,

     

    Je fais peut-être une erreur, mais je croyais que que VS 2002 demandait le framework 1.0 et non 1.1.

    Sur Vista, ne faut-il pas une version spéciale des framework 1.0 et 1.1 ?

     

    Quel est le message exact d'erreur ?

     

    Avez-vous regardé dans les logs Système,Application et Sécurité s'il y a des évènements enregistrés pour cette application ?

     

    Bonne journée

    vendredi 21 mars 2008 07:19
  •  

    Sur les PC en Vista, vous avez pensez à modifier la politique de sécurité du Framework .NET pour autoriser les applications, situées sur des partage réseau, à s'exécuter ?

    dimanche 23 mars 2008 14:53
  •  

    Effectivement la version est 1.0 pour VS 2002. Il n'y a pas de message précis seulement Windows qui prévient que l'application ne réponds plus et cherche une solution.

     

    Je n'avais pas pensé regardé dans les logs et effectivement il y a une piste à explorer. Je ne l'ai pas sous la main n'étant pas au travail pour l'instant. Si je me souvient bien c'était un problème DNS system ou un truc de genre. Dés que possible je mettrai à jour cette info.

     

    Oui pour les pc vista les zone intranet ont été mis en full trust.

     

     

    lundi 24 mars 2008 16:55
  •  

    Voila solution trouvée.

     

    Le framework n'était pas bien installé. J'ai suivi les directives trouvées http://blogs.msdn.com/astebner/archive/2007/02/04/error-installing-net-framework-1-0-and-1-1-on-windows-vista-caused-by-data-execution-prevention-dep.aspx

     

    Merci à tous.
    mercredi 9 avril 2008 10:41