none
Extension de Workflow RRS feed

  • Question

  • Bonjour,

    J'essaie actuellement de faire un workflow d'approbation à partir du workflow standard  et en utilisant Sharepoint designer 2010.

    Donc avec l'aide de celui-ci, j'ai bien effectué une copie du Workflow Standard et je l'ai modifié.

    Mon problème réside sur le formulaire d'initialisation au sein duquel j'aimerai que le champ Approvers (Person/Group picker) soit obligatoire. Or lorsque je souhaite configurer ce contrôle sur le formulaire avec Infopath 2010 la propriété "Cannot be blank" est grisée et je ne peux donc pas l'activer.

    J'aimerai donc savoir si cette limitation est normal ou si elle est du au fait que j'utilise la version béta d'InfoPath et SharePoint Designer 2010

     

    Merci

    • Déplacé Hengzhe Li mardi 21 février 2012 07:04 merge forum (Origine :Développement Sharepoint 2010)
    mercredi 16 juin 2010 09:31

Réponses

  • Peux tu vérifier le paramètre de compatibilité de ton formulaire. Dans Fichier -> Informations -> Options de formulaire avancées -> Compatibilité.
    Est ce que le paramètre "Type de formulaire" est réglé sur "Formulaire de navigateur Web (InfoPath 2007)" ? Si oui, place le sur "Formulaire de navigateur Web".

    Attention toute fois, ton formulaire ne sera plus accessible dans Outlook 2007 et antérieur, seulement dans la version 2010. Mais cela ne devrait pas poser de problème puisqu'il s'agit d"un formulaire d'initialisation.

    • Marqué comme réponse Alex Petrescu lundi 5 juillet 2010 07:55
    vendredi 2 juillet 2010 10:14

Toutes les réponses

  • Bonjour

    C'est la propriété expliquée ici qui est grisée ??

    http://blogs.msdn.com/b/infopath/archive/2010/04/08/improvements-to-the-person-group-picker-in-infopath-2010.aspx

     


    Xavier VANNESTE http://www.xvanneste.com http://media.xvanneste.com
    mercredi 16 juin 2010 11:49
    Auteur de réponse
  • Oui c'est bien cette propriété. Mais je pense que le problème vient de SharePoint Designer 2010 car c'est lui que génère le formulaire et je pense qu'il doit lui passer un context qui fait que je ne peux pas changer certaines propriétés, si je n'en suis pas sur.

    Mais merci pour ton lien.

    jeudi 17 juin 2010 09:14
  • as-tu essayé de le retirer et de le recréer ?
    Serge Luca; MVP blog: http://sergeluca.spaces.live.com Devoteam Belgium. http://twitter.com/sergeluca
    jeudi 1 juillet 2010 15:50
  • Peux tu vérifier le paramètre de compatibilité de ton formulaire. Dans Fichier -> Informations -> Options de formulaire avancées -> Compatibilité.
    Est ce que le paramètre "Type de formulaire" est réglé sur "Formulaire de navigateur Web (InfoPath 2007)" ? Si oui, place le sur "Formulaire de navigateur Web".

    Attention toute fois, ton formulaire ne sera plus accessible dans Outlook 2007 et antérieur, seulement dans la version 2010. Mais cela ne devrait pas poser de problème puisqu'il s'agit d"un formulaire d'initialisation.

    • Marqué comme réponse Alex Petrescu lundi 5 juillet 2010 07:55
    vendredi 2 juillet 2010 10:14