none
Problème sur ApplicationHost.config pour IIS 7 RRS feed

  • Question

  • Après avoir installé VS 2010 rc et le framework 4, j'ai relancé aspnet_regiis dans le répertoire v4 pensant que cet utilitaire allait me regénérer le ApplicationHost.config pour le nouveau framework. Je me retrouve avec un fichier ApplicationHost.config dans Windows\Sysytem32\inetsrv\config bourré d'erreurs ?

    <configSections>
            <sectionGroup name="system.applicationHost">
                <section name="applicationPools" allowDefinition="AppHostOnly" overrideModeDefault="Deny" />
                <section name="configHistory" allowDefinition="AppHostOnly" overrideModeDefault="Deny" />

     

    J'ai des 'type missing' et des 'invalid attribute' ....

    J'ai du oublier quelque chose ? Non ?

    Merci.

    lundi 22 mars 2010 17:30

Réponses

  • Si tu n'as pas d'erreur ce doit être ok et seulement VS studio qui ne connait pas de schéma pour valider le xml.

    Si besoin tu peux utiliser l'outil de configuration fournit avec IIS7 : dans la console admin IIS Gestion > Editeur de configuration

    ( voir ici si besoin )

    Cordialement

    • Marqué comme réponse soonia mercredi 24 mars 2010 17:43
    mercredi 24 mars 2010 14:23
    Modérateur

Toutes les réponses

  • Bonjour,

     

    Quels sont les autres versions .NET installées sur votre machine ?

    Quelles options avez-vous utilisé avec aspnet_regiis ?

     

    Cordialement,

    Alex


    Alex Petrescu - MSFT
    mardi 23 mars 2010 10:32
  • Bonjour,

    Les versions 2, 3 et 3.5. J'ai utilisé l'option -i avec aspnet_regiis.

    Lorsque je renomme le fichier ApplicationHost.config il me génère une erreur dans le log (j'ai essayé pour voir si il recréait le fichier).

    Merci.

    mardi 23 mars 2010 11:21
  • Bonjour,

    as tu des erreurs lorsque tu utilises une application web ? Si les erreurs sont celles renvoyées depuis visual studio en ouvrant le fichier, vérifie quel schéma xsd est utilisé ( depuis le menu Xml>schéma ). Il est possible que ce ne soit que des avertissements ou erreurs dus à un fichier xsd qui ne correspond pas au Xml lu.

    Note que si besoin d'un retour en arrière suite à des modificatifions dans le fichier, un historique des fichiers de conf est conservé dans :   C:\inetpub\history

    Cordialement

    mardi 23 mars 2010 13:00
    Modérateur
  • Bonjour nikho,

    J'ai créée une application web sans problèmes, elle s'exécute. Je n'ai fait aucune modifications dans ApplicationHost.config, je n'ai fait qu'installer le framework 4 et l'enregistrer auprès d'IIS 7. Quand j'ouvre ApplicationHost.config dans VS 2010, il m'indique plusieurs erreurs dans la section <ConfigSections> comme quoi la propriété type est manquante alors qu'elle est obligatoire ???

    D'ailleurs si je vais voir le fichier machine.config du framework 4, il y a la même <ConfigSections> sans erreurs.

    Est ce un problème d'installation ?

    Merci.

    mercredi 24 mars 2010 13:12
  • Si tu n'as pas d'erreur ce doit être ok et seulement VS studio qui ne connait pas de schéma pour valider le xml.

    Si besoin tu peux utiliser l'outil de configuration fournit avec IIS7 : dans la console admin IIS Gestion > Editeur de configuration

    ( voir ici si besoin )

    Cordialement

    • Marqué comme réponse soonia mercredi 24 mars 2010 17:43
    mercredi 24 mars 2010 14:23
    Modérateur