locked
[Platform Builder 5.0] Où est passé Kdstub ? RRS feed

  • Question

  • Bonjour,

    Il y a quelque temps, j'ai fait une image avec Platform Builder 5.0. A l'époque, je pouvais sélectionner dans Target/Connectivity Options/Debugger l'option Kdstub qui me permettait de faire du debug de mon image via Ethernet.

    Or maintenant, l'option "debugger" est vide... et je ne peux déboguer mon image.
    J'ai fais plusieurs essais en Debug et en Release, mais lorsque je cherche à deboguer, j'ai le message suivant sur ma liaison série de debug :
    Waiting for service 'KDBG' to connect..., fUseSysCalls = 0
    et du côté PB 5.0 :
    Starting kernel debugger software probe (KdStub) - KD API version 18
    >>> Loading module NK.EXE at address 0x80100000-0x801C1000 (RW data at 0x81086000-0x810E725F)

    Mes "Build options" dans "Platform settings" sont :
     - Enable CE Target Control Support (SYSGEN_SHELL=1)
     - Enable Eboot Space in Memory (IMGEBOOT=1)
     - Enable Full Kernel Mode (no IMGNOTALLKMODE=1)
     - Enable Kernel Debugger (no IMGNODEBUGGER=1)
     - Enable KITL (no IMGNOKITL=1)

    Ma liaison fonctionne bien puisque je peux uploader mon image dans ma cible (PXA270).

    Quelqu'un a une idée pour que je puisse deboguer mon image ?

    Merci d'avance


    [EDIT]
    Dans ma fenêtre de debug de PB 5.0, j'ai aussi les messages suivants :
    Warning:  Debugger service map is set to none.  If your image has debugging support it may not boot properly.
    Cannot access selected Device from service host.
    Debugger could not initialize connection.
    The Kernel Debugger is waiting to connect with target.
    The Kernel Debugger has been disconnected successfully.

    vendredi 18 janvier 2008 15:36

Réponses

  • Bonjour,

    Je me réponds à moi-même...

    J'ai tout désinstallé (PB 5.0, les BSP, les SDK), j'ai fait le ménage dans la base de registres et enfin tout réinstallé... Finalement tout est revenu dans l'ordre et je peux déboguer à nouveau mon image.

    Une journée de perdue...

    Merci à ceux qui ont pris le temps de lire mon post.
    mardi 22 janvier 2008 14:50