none
VS 2010 Pro - Application VB Net qui redémarre toute seule RRS feed

  • Discussion générale

  • Bonjour,

    Sur mon PC uniquement, mes applications VB.Net redémarrent tout seul.

    Même après réparation de VS SP 1 et VS 2010 Pro et reboot, le bug persiste.

    Même si je fais 1 nouveau projet VB Windows Form, je l'enregistre, et je génère immédiatement en mode Release, le bug est également présent.

    Je lance le fichier exe dans le répertoire bin\release, la fenêtre Form1 apparaît normalement, et au bout d'environ 13 secondes, l'application se ferme et se relance aussitôt.

    Je ne trouve strictement rien sur internet concernant ce problème.

    A noter que ce bug ne se produit pas ni sur d'autres PC sur lesquels mes applications sont installées, ni sur mon PC quand j'exécute le programme dans l'environnement VB.

    Même si ce bug n'est pas des plus gênants, j'aimerai trouver comment le régler, sans avoir à réinstaller Windows 7 Pro.

    Merci d'avance pour votre aide,

    Stéphane.

    PS : les modules VB et C++ sont installés sur mon PC pour VS 2010 Pro, ainsi que le module VB de VS 2013 Express.

    mercredi 1 avril 2015 15:45

Toutes les réponses

  • Bonjour,

    Le fait de faire des nouvelles installatiosn ne solutionne pas forcement les problèmes lier. Avez vous supprimé les résidus de fichiers (fichiers temp, dossier VS dans ProgramFiles, le ou les fichiers de config VS ) entre les réinstallations ?

    Je commencerais par initialiser la configuration de VS, vous devriez avoir une options initialisation dans le menu tools


    Cordialement,

    mercredi 1 avril 2015 19:34
    Auteur de réponse
  • Merci Troxsa.

    Je n'ai pas désinstallé puis réinstallé mais réparé.

    Je n'avais pas supprimé les fichiers temporaires avant.

    Par contre, je regarderai l'outil d'initialisation demain matin.

    Stéphane

    mercredi 1 avril 2015 21:22
  • Bonjour,

    J'ai réinitialisé les paramètres comme décrit dans la procédure MSDN, fermé et relancé VS, créé 1 nouveau projet, enregistré, compilé en mode Release, et le bug persiste.

    C'est quand même 1 drôle de bug que j'ai. Je pense qu'il faudrait que je désinstalle VS 2010 Pro avec le SP, la version 2013 Express, les Framework, rebooter, nettoyer les temps et autres fichiers à débusquer, pour ensuite tout réinstaller... mais ça fait vraiment beaucoup de temps pour 1 résultat pas si garanti que ça alors que le bug n'est que mineur et que sur mon PC (et hors de l'environnement VB). Le formatage aurait sûrement 1 résultat positif, mais cela prend trop de temps également pour remettre toutes mes app pour 1 si petit bug.

    Par contre, si 1 personne peut avoir 1 idée qui serait plus rapide à tester, je suis toujours preneur.

    Merci. Et bonne journée.

    jeudi 2 avril 2015 08:39
  • Bonjour

    Désolé pour vous, mais il va falloir faire un choix a un moment donné ...
    avez vous essayer de trouver des mises a jour pour VS ?


    Cordialement,

    jeudi 2 avril 2015 19:34
    Auteur de réponse
  • Bonjour Troxsa,

    Tout à fait, le choix est fait, je garde ce bug mineur et ne perd plus de temps avec ca :)

    VS est bien à jour.

    Merci encore et bonne journée.

    lundi 13 avril 2015 09:43