none
Compilation/Build d'un Site Web RRS feed

  • Question

  • Bonjour,
    depuis quelques temps, le build/rebuild de notre site web (sous VS2005 Team Edition) s'effectue uniquement sur le répertoire App_Code, alors que nous avons beaucoup d'autres répertoires avec des controles ascx et des classes C# & VB (.cs + .vb).
    Du coup, impossible de voir toutes les erreurs de compilations autrement que durant l'exécution du site web, ce qui est très pénalisant pour une appli web de plusieurs milliers de lignes de code !
    On a eu beau chercher dans toutes les options/propriétés du projet (site web) et de Visual Studio : rien n'y fait !

    Quelqu'un connait-il la marche à suivre pour forcer le build sur tout les répertoires du site web ?!
    Merci,

    Julien.

    mardi 25 novembre 2008 10:00

Réponses

  • Bonjour,

    Pour éviter ce genre de problème, je vous conseille d'utiliser plustôt les "Application Web" au lieu des "Sites Web". (Utilisable à partir du SP1 de Visual Studio).

    Cordialement
    Gilles TOURREAU - MVP C#
    dimanche 21 juin 2009 14:51
    Modérateur

Toutes les réponses

  • Bonjour,

     

    depuis quelques temps, le build/rebuild de notre site web (sous VS2005 Team Edition) s'effectue uniquement sur le répertoire App_Code

    C'est à dire ? Que se passe-t-il ensuite ?

     

    Avez vous téléchargé et installé le SP1 de Visual Studio 2005 ?

     

    Cordialement

     

    jeudi 27 novembre 2008 21:39
    Modérateur
  • Bonjour,
    oui le SP1 de VS2005 est installé.
    Pour être plus précis, par exemple nous avons un répertoire "admin" à la racine du projet qui contient tous les user controls d'admin (backoffice) de notre site web, et si on modifie un ou plusieurs de ces controls, la compilation se fait uniquement sur le répertoire App_Code. En fait, il compile systématiquement QUE le répertoire App_Code. Mais ce comportement est récent : auparavant il recompilait TOUT le site web.
    Donc je me doute que ça doit être un setting sous VS2005, mais quoi et ou ?

    Cdlt

    jeudi 4 décembre 2008 09:20
  • Bonjour,

    Pour éviter ce genre de problème, je vous conseille d'utiliser plustôt les "Application Web" au lieu des "Sites Web". (Utilisable à partir du SP1 de Visual Studio).

    Cordialement
    Gilles TOURREAU - MVP C#
    dimanche 21 juin 2009 14:51
    Modérateur