none
Workflow + wspbuilder, vsewss11 & VS2005 -> project type not supported RRS feed

  • Question

  • Bonjour,

    Voila j'essaie de créer un workflow avec les extensions pour visual studio 2005, que ça soit avec wspbuilder ou vsewss, j'obtiens le même message d'erreur lorsque je crée ce type de projet :
    "The project type is not supported by this installation."

    Tous les autres types de projets se créent sans problèmes :?

    Qqun à une idée ? Je n'ai rien vu de tel sur codeplex dans les issues.

    Merci d'avance !
    mercredi 30 avril 2008 07:35

Réponses

  • J'allais justement vous répondre avant de voir votre EDIT. Les extensions Visual Studio ne sont pas liées au SDK SharePoint, et les extensions WF ne sont pas périmées.

     

    Pour rappel donc, en cas de problème :

    - vérifier que les extensions sont bien installées

    - vérifier qu'il n'y a pas de pb avec des langues différentes

    lundi 5 mai 2008 06:45
    Modérateur

Toutes les réponses

  • En attendant j'ai utilisé STSDEV pour générer ma solution SP Workflow
    (oui ça fait vraiment celui qui veut pas tout faire à la main Stick out tongue)

    Mais de toute façon rien n'y fait, je crois que j'ai pas la partie WWF installée Tongue Tied je vais regarder de ce coté la

    Il faut peut être le service pack 1 de VS 2005
    mercredi 30 avril 2008 09:40
  • Bonjour,

     

    A priori il s'agit d'un bug connu qui se résout avec une seule ligne de commande :

    Code Snippet

     

    devenv /setup

     

     

     

    source : http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=931459&SiteID=1

    mercredi 30 avril 2008 10:10
  • Yep, mais cela ne fonctionne pas chez moi
    mercredi 30 avril 2008 10:22
  • Faites attention aux versions Visual Studio et à celles de ses extensions. Afin d'éviter tou problème, utilisez VS et les extensions dans les mêmes langues (idéalement tout en version EN, même si les extensions SharePoint sont sorties en VF récemment).

     

    Et bien sûr, les extensions pour WF sont indispensables.

     

    Votre problème provient soit des extensions WF manquantes, soitd'un problème de langue.

    samedi 3 mai 2008 14:03
    Modérateur
  • Bonjour,

    Je travail uniquement avec des versions EN.
    J'ai peut être eu une piste, j'ai d'abord installé le SDK 1.3 sharepoint avant visual studio 2005.
    J'ai tout désinstallé, et je reinstalle vs en premier puis le sdk pour voir ...

    Sinon les extensions WF j'en ai vu sur le site de microsoft download mais c'est périmé, il faut utilise le sdk sharepoint.


    EDIT:

    Voilà j'ai réussis, en fait quand j'ai vu que ça ne marchait pas j'ai effectivement télécharger les extensions ( http://www.microsoft.com/downloads/details.aspx?FamilyId=5D61409E-1FA3-48CF-8023-E8F38E709BA6&displaylang=en )
    Mais l'installation ne fonctionnait pas. En fait il y avait un problème avec une feature que j'ai installé (sp RateField).
    Maintenant après une réinstallation de tout au propre, cette extensions est parfaitement bien installée et je peux effectivement créer mon WorkFlow SharePoint.


    lundi 5 mai 2008 05:49
  • J'allais justement vous répondre avant de voir votre EDIT. Les extensions Visual Studio ne sont pas liées au SDK SharePoint, et les extensions WF ne sont pas périmées.

     

    Pour rappel donc, en cas de problème :

    - vérifier que les extensions sont bien installées

    - vérifier qu'il n'y a pas de pb avec des langues différentes

    lundi 5 mai 2008 06:45
    Modérateur
  • Oui voilà, c'est moi qui ai fait un raccourcis en disant que c'était périmé au vu de l'installation qui refusait de s'installer + la date de publication des extensions + la nécéssitée d'avoir le sdk.

    Tout fonctionne bien, merci :-)

    ps: je vais valider votre dernière réponse, ça pourrait en aider d'autres :-)
    lundi 5 mai 2008 07:02