none
Problème MSBuild RRS feed

  • Question

  • Bonjour,

    Je suis confronté à un message d’erreur dans Visual studio, lorsque je démarre une publication-> Web Deploy Package :
    Ci-dessous une capture d'écran.

    - L’erreur est reproduite également en exécutant directement MSBuild en ligne de commande (voir les log joints : msbuild.log et msbuild_diag.log (mode diagnostic de msbuild) )
    - Visual Studio et MSBuild ont été exécutés avec un profil administrateur
    - Le problème n’est pas lié à  un projet en particulier : j’ai créé une application WebForm vide, dans un répertoire quelconque, avec le même résultat.
    - Il s’agit de Visual Studio 2013 Pro, sous Windows 7 Pro, .Net Framework 4.0/4.5.1 installés

    Pourriez-vous m'aider?
    Merci d'avance
    Davide Usai

    lundi 14 avril 2014 08:27

Réponses

  • J'avais effectivement déjà tenté une réparation de Visual Studio, sans succès.

    Avec Process Monitor, je détecte un "ACCESS DENIED" pour le process "MSBuild.exe", Opération "RegOpenKey" sur la clé "HKCR\.Master" (Desired Access: Read).

    En comparant avec la configuration d'un collègue, pour les autorisations de la clé en question., il s'est avéré que le groupe "Administrateurs" n'y avait aucun droit. En ajoutant "Contrôle total", cela semble résoudre le problème.

    Merci pour votre aide, qui m'a permis d'identifier la source de mon dysfonctionnement.

    Bonne journée,
    bien cordialement,
    Jérôme Kramer.

    • Marqué comme réponse Aurel Bera mercredi 16 avril 2014 09:07
    mercredi 16 avril 2014 08:50

Toutes les réponses