none
Activer Fonction Recherche dans Sharpoint RRS feed

  • Question

  • Bonjour à tous,

    Voilà nous avons Sharepoint dans notre entreprise et je remarque en haut à droite qu'il y a la fontion recherche mais quand je saisis qqchose j'ai le message suivant:

    D'après moi cette fonction n'a jamais été activé .... Commen faire pour activer la fonction recherche sous Sharepoint ?

    Citation:
    Aucun résultat correspondant à votre recherche n'a été trouvé.
    Vérifiez l'orthographe. Les mots de votre requête sont-ils correctement orthographiés ?
    Essayez d'utiliser des synonymes. Des mots légèrement différents sont peut-être utilisés pour ce que vous recherchez.
    Faites une recherche plus générale. Essayez de remplacer les termes spécifiques par des termes plus généraux.
    Essayez d'effectuer la recherche dans une autre étendue. Des étendues différentes peuvent renvoyer des résultats différents.
    Merci d'avance
    jeudi 12 mars 2009 13:50

Réponses

Toutes les réponses

  • Bonjour,

    Le message indique que votre recherche fonctionne mais qu'aucun résultat n'est retourné. Celà peut provenir du fait que vos sites ne sont pas indexés. Pouvez vous :

    • Indiquer si vous utilisez MOSS ou WSS
    • Communiquer l'URL de la page indiquant le message (c'est les deux dernières parties de l'URL qui m'interessent)

    Celà permettra de vous donner plus d'information sur l'origine du problème.

    Outre ce point, vous pouvez vous connecter à la Console d'Administration Centrale de SharePoint pour :

    • Planifier l'indexation
    • Définir les sources de contenu et les étendues de recherche (seulement sous MOSS)

    Je pourrais vous dire exactement quoi faire une fois que j'aurai les détails.


    http://blogs.developpeur.org/gribouillon/
    jeudi 12 mars 2009 14:29
    Modérateur
  •  Bonjour et merci pour la réponse

    - WSS
    - /searchresults.aspx?k=vente&u=http%3A%2F%2Fvicques%3A90

    Oui j'arrive à me connecter à la console d'Administration Centrale mais ensuite c'est un peu la galère

    Merci de votre aide
    jeudi 12 mars 2009 15:15
  • Ok,

    puisque vous êtes sous WSS ca devrait être plus simple.

    Sous l'onglet "Operations", accédez aux Services (première ou seconde ligne).
    Dans les services, repérez celui lié à la recherche WSS.
    Vérifiez que l'indexation est active et la plage horaire d'indexation est cohérente.

    En ligne de commande, tapez stsadm -o spsearch -action fullcrawlstart
    Si la commande n'est pas reconnue, préfixez là par "c:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\bin\" (remplacez "Common Files" par "Fichiers Communs" si vous êtes sur une version française)

    Laissez le temps à l'indexation de se faire et ça devrait être bon.


    http://blogs.developpeur.org/gribouillon/
    jeudi 12 mars 2009 18:04
    Modérateur
  • Bonjour,

    Je suis allé sous l'onglet opération ensuite j'ai accédé à service selon prnt screen ci-dessous

    service

    Puis j'ai le tableau suivant (prnt screen) qui apparaît mais je ne vois pas ou est indiqué indexation active et quant à la plage horaire cohérente qu'entendez-vous par là

    indexation

    Pour la ligne c:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\bin\" (remplacez "Common Files" par "Fichiers Communs" si vous êtes sur une version française) j'ai bien ça....

    Le temps d'indexation dure combien de temps... Est-ce qu'il faut le faire en lorsque les users ne sont pas là ?

    Merci encore de votre aide

    vendredi 13 mars 2009 07:27
  • Après avoir cliqué sur "services sur le serveur" vous verrez la liste des services disponibles. Si vous êtes en batterie de serveurs, sélectionnez le serveur adéquat à l'aide de la liste déroulante (en jaune avec MOSS2007-WFE2 ci dessous). Cliquez sur le bouton radio "Personnalisé" pour avoir la liste complète des services.

    Repérez ensuite la ligne "Recherche Windows SharePoint Services" et cliquer sur le lien "Démarrer" situé à côté. (Arrêtez le service s'il est déjà démarré, puis redémarrez le).

    Services


     
    Sur l'écran qui suit, renseignez les paramètres d'accès (compte d'accès, serveur et base de données), puis planifiez l'indexation avec les éléments situés en bas de page.


    Paramétrage de l'indexation WSS


    http://blogs.developpeur.org/gribouillon/
    dimanche 15 mars 2009 23:04
    Modérateur
  • Bonjour,

    Merci pour votre réponse...

    Effectivement selon mon prnt screen tout est déjà démarrer mais je vais arrêter le service recherche et le redémarrer selon vos conseils

    Ok concernant la "Planification d'indexation" y-a-t'il un paramètrage particulier à faire afin de ne pas indexer sans arrêt ?
    Votre paramétrage "Toutes les heures entre 55 et 55 minutes après l'heure" ?

    Faut-il faire ces opérations en soirée afin de ne pas gêner l'utilisation de Sharepoint ?

    Afin d'éviter que je ne lance l'indexation et que Sharepoint ne soit plus utilisable la journée pendant des heures....

    Merci
    lundi 16 mars 2009 06:14
  • Le paramétrage de la capture d'écran est celui par défaut et permet l'indexation des documents.

    De manière générale, préférez les opérations en soirées. Je ne peux pas vous le confirmer ici (dans le cas de MOSS, un stop de l'indexation implique une réindexation full, ce qui peut prendre pas mal de temps. J'aurais tendance à voir ça moins conséquent avec WSS mais je ne peux pas vous le confirmer).
    http://blogs.developpeur.org/gribouillon/
    lundi 16 mars 2009 10:37
    Modérateur
  • Votre prnt-screnn donc toutes les heures entre 55 et 55 minutes après l'heure

    Car sur notre print-screnn (voir mon post) il indiqué toutes les 5 minutes ) mais ça parait un peut trop non ?

    Donc si je récapitule:

    1° j'arrête et redémarre le service de recherche
    2° vous indiquez "Vérifiez que l'indexation est active et la plage horaire d'indexation est cohérente" donc pour le faire immédiatement pour faire la première indexation je devrais laisser les 5 minutes que j'ai par défaut
    3° Est-ce que Sharepoint indique un message une fois l'indexation terminée ? afin de faire la dernière opération (no 4)
    4° En ligne de commande, tapez stsadm -o spsearch -action fullcrawlstart
    Si la commande n'est pas reconnue, préfixez là par "c:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\bin\" (remplacez "Common Files" par "Fichiers Communs" si vous êtes sur une version française)

    Si vous avez encore un instant pour l'autre post
    autre post

    Merci encore

    lundi 16 mars 2009 13:21
  • C'est ça. Que vous indiquiez toutes les 5 mn ou comme sur l'écran, vous devriez voir le résultat rapidement. A partir du moment ou celà fonctionne, il est inutile de taper la commande stsadm -o spsearch...

    N'oubliez pas de valider la/les messages du forum qui répondent à la question et de marquer les posts comme "utiles" lorsque ça a été le cas.
    Je regarde l'autre post.
    http://blogs.developpeur.org/gribouillon/
    lundi 16 mars 2009 22:06
    Modérateur
  • Bonjour,

    Je ferai l'essai ce soir....
    Mais comme on ne fait pas forcément des documents tous les heures je pourrais lessai l'indexation "Tous les jours Entre 20h00 et 20h30 par exemple" ?

    Si je redémarre mon service de recherche puis planifie l'indexation "Tous les jours Entre 20h00 et 20h30 par exemple" et que je fais démarrer la première indexation commencerait ce soir dès 20h00 non ?

    Ah ok je savais pas que si la recherche fonctionnait qu'il ne fallait pas lancer la commande "stsadm -o spsearch..."

    Elle sert à quoi cette commande d'ailleurs ?

    Merci
    mardi 17 mars 2009 06:48
  • Je vous conseille de laisser l'indexation par défaut.

    La commande stsadm -o spsearch est détaillée ici : http://technet.microsoft.com/fr-fr/library/cc288507.aspx

    J'insiste sur la validation des messages et la notation "utile" car ça fait parti du fonctionnement du forum. Les personnes qui répondent peuvent y passer beaucoup de temps (comme c'était le cas pour moi sur ce post avec les captures d'écran) et le font bénévolement... la validation ne vous demande que quelques secondes. Merci d'y penser.


    http://blogs.developpeur.org/gribouillon/
    mardi 17 mars 2009 10:54
    Modérateur
  • Oui je vais valider les messages avec la notation "utile" ...

    Je pensais le faire demain matin après avoir testé ce soir ce redémarrage du service et indexation.

    Oui je suis bien conscient de l'aide que vous m'apportez et je vais valider ce post demain matin.

    Est-ce ok comme ça ?

    Merci
    mardi 17 mars 2009 13:34
  • Je viens de faire l'essai donc j'ai arrêter le service puis cliquez sur démarrer mais j'ai le message qui apparaît:

    WSS_Search_xxx sur xxx contient un schéma défini par l'utilisateur. Les bases de données doivent être vides avant d'être utilisées. Supprimez toutes les tables, toutes les procédures stockées et tous les autres objets ou utilisez une autre base de données.

    Donc mon service maintenant est arrêté ....

    Aie....

    Est-ce que je dois lancer la commande stsadm -o spsearch -action fullcrawlstart ?

    La comande ci-dessus me donne l'erreur: Eche de l'action "Fullcrawlstart" La référence d'objet n'est pas définie à une instance d'un objet

    Merci de votre aide

    PS: Je remarque également dans mon observateur d'événement l'erreur suivante qui apparaît plusieurs fois par jour et apparemment depuis longtemps:

    Type de l'événement : Erreur
    Source de l'événement : Windows SharePoint Services 3 Search
    Catégorie de l'événement : Rassembleur
    ID de l'événement : 2424
    Date :  04.01.2009
    Heure :  17:40:02
    Utilisateur : N/A
    Ordinateur : xxxx
    Description :

    Impossible de démarrer la mise à jour car les sources de contenu sont inaccessibles. Corrigez les erreurs et essayez à nouveau d'effectuer la mise à jour.

    et

    Type de l'événement : Erreur
    Source de l'événement : Windows SharePoint Services 3
    Catégorie de l'événement : Base de données
    ID de l'événement : 3759
    Date :  18.03.2009
    Heure :  13:53:53
    Utilisateur : N/A
    Ordinateur : VICQUES
    Description :
    La base de données « WSS_Search_VICQUES » sur l'instance SQL Server « VICQUES » n'est pas vide et ne correspond pas au schéma de base de données actif.


     

    mardi 17 mars 2009 19:48
  • Indiquez une autre base de données en démarrant le service (renommez là en "WSS_Search_VICQUES_DB" par exemple).

    Merci de penser à la validation des réponses.
    http://blogs.developpeur.org/gribouillon/
    mercredi 18 mars 2009 23:33
    Modérateur
  • Donc je dois indiquez une autre bd mais dans le paramètrage de l'indexation c'est ça ?

    Paramétrage de l'indexation WSS

    Je dois pas renommez la bd ailleurs c'est juste pour l'indexation ?

    Et dans cette partie des paramètres d'accès je dois indiquer obligatoirerement les mots de passes car il m'indique un message que les mots de passes seront vu en clair...

     

    PS: Je vais valider une de vos réponses mais j'aurais voulu pouvoir réglé mon problème; est-ce que ça va comme ça ?
    comme j'ai fait pour ma question sur les droits sur un document d'une bibliothèque

    jeudi 19 mars 2009 05:51
  • Oui, changez juste le nom de cette base. Le message d'erreur vous indique qu'il ne peut pas réutiliser la même.

    En ce qui concerne la sécurité, restez en authentification intégrée.

    Pour la validation, assurez vous que celà fonctionne avant de valider les messages. Les posts peuvent par contre être marqués comme utiles s'il vous ont permis de mieux comprendre ou d'avancer, même si vous n'avez pas encore la solution.
    http://blogs.developpeur.org/gribouillon/
    jeudi 19 mars 2009 08:06
    Modérateur
    1. J'ai fait l'essai mon service est bien démarré maintenant mais ma recherche m'indique toujours l'erreur suivante 

    "Impossible d'effectuer la recherche car ce site n'est affecté à aucun indexeur. Contactez votre administrateur pour plus d'informations."

    Le fait d'avoir mis un autre nom me créer une autre bd non ?

    Je devrais lancer la commande stsadm -o spsearch -action fullcrawlstart ?

    JE vois également dans l'observateur d'événement l'erreur

    Type de l'événement : Erreur
    Source de l'événement : Windows SharePoint Services 3 Search
    Catégorie de l'événement : Rassembleur
    ID de l'événement : 2424
    Date :  19.03.2009
    Heure :  09:45:00
    Utilisateur : N/A
    Ordinateur : VICQUES
    Description :
    Impossible de démarrer la mise à jour car les sources de contenu sont inaccessibles. Corrigez les erreurs et essayez à nouveau d'effectuer la mise à jour.

    Contexte : application « Fichier », catalogue « d'index de recherche sur le serveur de recherche Search »

    Je remarque maintenant dans "Gestion des applications" Base de données de contenu l'option suivante 

    base de données

    Je dois certainement sélectionner ma bd vicques non ?

     Ah ok marquer comme réponse valide le post définitivement et la publication était utile c'est pour les post utiles

    Merci
    jeudi 19 mars 2009 08:40
  • Votre service de recherche est correctement démarré donc. Il vous reste à l'associer à des bases de données de contenu. Connectez vous à la console d'administration centrale puis cliquez sur l'onglet "Gestion des applications". Cliquez ensuite sur le lien "Bases de données de contenu" comme ci dessous :

    Gestion des applications & Bases de données de contenu


    Assurez vous d'avoir sélectionné la bonne application Web (dropdownlist en haut à gauche) puis cliquez sur la (ou les) base(s) de données de contenu comme ci dessous :

    Séléction de la base de données de contenu


    Pour chacune des bases, sélectionnez le serveur de recherche : vous trouverez dans cette dropdownlist tous les serveurs pour lesquels le service de recherche est démarré.

    Sélection du serveur de recherche



    http://blogs.developpeur.org/gribouillon/
    jeudi 19 mars 2009 09:17
    Modérateur
  • Je viens de faire l'essai et j'ai le message suivant qui réapparaît:

    Aucun résultat correspondant à votre recherche n'a été trouvé.
    1. Vérifiez l'orthographe. Les mots de votre requête sont-ils correctement orthographiés ?
    2. Essayez d'utiliser des synonymes. Des mots légèrement différents sont peut-être utilisés pour ce que vous recherchez.
    3. Faites une recherche plus générale. Essayez de remplacer les termes spécifiques par des termes plus généraux.
    4. Essayez d'effectuer la recherche dans une autre étendue. Des étendues différentes peuvent renvoyer des résultats différents.

    Dans mon observateur d'événement j'ai les deux erreurs suivantes:

    Type de l'événement : Avertissement
    Source de l'événement : Windows SharePoint Services 3 Search
    Catégorie de l'événement : Rassembleur
    ID de l'événement : 2436
    Date :  19.03.2009
    Heure :  10:25:00
    Utilisateur : N/A
    Ordinateur : xxx
    Description :
    Impossible d'analyser l'adresse de démarrage <sts3://vicques:90/contentdbid={b04a7113-4907-4163-b800-1b4f84932eb8}>.

    Contexte : application « Fichier d'index de recherche sur le serveur de recherche », catalogue « Search »

    Détails :
      (0x80131534)

    et

    Type de l'événement : Erreur
    Source de l'événement : Windows SharePoint Services 3 Search
    Catégorie de l'événement : Rassembleur
    ID de l'événement : 2424
    Date :  19.03.2009
    Heure :  10:25:00
    Utilisateur : N/A
    Ordinateur : VICQUES
    Description :
    Impossible de démarrer la mise à jour car les sources de contenu sont inaccessibles. Corrigez les erreurs et essayez à nouveau d'effectuer la mise à jour.

    Contexte : application « Fichier », catalogue « d'index de recherche sur le serveur de recherche Search »

    jeudi 19 mars 2009 09:23
  • Je veux bien vous aider, mais merci de me dire :

    • Que tout ce qui a été marqué précédemment ne vous a servi à rien, même à comprendre.

    ou

    • Que ce qui a été marqué précédemment a été utile (et dans ce cas cliquez sur l'étoile "La publication a été utile")

     

    Pour continuer sur votre problème, assurez vous que le compte utilisé par le service de recherche (celui de l'authentification Windows dont nous avons déjà parlé) a bien les droits d'accès sur la base de données de contenu. Cette vérification se fait sur le serveur SQL.


    http://blogs.developpeur.org/gribouillon/
    jeudi 19 mars 2009 09:51
    Modérateur
  • J'ai indiqué trois de vos post comme "publication utile".

    Je pensais remplir tout à la fin de mon problème désolé.

    Dans mon cas le compte utilisé par le service de recherche est lequel ? C'est celui qui se connecte à Sharepoint ?
    Dslé mais j'ai un doute....

    Sur le serveur SQL et ou exactement si je peux vous demander ?

    PS:
    En faisant des recherches je suis tombé là-dessus concernant mon message dans l'observateur d'événement erreur 2424

    "en fait j'ai utilisé le même compte pour l'accès au contenu que celui pour le compte de service, qui est un compte utilisateur du domaine (pas admin du dom) et qui est dans le groupe Administrateur local de mon serveur WSS (pour rappel le serveur SQL et sur un autre serveur : mode batterie avec SQL 2005)
     
    Voilà ça marche, truc de malade j'ai cru péter un plomb LOL"

    ça doit être un problème de compte utilisé non ?

    jeudi 19 mars 2009 10:21
  • Je reviens à la charge...

    En cherchant dans Microsoft SQL je remarque que dans la liste des bases de données se trouve celle qui s'appelle WSS_Content (donc bd contenu c'est juste ?).

    Dans cette base WSS_Content puis dans Sécurité et Utilisateurs ne se trouvais pas l'utilisateur Recherwss. Donc je l'ai rajouté mais j'ai encore une question .

    1° Selon le print screnn ci-dessous dois-je cocher qqchose de supplémentaire ?

    WSS_Content

    2° Et après avoir valider doit-on redémarrer Base de données SQL (je crois mais je demande confirmation)
    jeudi 19 mars 2009 13:05
  • Si le compte utilisé par la recherche est db_owner c'est largement suffisant (vous n'avez besoin que de db_datareader sur cette base WSS_Content).

    Le compte utilisé est celui spécifié sur l'écran de démarrage du service de recherche.

    PS : inutile de redémarrer le service SQL.
    http://blogs.developpeur.org/gribouillon/
    jeudi 19 mars 2009 13:36
    Modérateur
  •  C'est le compte d'accès au contenu c'est ça ?

    Donc d'après mon prnt screen le compte utilisateur Recherchewss serait le compte utilsé pour la recherche.

    le compte db_owner vient automatiquement coché .... mais je devrais cocheé de_datareader ?

    Dans schéma je ne dois rien cocher c'est juste dans membre du rôle que je dois cocher qqchose ?
    jeudi 19 mars 2009 13:51
  • Oui. Par contre inutile de cocher datareader, vous avez même plus de droits.

    Petite question pour la forme : vous avez bien des données sur votre site ? Vous confirmez qu'il y a quelque chose à indexer ?
    http://blogs.developpeur.org/gribouillon/
    jeudi 19 mars 2009 14:20
    Modérateur
  • Ok... je laisse comme l'image ci-dessous...

     Par contre dans Shéma par défaut je ne devrait pas mettre autre chose que xxx/Recherchewss ?

    Je ne dois rien cocher dans "Schémas appartenant à un rôle



    Oui nous avons plusieurs sites avec des bibliothèques de documents word / excel ainsi que d'autre bibliothèques.

    Mais nous devons dire à Sharepoint quand nous faisons des bibliothèques de documents qu'il faut indexer ces documents ou il fait ça tout seul ?

    jeudi 19 mars 2009 14:43
  • A moins que vous n'ayez décoché la demande d'indexation, elle se fait par défaut.
    http://blogs.developpeur.org/gribouillon/
    jeudi 19 mars 2009 15:00
    Modérateur
  • pour rappel la lLa demande d'indexation se trouve ou ?

    concernant mon prnt-screen  dans Shéma par défaut je ne devrait pas mettre autre chose que xxx/Recherchewss ?

    Je ne dois rien cocher dans "Schémas appartenant à un rôle" ?
    uniquement cocher db_owner dans Membres du rôle ?

    Merci de vos réponses


    PS: j'ai essayer à nouveau stsadm -o spsearch -action fullcrawlstart

    J'ai eu le message opération fait avec succès mais assez rapidement donc a t'il indexé qqchose ?

    La recherche ne fonctionne toujours pas

    jeudi 19 mars 2009 15:03
  • Au niveau de chaque liste : l'écran d'administration de liste / bibliothèque vous permet d'indiquer si la liste doit être indexée ou non (propriété NoCrawl sur les objets SPList depuis le modèle objet)
    http://blogs.developpeur.org/gribouillon/
    jeudi 19 mars 2009 18:43
    Modérateur
  • Comme par exemple dans cette liste là (voir encadré en rouge)

    index

    Pouvez-vous encore répondre à ces questions:

    concernant mon prnt-screen  dans Shéma par défaut je ne devrait pas mettre autre chose que xxx/Recherchewss ? Je ne dois rien cocher dans "Schémas appartenant à un rôle" ?
    uniquement cocher db_owner dans Membres du rôle ?

    Sinon je vois plus vraiment que faire ?

    Au niveau d'IIS il y a qqchose peut-être à faire ?

    J'ai toujours cette erreur dans mon observateur d'événement

    Type de l'événement :    Erreur
    Source de l'événement :    Windows SharePoint Services 3 Search
    Catégorie de l'événement :    Rassembleur
    ID de l'événement :    2424
    Date :        19.03.2009
    Heure :        20:45:00
    Utilisateur :    N/A
    Ordinateur :    VICQUES
    Description :
    Impossible de démarrer la mise à jour car les sources de contenu sont inaccessibles. Corrigez les erreurs et essayez à nouveau d'effectuer la mise à jour.

    Contexte : application « Fichier », catalogue « d'index de recherche sur le serveur de recherche Search »

    jeudi 19 mars 2009 19:48
  •  Pour l'option activant/désactivant l'indexation des listes/bibliothèques, c'est exactement ça.

    Rien de particulier à faire côté IIS.

    Il vous reste cependant un problème, et c'est visiblement un problème de droit. Et effectivement, j'ai tendance à penser à un problème d'accès à la base de contenu par le compte réalisant l'indexation... ce qui pourtant vient d'être vérifié.

    Retournez sur SQL Server et consultez les propriétés de la base de données de contenu. Vérifiez les autorisations assignés sur cette base, et assurez vous que le compte xxx\recherchewss a bien les droits de lecture.


    http://blogs.developpeur.org/gribouillon/
    vendredi 20 mars 2009 11:58
    Modérateur
  • Ok bon comme je laisse toujours par défaut donc le contenu devrait être indexé.

    Oui effectivement il doit y avoir un problème de ce côté là.

    Pouvez-vous vérifier les points 3 points suivants sur mon prnt screen  afin d'éliminer d'éventuelles erreurs que j'aurais faites

    compte recherche

    1° Le compte de service doit être un compte Administrateur du serveur ou se trouve la base de données c'est juste ?

    2° Le compte d'accès au contenu doit être un compte différents du compte de service. Donc dans mon cas le compte Recherchewss est un compte que j'ai créé dans AD donc c'est bien juste ?

    3° Pour le nom de la base de données ça ne doit pas être WSS_Content ?

    C'est un peu flou les différences entre le compte service et compte d'accès ?

    Maintenant dans SQL

    Voici une copie de mes bases de données

    Sql

    le droit de lecteur c'est uniquement db_owner ?

    vendredi 20 mars 2009 14:35
  • Bonjour auriez-vous du temps aujourd'hui pour mon dernier post...

    Merci
    lundi 23 mars 2009 06:13
  • Bonjour,

    je ne vois pas d'erreur sur votre capture d'écran WSS. Je n'ai pas assez de détail pour la partie SQL par contre.

    Pour répondre à vos questions :

    1. Le compte de service utilisé pour la rechercher n'est pas nécessairement administrateur du serveur.
    2. Vous n'avez aucune obligation de dissociation de compte. Utiliser des comptes différents constitue une "Bonne Pratique" mais n'est pas obligatoire. Pour des raisons de test, je vous recommande même de tenter l'indexation avec le compte administrateur de SharePoint qui a été utilisé pour l'installation. Quitte à le changer par un autre lorsque ça fonctionnera (et dans ce cas ovous regardez les différences de droit).
    3. WSS_Content correspond au nom d'une base de données de contenu. Le nom de votre base de recherche est obligatoirement différent. Le compte utilisé pour la recherche doit pouvoir lire et écrire dans la base de données de recherche, et lire dans la base de données de contenu.

    Enfin, le droit de lecteur n'est pas db_owner. db_owner correspond au propriétaire de la base.


    http://blogs.developpeur.org/gribouillon/
    lundi 23 mars 2009 12:33
    Modérateur
  • Bonjour et merci de votre réponse
     
    Question bête, mais le compte utilisé pour la recherche dans mon notre cas c'est Recherchewss c'est bien juste ?

    Notre base de données de contenu est donc WSS_Content ?

    Et la base de données de recherche WSS_Search_Vicques_DB ?

    Voici le détail SQL

    Pour la bd WSS_Content

    et

    Pour la bd de recherche Vicques_DB 

    lundi 23 mars 2009 15:18
  • Plutôt que de continuer sur cette piste, je vous recommande de tester avec un compte qui dispose de plus de droits. Tentez de vérifier que vous êtes bien face à un problème lié au compte, dans un premier temps en utilisant le compte qui a été utilisé pour installer SharePoint / qui est administrateur de la plateforme SharePoint.

    Vous pourrez ensuite affiner en changeant de compte et en restreignant les droits. Voici la liste des droits dont vous avez besoin :

    WSS Search Service Account :

    Ce compte est utilisé pour exécuter le service de recherche WSS

    Privilèges nécessaires :

    • Utiliser un compte de domaine (ou local en cas d'installation stand alone)

     

    Les privilèges suivant sont accordés automatiquement (vérifiez les du coup) :

    • accès en lecture à la base de données de configuration.
    • accès en lecture à la base de données de contenu de la console d'administration centrale
    • membre du rôle SQL db_owner pour la base de données de recherche WSS.


    http://blogs.developpeur.org/gribouillon/

    lundi 23 mars 2009 21:42
    Modérateur
  • Bonjour,

    Ok mais comme au départ ce n'est pas moi qui ai installé Sharepoint c'est un peu la difficulté.

    Quand vous dites tester  en utilisant le compte  qui a été utilisé pour installer Sharepoint ?
    Je devrais tester cela comment en allant dans l'Administration centrale - Opérations - et dans Configurer les paramètres du service Recherche Windows SharePoint Services ?

    Peux-t'on retrouver à un endroit le compte qui a été utilisé pour l'installation de Sharepoint ?

    Le service de recherche wss que vous mentionné est celui que l'on retrouve dans mon print screen ?
    Compte de service ou Compte de contenu ?

    J'avoue que ce n'est pas très clair.

    Merci d'avance pour vos détails

    PS: Les droits s'attribue pour les comptes utilisés s'attribuent bien dans SQL Serveur ?
    mardi 24 mars 2009 07:51
  • Bonjour,

    Pour être sûr, faites un test avec un compte quit soit :

    • Un compte de domaine
    • Administrateur des serveurs de la ferme
    • Qui soit db_owner sur toutes les bases SQL relatives à SharePoint

    Bien sûr, c'est juste pour les tests. En aucun cas vous ne devez suivre ces recommandations pour le fonctionnement quotidien. Soit ce compte existe déjà, soit il vous est possible de le créer. Il vous suffit de vous connecter avec ce compte sur la console d'administration centrale et de réaliser les opérations. Spécifiez ce compte comme compte à utiliser pour accéder au contenu.

    Vous pouvez faire la distinction entre les comptes de service et les comptes d'administration. Le terme "compte de contenu" n'existe pas.


    http://blogs.developpeur.org/gribouillon/
    mardi 24 mars 2009 18:49
    Modérateur
  • Bonjour, je vais essayer par étapes.

    1. mon compte de domaine s'appelle domaine/Administrateur
    qui est administrateur des serveurs

    En me connectant à mon administration centrale avec ce compte il m'indique "compte système"

    si j'essaie dans sécurité d'insérer ce compte domaine/Administrateur avec les droits db_owner j'ai un message d'erreur de sql:

    Echec de création d'utilisateur

    L'ouverture de session a déjà un compte sous un nom d'utilisateur différent (Microsfot SQL Server Erreur: 15063)

    C'est le compte qui est utilisé pour la connexion à sql serveur.
    mercredi 25 mars 2009 07:12
  • L'erreur est normale, votre compte est déjà db_owner.

    Il est recommander de ne pas procéder à l'installation de SharePoint avec un compte administrateur du domaine (administrateur des serveurs de la ferme seulement). Pour votre test, celà ne posera pas de problème, mais il pourrait être judicieux de changer àa pas la suite.

    Pour le moment, utilisez ce compte à la place de votre compte Recherchewss pour le service de recherche et pour l'accès aux bases de contenu.
    http://blogs.developpeur.org/gribouillon/
    mercredi 25 mars 2009 07:59
    Modérateur
  • Finalement j'ai enfin un résultat....

    Je me suis connecté à l'Administration centrale avec le compte système xxx/Administrateur.

    Puis dans la partie indexation j'ai mis également le compte système xxx/Administrateur dans Compte de service et dans Compte d'accès au contenu.

    Puis j'ai lancé finalement la commande

    stsadm -o spsearch -action fullcrawlstart

    Bon d'après ce que j'ai compris ce n'est pas la bonne solution d'avoir un compte administrateur pour mon compte d'accès au contenu.


    Maintenant cela signifie que le problème vient de mon compte xxx/Recherchewss qui est prévu pour l'accès au contenu  (enfin je pense) pourtant il se trouve partout dans les sécurités de sql.

    Comme l'indexation est fixé sur 5 minutes si je supprime un document ou j'en crée un nouveau je ne suis pas obligé de relancer 

    stsadm -o spsearch -action fullcrawlstart ????

    Car j'ai posté un nouveau document dans une bibliothèque mais la recherche sur le site en question ne la trouve pas malgré l'indexation toutes les 5 minutes ?
    mercredi 25 mars 2009 12:56
  • Ce test permet effectivement de dire qu'il s'agit d'un problème de droit avec votre compte de recherche. Bien que je vous ai indiqué les droits recommandés pour ce type de compte, vous pouvez lui attribuer plus de droits. Vous pourrez ensuite lui en retirer itérativement pour identifier le problème qui se posait et trouver un profil d'utilisation convenable.

    En ce qui concerne l'indexation, le fullcrawl indique une indexation complète (full crawl), en opposition à une indexation incrémentale (celle qui est réalisée toutes les 5 mn). Le paramétrage de l'indexation toutes les 5 mn n'indique pas que les documents seront indexés en 5 mn mais plutôt que le job d'indexation sera relancé toutes les 5 mn. Il lui faudra ensuite du temps (je ne peux pas vous préciser combien) pour trouver les modifications réalisées.

    J'espère que vos problèmes d'indexation / recherche sont résolus.

    Bonne continuation.


    http://blogs.developpeur.org/gribouillon/
    mercredi 25 mars 2009 18:29
    Modérateur
  • Bonjour,

    Mon compte de recherche c'était bien xxx/Recherchewss ?

    Dans la console d'administration c'est ce qui est équivalent au Compte d'accès au contenu non ?

    J'ai actuellement deux bd de recherches WSS_Search_VICQUES et WSS_Search_VICQUES_DB (dernière que j'ai du faire selon votre post). est-ce que je peux supprimer sans autre l'autre bd WSS_Search_VICQUES ?

    Encore une chose auriez-vous un lien web ou une explication plus détaillés sur les types de critères, caractères spéciaux qui peuvent être saisi dans la recherche Sharepoint ?

    Merci

    PS: Dans l'Administration centrale il sous services il indique:

    Compte d'accès au contenu

     
    Le service de recherche va accéder à l'ensemble du contenu à l'aide de ce compte.

    Le compte va être ajouté à la stratégie de lecture totale et disposera d'un accès en lecture seule à l'ensemble du contenu.

    Pour optimiser la fonctionnalité de recherche et la sécurité des informations, n'utilisez pas de compte d'administrateur, ni de compte pouvant modifier du contenu.



    il indique que le compte va être ajouté à la stratégie de lecteur locale. Mais ou exactement ?

    Car j'ai refait l'essai avec Recherchewss mais j'ai à nouveau les erreurs de l'observateur d'événement. Donc ou dois-je exactement regarder que mon compte "Recherchewss" ait les autorités suffisantes ?

    Afin de vérifier et ne pas mettre de compte administrateurs pour cette recherche.

    Merci
    jeudi 26 mars 2009 07:16
  • Bonjour,

    Si vous avez un peu de temps...

    Merci
    vendredi 27 mars 2009 10:29
  • Dans votre cas, "www\Recherchewss" est à la fois votre compte de service (c'est à dire l'identité utilisé pour faire tourner le service de recherche) et le compte d'accès au contenu (c'est à dire l'identité utilisée pour accéder au contenu à indexé). Les deux peuvent être différents car le compte de service a besoin de droits suivants :

    • accès en lecture à la base de données de configuration.
    • accès en lecture à la base de données de contenu de la console d'administration centrale
    • membre du rôle SQL db_owner pour la base de données de recherche WSS.

    Alors que le compte d'accès au contenu a besoin des droits de lecture sur le contenu à indexer. Veillez donc à ce que votre compte xxx\Recherche ait bien les droits décrits ci dessus. Pour la partie "Accès au contenu", vous pouvez procéder simplement en cliquant sur l'onglet "Gestion des applications web" de la console d'admin, puis "Sécurité des applications" puis "Stratégie de l'application Web". Dans la liste déroulante en haut à droite, sélectionner la/les application(s) web à indexer puis cliquer sur "Ajouter un utilisateur". Sélectionnez "Toutes les zones", indiquez votre compte de recherche, cochez "Lecture Totale" puis cliquez sur le bouton "Terminer".

    Cette manipulation donne aussitôt les droits de lecture au compte sur tous les sites de toutes les collections de site de l'application web sélectionnée.


    http://blogs.developpeur.org/gribouillon/
    mercredi 1 avril 2009 23:12
    Modérateur
  • Bonjour et merci pour votre réponse...

    Non dans notre cas le compte de service n'est pas "www\Recherchewss" mais le compte Administrateur "www\Administrateur". Le compte d'accès lui est bien le "www\Recherchewss".

    Le compte de service étant le "www\Administrateur" a déjà tous les droits....

    Concernant le compte d'accès au contenu "www\Rerchewss" voici un prnt scren de la "Sécurité des applications" déjà avec les droits "Lecture Totale"

    Lorsque j'essai de me connecter à la console d'admin avec le compte "www\Recherchewss" j'ai le message suivant prnt screen

    Est-ce que c'est éventuellement lié ?

    jeudi 2 avril 2009 07:50
  • Bonjour,

    votre print screen d'erreur est intéressante. Vous devriez avoir une erreur SharePoint et non une erreur ASP.Net. L'erreur SharePoint indiquerait que votre compte a bien accès au site IIS, mais que la sécurité applicative (interne à SharePoint) ne laisse pas passer le compte. Or, votre erreur est une erreur ASP.Net, ce qui me laisse penser que votre compte n'a pas accès du tout au site. Je ne vois pas en quoi ce serait lié à votre problème, mais ça caractérise un paramétrage potentiellement erroné (pas nécessairment, ça pourrait être volontaire aussi)... pour l'instant, faute de mieux, miser sur le fait que ce paramétrage vous bloque également sur l'indexation en elle même me paraît être une piste à suivre.

    Pouvez vous regarder le web.config de la console d'administration et regarder s'il y a un élément <deny> sous le bloc <authorization> ? Si oui, votre compte est-il compris dans les utilisateurs en deny ?
    http://blogs.developpeur.org/gribouillon/
    jeudi 2 avril 2009 22:20
    Modérateur
  • Bonjour,
    Je vous conseille de lire l'article suivant afin de bien valider le processus de paramétrage :
     - http://www.asp-php.net/tutorial/asp.net/sharepoint-search-wss.php

    Dans le cas ou tout ceci a déjà été fait au préalable, mais que vous n'avez aucun résultat tout de même, la solution est la suivante :
     - http://blogs.codes-sources.com/fabrice69/archive/2008/11/27/sharepoint-erreur-potentielle-sur-wss-v3-search.aspx

    Cordialement
    Romelard Fabrice [MVP]
    lundi 6 avril 2009 11:51
  • Bonjour,

    Excusez-moi pour la réponse tardive...

    Je n'arrive pas à trouver le "web.config" dans la console d'administration ????? Pouvez-vous m'indiquer si cela se trouve dans Opérations ou Gestion des applications...

    Merci

    mardi 7 avril 2009 08:43
  • Le fichier web.config est un fichier situé sur votre serveur, dans le répertoire de l'application web (par défaut dans c:\InetPub\wwRoot\wss\80). Bien sûr, ce chemin change selon votre configuration IIS et le port utilisé par votre site SharePoint.
    http://blogs.developpeur.org/gribouillon/
    mardi 7 avril 2009 12:22
    Modérateur
  • Le fichier web.config se trouve dans

    C:\Inetpub\wwwroot\wss\VirtualDirectories\48704

    Bon il y pas mal de codes et quelques rubrique autorisation. (faut-il en regarder une en particulier) car en général c'est indiqué ceci:

    <authorization>
          <allow users="*" />
        </authorization>
    Pour IIS voici une capture de mon écran j'ai pas vu de compte Recherchewss dans les autorisations. Est-ce que l'erreur peut venir de là..... dans cette capture je dois vérifier dans une rubrique en particulier

    http://cjoint.com/?ekbHFhyWjJ
    mercredi 8 avril 2009 09:54
  • Bonjour Fabrice...

    Merci à vous pour vos liens...

    Pour le premier lien tous semble ok...

    Je pense que c'est certainement une erreur de droit mais je n'arrive pas encore à trouver ou configurer ces paramètres
    mercredi 15 avril 2009 07:45
  • Bonjour,

    J'ai le problème deque Rizoule. Avez vous pu trouver la solution
    mercredi 17 février 2010 19:28
  • Bonjour Sébastien,

    Je suis tombé sur votre poste (vieux certes mais très intéressant) et dans un premier temps je vous remercie pour votre patience et de vos explications d'experts sur SharePoint.

    Mon problème est le suivant. Ma recherche Sharepoint marchait très bien, mais je ne sais pas depuis quand, seule la recherche dans ma collection de site qui est reliée au site supérieur fonctionne, alors que celle de ma collection de site (essentielle) réservé aux stockages des grandes bases de données ne donne plus rien?

    J'ai fait le tours de beaucoup e problème autour e la recherche sharepoint mais aucune ne ressemble à ce que j'ai. 

    Je suis sous WSSV3, l'Url qui fonctionne pour la recherche est la suivante :

    http://www.u-web2.com/_layouts/searchresults.aspx?k=essai&u=http://www.u-web2.com

    ainsi que tous les sous-sites 

    Et la collection de site qui ne marche plus est

    http://www.u-web2.com/sites/accueilulysoft/_layouts/searchresults.aspx?k=essai&u=http://www.u-web2.com/sites/accueilulysoft

     

    Si vous pouvez m'apportr un début d'éclaircissement et e la démarche à suivre pour corriger cette erreur je vous ens erais infiniment reconnaissant (les paramètres de visibilité sont les mêmes, les administrateurs également et c'est sûr ça marchait très bien)

     

    Cordialement

    Mehdi

    dimanche 23 octobre 2011 13:17
  • Bonjour Mehdi,

    Vu la longeur de ce billet je vous suggère d'en créer un nouveau pour traiter de votre problématique.

    J'ai moi-même des soucis de scripts causer par cette longueur justement ;-)

    En vous remerciant d'avance...


    Pascal P
    http://sharepoint-afterwork.fr
    Nouveaux site en FR
    Twitter: @PascalPoeck
    jeudi 3 novembre 2011 14:36