none
Pb déploiement appli winform cible .NET 2.0 setup généré par VS2008 RRS feed

  • Question

  • Bonjour,

    j'ai un soucis lorsque je déploie mon application winform avec le framework .NET 2.0 pour cible.

    J'ai créé un projet de déploiement dans VS2008 avec pour dépendance la version 2.0.50727 du framework.
    Les projets de ma solution associée à ce projet de déploiement ont également pour cible le framework 2.0.
    L'ensemble de mes dll de références sur mes différents projets correspondent à la version du runtime 2.0.50727.

    OR lorsque je lance le Setup de mon projet de déploiement il me demande d'installer le framework 3.5 !!!!
    Je n'y comprend plus rien.

    J'ai repris la solution sur VS2005 et là pas de problème je génère bien un setup qui m'impose comme pré-requis seulement le framework .NET 2.0.

    si quelqu'un a une idée elle sera la bienvenue.

    Merci d'avance

    Cordialement

    Wodan37
    mardi 20 janvier 2009 15:08

Réponses

  • Bonjour,

    J'ai eu le même problème. Il y a un bug dans VS 2008.

    Projet SetUp ; Il faut mettre à jour manuellement les propriétés du .NET Framework dans les dépendences du projet et choisir la bonne version du Framework.

    Cordialement.


    Alain
    • Proposé comme réponse AchLog mardi 5 mai 2009 12:33
    • Marqué comme réponse Marius Bugiulescu jeudi 16 juillet 2009 12:42
    vendredi 30 janvier 2009 11:24