none
Problème Affichage Liste avec nouveau thème RRS feed

  • Question

  • Bonjour,

    J'ai un problème sur mon site Sharepoint en ce qui concerne l'affichage des listes, suite à la mise en place d'un nouveau thème.

    Lorsque la liste contient beaucoup de colonnes, le problème suivant se produit
    « Les titres de colonnes s’affichent en dehors du cadre.
    De plus, lorsque l’on scroll vers la droite les titres de colonnes restent figées alors que le contenu de la liste lui suit bien le déplacement. Par contre, quand on passe la souris sur les titres de colonnes figées, ils se retrouvent au bon endroit (comme si l’affichage était rafraichit lorsque l’on passe la souris dessus). »

    Bien évidemment ce problème ne se produit que sur IE et pas sur Firefox
    mercredi 17 février 2010 16:01

Toutes les réponses

  • Bonjour,

    votre problème n'est pas spécifique à SharePoint. Les thèmes SharePoint s'appuient sur les CSS. C'est donc de ce côté que vous trouverez le problème.

    Le respect des normes w3c diffère d'un navigateur à l'autre et d'une version à l'autre pour un même navigateur. Réaliser des CSS qui sont restitués de la même façon avec tous les navigateurs est souvent très difficile.

    Pour résoudre votre problème, vous devez identifier les problèmes de CSS (à l'aide d'outils comme FireBug, IE dev toolbar ou l'outil de développeur inclu en standard dans IE8).
    Une fois les problèmes identifiés, vous devrez modifier les fichiers CSS de votre thème.

    SI ces modifications ne vous parlent pas, ou si ce n'est pas du tout votre domaine, faites vous aider par un designer... Le temps que prend ce genre de choses est très difficile à estimer lorsqu'on est novice.

    Bon courage.

    http://blogs.developpeur.org/gribouillon/
    mercredi 17 février 2010 19:21
    Modérateur
  • Bonjour,

    Nous avons réalisé la refonte complète de la charte graphique de notre intranet via JQuery et CSS.
    Évidement, tout au long de nos développements, nous avons été confrontés à des différences d'interprétations entre IE et FireFox.
    Pour le moment, nous avons toujours réussi à y faire face en ciblant la class concernée via FireBug ou IE dev toolbar puis en la modifiant dans notre CSS.

    Mais là, le problème nous semble plus sombre...
    En effet, la bibliothèque native SharePoint a un comportement très étrange. Nous avons retourné le css dans tous les sens, impossible de résoudre le problème.
    Je n'ai pas pu joindre des images à ce topic. Je te donne donc le lien vers ce même topic hébergé sur un autre forum Microsoft avec des images.

    Merci d'avance pour ta contribution.

    jeudi 18 février 2010 09:07