none
Excel 2010 Pro Plus... les WebBrowser arrêtent de s'animer quand une macro s'exécute... RRS feed

  • Question

  • Dans une feuille vierge j'ai créé 3 "webbrowser". Avec une macro, je mets une animation Gif dans chacun d'eux. Cette partie-là fonctionne. La première ligne de macro mets une animation dans le premier WebBrowser" et l'animation roule. Le problème c'est que lorsque la macro exécute la 2e ligne, qui mets l'animation dans le 2e Webbrowser, l'animation dans le premier arrête de jouer. Lorsque la 3e ligne mets l'animation dans le 3e Webbrowser, l'animation du premier se remet à jouer, mais c'est l'animation du 2e qui arrête de jouer.
    En bout de ligne, je me retrouve avec plus d'animations qui ne jouent pas, que d'animations qui jouent.
    Je veux savoir pourquoi les animations arrête de jouer, quand une macro s'exécute, et qu'est-ce qu'il faut faire pour prévenir ça???
    Si on ne peut pas empêcher de les arrêter de jouer pendant qu'une macro s'exécute y a t-il une commande VBA qui les repart tous?
    Sur certains forums il est suggéré de mettre "DoEvents", ou de faire "Design OFF puis ON"... j'ai essayé, sans succès.
    Merci

    André

    Andre

    lundi 5 juin 2017 19:57

Toutes les réponses

  • J'ai des problèmes similaires dans MS Access et, longue histoire courte, il n'y a pas de solution.  J'ai essayé toutes les solutions proposes et rien ne marche.  Je crois que c'est tout du fait que les logiciels sont "Single Threaded" et non "Multi-Threaded", donc ils ne peuvent que faire une seule opération à la fois.  Si jamais tu trouves une solution, STP partage-la, mais malheureusement, je ne crois pas qu'il y en existe une.

    Daniel Pineault, 2010-2016 Microsoft MVP
    Professional Support: http://www.cardaconsultants.com
    MS Access Tips and Code Samples: http://www.devhut.net


    mardi 6 juin 2017 17:42