none
quick launch dans la page Web Analytics avec une master page personnalisée RRS feed

  • Question

  • Bonjour,

     

    J'ai un soucis avec les pages de rapports de collection de site et de site SPWeb:

    http://~/_layouts/WebAnalytics/Report.aspx?t=SummaryReport&l=s

    http://~/_layouts/WebAnalytics/Report.aspx?t=SummaryReport&l=sc

    Les deux pages indiquent l'erreur ci-dessous lorsque ma page maître est active, mais les rapports fonctionnent si je remets v4.master.

    Avez vous une idée d'où peut provenir l'erreur?

    J'ai été regarder dans le fichier report.aspx

    C'est le contrôle suivant qui semble planter: <asp:SiteMapDataSource ID="siteMapDataSource" runat="server" SiteMapProvider="SPXmlContentMapProvider" StartingNodeUrl ="/_layouts/WebAnalytics/WebAppSelection.aspx" ShowStartingNode="false"/>

     

    La page indiquée dans l'erreur n'existe pas lorsque j'essaie de naviguer dessus (même avec v4.master: http://~/_layouts/WebAnalytics/WebAppSelection.aspx)

     

    Merci pour votre aide :)

     

     

     

    Erreur du serveur dans l'application '/'.

    Impossible de trouver le noeud sitemap avec l'URL '/_layouts/WebAnalytics/WebAppSelection.aspx'.

    Description : Une exception non gérée s'est produite au moment de l'exécution de la demande Web actuelle. Contrôlez la trace de la pile pour plus d'informations sur l'erreur et son origine dans le code.

    Détails de l'exception: System.ArgumentException: Impossible de trouver le noeud sitemap avec l'URL '/_layouts/WebAnalytics/WebAppSelection.aspx'.

    Erreur source:

    Une exception non gérée s'est produite lors de l'exécution de la demande Web actuelle. Les informations relatives à l'origine et l'emplacement de l'exception peuvent être identifiées en utilisant la trace de la pile d'exception ci-dessous.

    Trace de la pile:

    [ArgumentException: Impossible de trouver le noeud sitemap avec l'URL '/_layouts/WebAnalytics/WebAppSelection.aspx'.]
     System.Web.UI.WebControls.SiteMapDataSource.GetNodes() +4049807
     System.Web.UI.WebControls.SiteMapDataSource.GetTreeView(String viewPath) +35
     System.Web.UI.WebControls.HierarchicalDataBoundControl.GetData(String viewPath) +43
     System.Web.UI.WebControls.Menu.DataBindItem(MenuItem item) +53
     System.Web.UI.WebControls.Menu.PerformDataBinding() +49
     System.Web.UI.WebControls.HierarchicalDataBoundControl.PerformSelect() +114
     System.Web.UI.WebControls.BaseDataBoundControl.EnsureDataBound() +82
     System.Web.UI.WebControls.Menu.EnsureDataBound() +38
     Microsoft.SharePoint.WebControls.AspMenu.OnPreRender(EventArgs e) +176
     System.Web.UI.Control.PreRenderRecursiveInternal() +108
     System.Web.UI.Control.PreRenderRecursiveInternal() +224
     System.Web.UI.Control.PreRenderRecursiveInternal() +224
     System.Web.UI.Control.PreRenderRecursiveInternal() +224
     System.Web.UI.Control.PreRenderRecursiveInternal() +224
     System.Web.UI.Control.PreRenderRecursiveInternal() +224
     System.Web.UI.Control.PreRenderRecursiveInternal() +224
     System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3394
    


    Informations sur la version :  Version Microsoft .NET Framework :2.0.50727.4927; Version ASP.NET :2.0.50727.4927

     

    • Modifié Marc TRAN mercredi 22 septembre 2010 09:32
    • Déplacé Hengzhe Li mardi 21 février 2012 07:03 merge forum (Origine :Développement Sharepoint 2010)
    mercredi 22 septembre 2010 08:44

Réponses

  • Bonjour, j'ai finalement refait ma master page, je ne suis pas capable de dire ce qui a corrigé le problème étant donné que j'ai tout recommencé à partir de la master page minimale mais ça fonctionne.

     

    • Marqué comme réponse Marc TRAN dimanche 3 octobre 2010 16:54
    dimanche 3 octobre 2010 16:53

Toutes les réponses

  • La page fonctionne avec la page maître personnalisée si je retire les contrôles du lancement rapide:

    <SharePoint:AspMenu
                        id="V4QuickLaunchMenu"
                        DataSourceID="siteMapDataSource"
                        runat="server"
                        EnableViewState="false"
                        UseSimpleRendering="true"
                        CssClass="s4-ql"
                        Orientation="Vertical"
                        StaticDisplayLevels="3"
                        >
                    </SharePoint:AspMenu>
                    <asp:SiteMapDataSource ID="siteMapDataSource" runat="server" SiteMapProvider="SPXmlContentMapProvider" StartingNodeUrl ="/_layouts/WebAnalytics/WebAppSelection.aspx" ShowStartingNode="false"/>

    mercredi 22 septembre 2010 09:19
  • Bonjour, j'ai finalement refait ma master page, je ne suis pas capable de dire ce qui a corrigé le problème étant donné que j'ai tout recommencé à partir de la master page minimale mais ça fonctionne.

     

    • Marqué comme réponse Marc TRAN dimanche 3 octobre 2010 16:54
    dimanche 3 octobre 2010 16:53