locked
pas à pas et point d'arret RRS feed

  • Question

  • Bonjour,

     

    Les petits logiciel que je devellope pour les clients de mon entreprise etaient fait sous VB6. Nous venons d'investir dans visual studio 2008. Investissement consequent et changement radical. A tel point que je n'arrive meme pas a tester mes applications pas a pas...

     

    Avant sur vb6 je mettais mon point d'arret et quand mon programme arrivait à ce point d'arret je pouvais suivre petit à petit son evolution grace à F8.

     

    C'est peut etre une question bete mais bon comment fait on ca sur VS2008, je mets mon point d'arret mais mon programme ne s'y arrete pas... pourtant il passe dans la procedure ou se trouve ce point d'arret.

     

    Merci d'avance

     

    Laurent 

     

    PS : j'ai suivi les instructions de http://gilles.tourreau.fr . Mais mon programme ne se met pas en pause

    vendredi 12 septembre 2008 07:22

Réponses

  • Bonjour,

     

    Ce problème vient du fait que les fichiers .pdb ne sont présent dans le répertoire de l'exécutable.

    Vérifiez la propriété suivante :

    • Dans les propriétés de votre projet allez dans l'onglet : "Compiler"
    • Cliquez en bas sur le bouton "Options avancées de compilation"
    • Dans "Générer les informations de débogage", vérifiez que "Full" est sélectionné.

    Cordialement

     

    lundi 15 septembre 2008 20:58

Toutes les réponses

  • Es-ce que dans ta barre en haut tu compile en Release? si c'est le cas, il faut que tu le change pour Debug, là il va reconnaitre les points d'arrêts.

    vendredi 12 septembre 2008 20:23
  • Bonjour,

     

    la liste deroulante avait pour valeur DEBUG. Donc ca ne vient pas de la.Quand j'execute, mon point d'arret se transforme en cercle rouge avec un triangle jaune contenant un point d'exclamation. Mais a aucun moment le programme s'arrete.

     

    lundi 15 septembre 2008 06:35
  • Bonjour,

     

    Ce problème vient du fait que les fichiers .pdb ne sont présent dans le répertoire de l'exécutable.

    Vérifiez la propriété suivante :

    • Dans les propriétés de votre projet allez dans l'onglet : "Compiler"
    • Cliquez en bas sur le bouton "Options avancées de compilation"
    • Dans "Générer les informations de débogage", vérifiez que "Full" est sélectionné.

    Cordialement

     

    lundi 15 septembre 2008 20:58
  •  

    Effectivement ca venait de la. Merci beaucoup.

     

    Cordialement

     

    Laurent 

    mardi 16 septembre 2008 12:10
  • Merci Gilles!

     

    mardi 16 septembre 2008 12:17
  • Merci, cela fait un moment que je cherchait la solution !

     

    Cordialement

    mercredi 15 octobre 2008 19:04