none
Bug Affichage Visual Studio RRS feed

  • Question

  • Bonjour,

    J'ai un problème avec mon Visual Studio 2010 Pro.

    Lorsque je navigue sur les différentes pages de la solution le code se superpose, la page de code devient illisible...

    Je ne sais pas quoi faire, je n'ai rien de spécial d'installé coté plugin.

    Cela a commencé début de semaine dernière, le problème d'affichage pendant un temps ne se faisait que lorsque j'étais en mode debug mais maintenant c'est tout le temps ...

    Je suis sous Windows 7 Pro SP1

    Version Visual Studio 10.0.40219.1 SP1Rel

    Version .NET Framework 4.0.3019 SP1Rel

    Merci d'avance.

    jeudi 12 juillet 2012 08:27

Réponses

  • Bonjour,

    C'est problème sont dus le plus souvent à des bug du drivers de votre carte graphique.
    Il n'y a pas d'autres solutions que désactiver l'accélaration graphique dans Visual Studio :

    Pour cela allez dans les options de Visual Studio et déactivez les options suivantes :

    Cordialement


    Gilles TOURREAU - MVP C#
    Architecte logiciel/Consultant/Formateur Freelance
    Blog : http://gilles.tourreau.fr
    - MCPD : Enterprise Developper / Windows Developper 3.5 / ASP .NET 3.5/4.0
    - MCITP : SQL Server 2008 Developper
    - MCTS : ADO .NET 3.5 / SQL Server 2008 Developper / Windows Forms 3.5 / ASP .NET 3.5/4.0

    lundi 16 juillet 2012 08:50
    Modérateur
  • Bonjour,

    Après avoir réinitialisé les paramètres Visual Studio le problème semble être résolu.

    Merci pour votre aide.

    Cordialement.

    • Marqué comme réponse Eyeshield lundi 16 juillet 2012 09:41
    lundi 16 juillet 2012 09:40

Toutes les réponses

  • c'est très bizarre

    es que ça te le fait dans d'autre logiciel (microsoft ou pas)???

    ça te le fait avec un projet en particulier ou sur tout les fichiers?

    quoi que peut probable c'est peut-être la carte graphique qui a un défaut (pilot, matériel défaillent .......)

    samedi 14 juillet 2012 19:28
  • Bonjour,

    Pouvez-vous réaliser une capture d'écran afin que l'on puisse voir plus précisement le problème ?

    Cordialement


    Gilles TOURREAU - MVP C#
    Architecte logiciel/Consultant/Formateur Freelance
    Blog : http://gilles.tourreau.fr
    - MCPD : Enterprise Developper / Windows Developper 3.5 / ASP .NET 3.5/4.0
    - MCITP : SQL Server 2008 Developper
    - MCTS : ADO .NET 3.5 / SQL Server 2008 Developper / Windows Forms 3.5 / ASP .NET 3.5/4.0

    dimanche 15 juillet 2012 18:51
    Modérateur
  • Bonjour,

    Merci pour votre aide.

    Voila ce que j'ai après quelques montées et descentes successives sur ma page de code.

    Merci d'avance.

    lundi 16 juillet 2012 08:08
  • Bonjour,

    Merci pour votre aide.

    J'ai eu les droits admin de ma machine, j'ai pu réinstaller Visual Studio ainsi que les drivers à jours de ma carte graphique et rien n'a changé :/.

    Et pour répondre a ta question je n'ai ce problème que dans Visual Studio et sur toutes les pages .cs

    Merci d'avance.


    • Modifié Eyeshield lundi 16 juillet 2012 08:28
    lundi 16 juillet 2012 08:28
  • Bonjour,

    C'est problème sont dus le plus souvent à des bug du drivers de votre carte graphique.
    Il n'y a pas d'autres solutions que désactiver l'accélaration graphique dans Visual Studio :

    Pour cela allez dans les options de Visual Studio et déactivez les options suivantes :

    Cordialement


    Gilles TOURREAU - MVP C#
    Architecte logiciel/Consultant/Formateur Freelance
    Blog : http://gilles.tourreau.fr
    - MCPD : Enterprise Developper / Windows Developper 3.5 / ASP .NET 3.5/4.0
    - MCITP : SQL Server 2008 Developper
    - MCTS : ADO .NET 3.5 / SQL Server 2008 Developper / Windows Forms 3.5 / ASP .NET 3.5/4.0

    lundi 16 juillet 2012 08:50
    Modérateur
  • Bonjour,

    Après désactivation de l'expérience visuel le problème persiste toujours :/.

    lundi 16 juillet 2012 09:02
  • Bonjour,

    Avez-vous redémarré Visual Studio ?

    Cordialement


    Gilles TOURREAU - MVP C#
    Architecte logiciel/Consultant/Formateur Freelance
    Blog : http://gilles.tourreau.fr
    - MCPD : Enterprise Developper / Windows Developper 3.5 / ASP .NET 3.5/4.0
    - MCITP : SQL Server 2008 Developper
    - MCTS : ADO .NET 3.5 / SQL Server 2008 Developper / Windows Forms 3.5 / ASP .NET 3.5/4.0

    lundi 16 juillet 2012 09:11
    Modérateur
  • Bonjour,

    Oui, a chaque modification.

    Cordialement.

    lundi 16 juillet 2012 09:19
  • Bonjour,

    Dans ce cas, le problème vient des drivers de la carte graphique. Il faudrait voir à installer les derniers drivers ou contacter directement le support du fabricant.

    Cordialement


    Gilles TOURREAU - MVP C#
    Architecte logiciel/Consultant/Formateur Freelance
    Blog : http://gilles.tourreau.fr
    - MCPD : Enterprise Developper / Windows Developper 3.5 / ASP .NET 3.5/4.0
    - MCITP : SQL Server 2008 Developper
    - MCTS : ADO .NET 3.5 / SQL Server 2008 Developper / Windows Forms 3.5 / ASP .NET 3.5/4.0

    lundi 16 juillet 2012 09:38
    Modérateur
  • Bonjour,

    Après avoir réinitialisé les paramètres Visual Studio le problème semble être résolu.

    Merci pour votre aide.

    Cordialement.

    • Marqué comme réponse Eyeshield lundi 16 juillet 2012 09:41
    lundi 16 juillet 2012 09:40