none
Visual Studio 2010 Bug : Impossible d'ouvrir un formulaire, message d'erreur RRS feed

  • Discussion générale

  • Bonjour,

    Je suis un utilisateur de Visual Studio 2010 Premium (ma société étant partenaire Microsoft) et je l'ai utilisé pendant plusieurs mois sans problème. Cependant, je viens d'avoir un message d'erreur car je ne peux plus ouvrir mes formulaires en mode design, quelle que soit le solution ou le formulaire.

    En effet, lorsque je double-clic, dans l'explorateur de solutions, sur un formulaire, j'obtiens ce message : "Aucun éditeur disponible pour '<chemin du fichier .vb>'. Vérifiez que l'application correspondant au type de fichier (.vb) est installée."

    J'ai tenté de lancer visual studio de cette manière : devenv.exe /ResetSkipPkgs et devenv.exe /Resetsettings

    Le premier n'a rien fait, tandis que le second a bien rechargé l'environnement de développement, mais j'ai toujours la même erreur. Avez-vous une solution à mon problème, car je n'ai absolument plus la possiblité d'éditer mes projets. En revanche, quand je crée un tout nouveau projet, cela fonctionne.

    Je précise que les projets dont je parle ont tous été créés avec Visual Studio 2010 (en VB.Net)


    Cyril
    jeudi 17 février 2011 17:38

Toutes les réponses

  • Bonjour,

     

    Avez vous essayer d'installer la mise a jour SP1 beta ?

     

    -


    Cordialement,
    Xavier
    Alias Troxsa My M@iL
    vendredi 18 février 2011 12:28
  • Bonjour,

     

    Vous pouvez aussi essayer de réparer Visual Studio en exécutant le kit d’installation à nouveau.

     

    Je vous remercie de nous tenir au courant si une de ces solutions fonctionne.

     

    Cordialement,

    Alex

    ________________

    Publiez un article sur MSDN !

    Windows Phone 7

    Astuces pour Visual Studio 2010

    XNA – Développement jeux vidéo

    Didacticiels et astuces : VB.NET, C#, ASP.NET, .NET Framework, Silverlight, Workflow Foundation, SharePoint, WPF

    Microsoft propose ce service gratuitement, dans le but d'aider les utilisateurs et d'élargir les connaissances générales liées aux produits et technologies Microsoft. Ce contenu est fourni "tel quel" et il n'implique aucune responsabilité de la part de Microsoft.

     

     


    Suivez MSDN sur Twitter 

    lundi 21 février 2011 14:06
  • Bonjour, j'ai exactement le même problème, j'ai réinstaller l'éditeur, puis mis à jour avec SP1 final.

    J'ai toujours le même problème, ça n'a rien résolu.

     

    Merci pour votre aide.

    jeudi 24 mars 2011 17:42
  • Bonjour,

     

    Vous avez installé VS depuis combien de temps ?

    Votre système OS est (mise a jour) ?

    Peut être un checkdisk a faire ?

    Il doit bien y avoir une solution a votre probleme ....

     

    A bientot


    Cordialement,
    Xavier
    Alias Troxsa My M@iL
    vendredi 25 mars 2011 10:28
  • Bonjour,

    Ce post date pas mal mais avez vous eue une solution à ce problème.

    J'ai le même cas qui se produit fréquemment. Bon mon souci viens je pense de l'utilisation de composant ancien, car je fait à mes heures perdu de la conversion d'un logiciel VB6 vers le .net.

    Parfois à l'ouverture de VS j'ai le même souci. aucune fenêtres ne s'ouvrent en mode desing avec le même message d'erreur. J'ai constaté qu'a chaque fois c'était un composant COM qui n’était plus trouvé. Je l’enlève puis le rajoute et c'est bon. Enfin à moitié car certaine form son vide.

    Avez vous trouvé une solution?

    lundi 18 février 2013 08:21