none
Compiler VB sous Microsoft Visual Studio 2013 RRS feed

  • Question

  • Bonjour,

    Après avoir cherché comme un taré, je me tourne vers vous !
    J'ai finit mon programme VB sous Microsoft Visual Studio 2013 mais le problème c'est que je n'arrive pas à le compiler pour l'utiliser sur un autre ordinateur. Il existe une solution sous Microsoft Visual Studio 2010 : https://www.youtube.com/watch?v=Hnruwi5BkZc mais le problème c'est que ce n'est pas la même chose sous la version 2013 !

    Je vous prie donc de bien vouloir m'aider, merci d'avance pour toute l'aide que vous m'apporterez !

    mardi 30 juin 2015 15:09

Réponses

  • Je viens de regarder la vidéo, bonne nouvelle... Vous n'avez pas cette option car elle est spécifique au développement C++ (ce type de problème est classique, y-compris quand on fait du C++/CLI comme dans votre video.)

    Concernant votre message d'erreur, j'ai l'impression qu'il y a un accès en dur quelque part dans l'application. L'exception non gérée est ici bien renvoyé par .Net (le framework est donc bon^^) et lié au fait que vous n'avez pas de catch spécifique au moment où vous faîte une tentative d'accès au disque dur.

    'En clair 'C:\Users\Gary1_000\Documents\SaveTest\Backup' ne doit pas être un répertoire valide sur la 2ème machine.

    Je vous propose de vérifier ce point ainsi que de faire un try/catch lors de votre opération de Save/Restore pour vérifier cela.

    Vous pouvez aussi demander à votre amie de cliquer sur Détails et de vous envoyer la pile d'exception...

    mardi 30 juin 2015 17:08

Toutes les réponses

  • Bonjour,

    Votre problème peut a priori être de 2 ordres :

         - vous savez compiler en local mais pas l'utiliser sur une autre machine. Dans ce cas c'est 1 pb de CLR, il faut installer la version adéquate de .NET sur l'autre ordinateur

         - vous ne savez pas compiler en local... Dans ce cas vous ne savez tout simplement pas qu'une compilation est systématiquement faite derrière votre dos dès que vous testez votre programme. Allez dans le répertoire où vous développez votre application. Vous allez voir un répertoire bin. Dans ce répertoire, il y aura 1 ou plusieurs sous-répertoires en fonction du mode de compilation choisi (Debug ou Release. Cela se gère dans le menu Build\Configuration Manager). Dans ces répertoires Debug ou Release se trouveront vos binaires compilés que vous pourrez tester ailleurs (en ayant vérifié sur l'ordinateur cible que le framework .NET adéquat est installé).

    Bien cordialement,

    Fabrice JEAN-FRANCOIS

    mardi 30 juin 2015 16:14
  • Oui je sais compiler en local ce n'est pas ça le problème. Si vous regardez bien la vidéo youtube que j'ai mise dans ma publication, vous pouvez voir que la personne a utilisé une machine virtuelle pour regarder si sa compilation fonctionnée or ce n'était pas le cas. Il a alors dû faire une manipulation en changeant dans ses options de langage quelque chose avec la bibliothèque runtime que je ne retrouve pas sous la version 2013.
    J'ai une amie qui a testée mon programme et a eu l'erreur suivante : http://puu.sh/iIngJ/d964cae213.png

    mardi 30 juin 2015 16:33
  • Je viens de regarder la vidéo, bonne nouvelle... Vous n'avez pas cette option car elle est spécifique au développement C++ (ce type de problème est classique, y-compris quand on fait du C++/CLI comme dans votre video.)

    Concernant votre message d'erreur, j'ai l'impression qu'il y a un accès en dur quelque part dans l'application. L'exception non gérée est ici bien renvoyé par .Net (le framework est donc bon^^) et lié au fait que vous n'avez pas de catch spécifique au moment où vous faîte une tentative d'accès au disque dur.

    'En clair 'C:\Users\Gary1_000\Documents\SaveTest\Backup' ne doit pas être un répertoire valide sur la 2ème machine.

    Je vous propose de vérifier ce point ainsi que de faire un try/catch lors de votre opération de Save/Restore pour vérifier cela.

    Vous pouvez aussi demander à votre amie de cliquer sur Détails et de vous envoyer la pile d'exception...

    mardi 30 juin 2015 17:08
  • Tu as raison, le chemin n'existait pas sur les autres ordinateurs mais en changeant le chemin pour qu'il corresponde à celui des autres utilisateurs ça marche sans problèmes. Merci pour ton aide ! :)
    mardi 30 juin 2015 18:01