none
Sharepoint 2013 acces depuis internet RRS feed

  • Question

  • Bonjour,

    Je cherche a donner accès à notre intranet (http://monserveur) par internet.

    Dans un premier temps en http sur un port different de 80 et pour cela notre reverse proxy server renvoie les demandes de http://sharepoint.mondomaine.com:8081 sur l'IP de monserveur mais cela ne fonctionne pas correctement.

    J'ai configuré deux AAM : en zone défaut http://sharepoint.mondomaine.com et en zone internet .http://monserveur

    Mais si je précise un port différent de 80 rien ne fonctionne et si je ne précise pas dans sharepoint on accède au site mais on ne peut pas descendre dans les pages, l'adresse ip locale vient remplacer l'adresse internet

    Savez-vous me dire ce que je dois faire ?

    Merci

    mardi 28 février 2017 15:08

Réponses

  • Bonjour à vous,

    Je n'ai dans l'immédiat pas d'idée mais je pense que vous pouvez trouver la cause avec l'aide d'un outil comme fiddler par exemple qui vous permettra d'identifier les trames réseaux et les requêtes. Vous pouvez également consulter les logs ULS de SharePoint voir si il y a plus de détails.

    En tout cas si cela fonctionne correctement sur votre intranet, c'est certainement une configuration manquante au niveau de votre ferme qui ne permet pas la consultation d'une ressource à partir de l'exterieur.

    Bien à vous,

    Valentin LECERF


    SharePoint Administrator & Developer Expert My blog: http://vlecerf.be Twitter: @IoX_ Microsoft Partner | MCP

    • Marqué comme réponse Patricia__ lundi 3 avril 2017 14:13
    mardi 28 mars 2017 07:39
  • Bonjour,

    Il est possible que le reverse proxy bloque certains flux ou certains fichiers (CSS, etc.).

    Vous pouvez le vérifier avec Fiddler comme le suggère Valentin.

    Regardez aussi dans les journaux applications de windows, ainsi que les logs de IIS et ceux de SharePoint.


    Claude Couderc Consultant IIS, SharePoint, Exchange http://coudr.com

    • Marqué comme réponse Patricia__ lundi 3 avril 2017 14:13
    lundi 3 avril 2017 14:06

Toutes les réponses

  • Bonjour,

    Avez vous vérifier la configuration de votre instance IIS notamment le host header spécifié car par défaut il pointe sur * port 80.

    Si vous souhaitez utiliser un port différent du 80 il faudra faire le changement également sur l'instance IIS.

    Bien à vous,

    Valentin


    SharePoint Administrator & Developer Expert My blog: http://vlecerf.be Twitter: @IoX_ Microsoft Partner | MCP

    lundi 13 mars 2017 13:45
  • Bonjour,

    Merci pour votre réponse

    En fait depuis fin février je ne m'en sortais pas on a donc décidé de passer sur le port 80 en http en intranet et internet mais les bindings avaient été correctement ajustés.

    Au final, en intranet tout va bien mais je rencontre quand-même des soucis quand on passe par internet : L'application intranet a été étendue avec l'en-tête d'hôte correspondant à notre enregistrement A sur notre domaine internet, l'authentification choisie est NTLM. On y accède de l'extérieur mais : à l'usage du lien ajouter un document, après validation du choix du fichier on a une page web d'erreur Http403 et de même à la création d'un dossier, après renseignement du nom du dossier et validation on a une page d'erreur 403

    Malgré cela le dossier est créé mais impossible de mettre quoi que ce soit dedans car accès refusé.

    Pourtant les drags & drop dans des liste de documents fonctionnent bien

    J'ai remonté une deuxième plateforme sharepoint avec un site différent et je reproduis le problème !! Il y a quelque chose que j'oublie ou que je fais incorrectement mais je ne sais pas quoi

    Auriez-vous une idée ?

    Merci

    Patricia

    jeudi 16 mars 2017 09:18
  • Bonjour à vous,

    Je n'ai dans l'immédiat pas d'idée mais je pense que vous pouvez trouver la cause avec l'aide d'un outil comme fiddler par exemple qui vous permettra d'identifier les trames réseaux et les requêtes. Vous pouvez également consulter les logs ULS de SharePoint voir si il y a plus de détails.

    En tout cas si cela fonctionne correctement sur votre intranet, c'est certainement une configuration manquante au niveau de votre ferme qui ne permet pas la consultation d'une ressource à partir de l'exterieur.

    Bien à vous,

    Valentin LECERF


    SharePoint Administrator & Developer Expert My blog: http://vlecerf.be Twitter: @IoX_ Microsoft Partner | MCP

    • Marqué comme réponse Patricia__ lundi 3 avril 2017 14:13
    mardi 28 mars 2017 07:39
  • Bonjour,

    Il est possible que le reverse proxy bloque certains flux ou certains fichiers (CSS, etc.).

    Vous pouvez le vérifier avec Fiddler comme le suggère Valentin.

    Regardez aussi dans les journaux applications de windows, ainsi que les logs de IIS et ceux de SharePoint.


    Claude Couderc Consultant IIS, SharePoint, Exchange http://coudr.com

    • Marqué comme réponse Patricia__ lundi 3 avril 2017 14:13
    lundi 3 avril 2017 14:06
  • Bonjour,

    Fiddler m'a effectivement aidé à diagnostiquer que cela ne pouvait pas venir de sharepoint.

    Il s'agissait en fait de règlages au niveau de notre firewall que nous avons du modifier pour ne pas dire alléger pour que le site fonctionne correctement.

    Merci Valentin et Claude

    Patricia

    lundi 3 avril 2017 14:17
  • Merci Patricia pour votre retour.

    Claude Couderc Consultant IIS, SharePoint, Exchange http://coudr.com

    lundi 3 avril 2017 14:26