none
[Reporting Services 2005] Accès au serveur de rapport impossible RRS feed

  • Question

  •  

    Bonjour,

     

    Le serveur SQL Server Reporting Service 2005 (SSRS) est installé sur un Vista Ultimate.

    Je n'arrive pas à afficher la page http://localhost/ReportServer . IE affiche une erreur interne (HTTP 500.0) (après qu'IE ait  demandé un compte Windows).

    Toutes les configurations de Reporting Serices sont OK. Dans les fichiers des Log, il n'y a rien : le Web Services ne semble pas être lancé.

     

    En poursuivant les investigations dans IIS 7 (activation des "Régles de suivi des demandes ayant échoué", j'ai trouvé l'erreur suivantes :

     

    IIS Trace Detail Highlights
    No.  EventName Details Time
    53. MODULE_SET_RESPONSE_ERROR_STATUS Warning
    ModuleName="IsapiModule", Notification="EXECUTE_REQUEST_HANDLER", HttpStatus="500", HttpReason="Internal Server Error", HttpSubStatus="0", ErrorCode="Syntaxe du nom de fichier, de répertoire ou de volume incorrecte. (0x8007007b)", ConfigExceptionInfo="" 09:02:33.716

     

    J'ai fait une recherche compléte sur Internet et dans la littérature à ma disposition et je n'ai rien trouvé qui puisses me faire avancer vers un début de solution...

     

    Merci à tous pour l'aide que vous pourrez m'apporter.

     

    Cordialement,

     

    Philippe Geiger

    mardi 4 mars 2008 10:32

Réponses

  • Bonsoir,

     

    J'ai trouvé par hasard. Dans IIS, au niveau du serveur virtuel de Reporting Services (ReportServer), une erreur s'est glissé au niveau de la définition du module Isapi, le chemin contenait deux anti-slash (\\). Cette erreur ne lancait pas le Web Services.

     

    Cordialement, 

    jeudi 6 mars 2008 19:12

Toutes les réponses

  • L'installation de SSRS sur une machine Vista nécessite quelques opérations de configurations spécifiques.

     

    Celles-ci sont listées ici:

    http://support.microsoft.com/default.aspx/kb/934164/en-us

    mardi 4 mars 2008 17:29
  • Merci pour la réponse.

     

    J'ai déjà lu (et relu) cet article en anglais comme en français et bien entendu je l'ai appliqué à la lettre pour un résulatt négatif. L'anomalie concerne le point 8b de l'article mentionné.

     

    Si vous avez une autre idée, je suis preneur...

    mardi 4 mars 2008 21:06
  • Si vous essayez de vous connecter à SSRS via le Management Studio, vous obtenez quel résultat ?

    mercredi 5 mars 2008 08:55
  • Bonjour,

     

    La remarque est judicieuse. Mais, les résulatst des tests que j'ai effectués avec Management Studio, sont les même que ceux lorsque j'essaye de me connecter au gestionnaire du serveur de rapport (http://localhost/Reports), à savoir une erreur 500 qui signale que le seurveur de rapport n'est pas disponible. Je reviens au même problème, à savoir corriger le problème du serveur de rapport (http://localhost/ReportServer).

     

    Comme la désinstallation et la réinstallation aussi bien de IIS que de SQL Serveur 2005 ne solutionnent pas mon problème, je ne sais plus quoi faire. Est-ce un problème de droit d'accès (notamment lié à l'UAC de Vista) ? Si oui, lequel ?

    mercredi 5 mars 2008 17:50
  • Bonsoir,

     

    J'ai trouvé par hasard. Dans IIS, au niveau du serveur virtuel de Reporting Services (ReportServer), une erreur s'est glissé au niveau de la définition du module Isapi, le chemin contenait deux anti-slash (\\). Cette erreur ne lancait pas le Web Services.

     

    Cordialement, 

    jeudi 6 mars 2008 19:12