none
faille dans sharepoint2007 RRS feed

  • Question

  • Bonjour,
    j'ai un soucis avec le moss2007,
    lorsque je veux changer d'utilisateurs on m'affiche " impossible d'afficher la page " pourtant mon active directory est en marche et je me suis pas trompé d'identifiant ni de mot de passe , j'ai remarqué que lorsque j'effectue des modifications au niveau du designer vu ke je suis obligé , y'a toujours un soucis au niveau du portail et la c'est l'authentification qui passe pas !!!
    quelqun aurait deja rencontré ça ??? ou aurait une explication ???
    mercredi 7 octobre 2009 04:48

Réponses

  • Bonsoir,

    Supposons que vous êtes en version X.Y :
    X représente le nombre de versions majeures
    Y représente le nombre de versions mineures (à patir de la dernière version majeure)

    Donc quand il y a affiché version 1.2 c'est que la page a une version majeure (publiée) qui est la version 1.0, et que la page en est à sa deuxième modification mineure (.2)

    Les lecteurs voient la dernière version principale (1.0) et les admins voient la dernière version mineure (1.2).
    A chaque fois que vous modifiez puis archivez un fichier, le numéro de version augmente.

    Bref, toujours pour ces 2 fichiers cliquer sur "Archiver" si c'est présent,
    Cliquer sur "Publier une version principale" si c'est présent,
    Cliquer sur "Approuver/Rejeter" si c'est présent et faites Approuver.

    Le but, c'est qu'à la fin, dans la colonne "Statut d'approbation", ça soit marqué "Approuvé".

    Et là, ça marche ?

    Bonne soirée,
    Sylvain
    • Marqué comme réponse starrr dimanche 11 octobre 2009 18:55
    vendredi 9 octobre 2009 22:16
    Auteur de réponse

Toutes les réponses

  • Bonjour,

    Pouvez vous donner plus de détails :
    - Sur quelles pages rencontrez vous l'erreur "impossible d'afficher la page" (après avoir changé d'utilisateur) ?
    - Quand vous avez ce message, réussissez vous à accéder au site avec cet utilisateur en faisant F5 ou en allant sur une autre URL ?
    - Quand vous parlez du "designer", vous parlez de SharePoint Designer ou de la page en mode édition ?
    - "y'a toujours un soucis au niveau du portail" : dans quels cas précis, pour quels types d'utilisateurs ? Quelle est l'erreur que vous rencontrez ?

    Avec ces informations, il sera plus facile de vous aider...

    Cordialement,
    Sylvain

    mercredi 7 octobre 2009 20:58
    Auteur de réponse
  • Bonjour,
    - je rencontre l'erreur "impossible d'afficher la page " sur la page principale de mon portail 
    - et en actualisant la page y'a rien qui se passe y'a toujour la page " impossible d'afficher la page " meme en changeant l'URL par un autre.
    - oui c'est en modifiant dans sharepoint designer que j'ai constater qu'il en suit des erreur ou des probleme, 
    - je vous donne un exemple des probleme que j'ai deja rencontré apres avoir modifié dans le design de la page maitre dans sharepoint designer : une fois j'ai constaté que le moteur de recherche ne fonctionnais plus , en tapant un mot clé j'avais la page " impossible d'afficher la page " 
    une autre fois c'etait d'autre pages qui repondaient plus comme bibliothéque d'image, FAQ .....

    et là le type d'utilisateur que j'entre c'est " utilisateur lecteur " equivelent à " employé " dans la société pour laquelle je boss et donc chaque employé a droit de lecture sauf sur le forum et le partage de fichier, et boite à idée  où il a plus de droit que la lecture.

    Voila tout, 

    Cordialement,
    Lucie   
    jeudi 8 octobre 2009 06:52
  • Bonjour,

    Merci pour ces précisions.
    Quand vous faites des modifications via SharePoint Designer (ou autre), archivez vous bien vos modifications en version Publiée ?

    Sinon, d'un point de vue générale, vous utilisez SharePoint Designer pour modifier vos sites en recette ou en prod en direct ?
    Avez vous installé les derniers service packs (le 2) à SharePoint Designer ?

    Il faut faire très attention dans l'utilisation de SharePoint Designer, celui ci étant très puissant, mais quelque peu buggué sans Service Pack.

    Bonne journée,
    Sylvain
    jeudi 8 octobre 2009 07:23
    Auteur de réponse
  • Bonsoir,
    Merci de m'avoir répondu,
    en fait lorsque j'effectue des modif via sharepoint designer j'enregitre la page puis j'actualise mon portail sur le navigateur pour voir les modifications mais je pense pas que ce soit de sa que vous parler en disant " archiver " ; pourais je savoir comment faire pour effectuer l'archivage en version publiée ??
    et non je n'ai pas installé la derniere version du pack 2 , pourai je avoir un lien ou la télécharger ???

    Merci d'avance ,
     
    Bonne nuit.
    Lucie
    jeudi 8 octobre 2009 20:35
  • Bonsoir,

    pour ce qui est du service pack 2, le voici ici :
    http://www.microsoft.com/downloads/details.aspx?familyid=88EFF285-0B92-45ED-979B-65AA22304DD6&displaylang=fr

    Pour ce qui est de l'archivage :
    En générale, toutes les pages (sauf par ex pour la page default.aspx en WSS), page layouts et master page (pages maitres) sont stockées dans des bibliothèques de documents.
    Ainsi, il y a en standard un systèmes de versioning et de versions mineures et majeures.
    Je vous conseille de lire cette page : http://office.microsoft.com/fr-fr/help/HA100215761036.aspx

    Toujours est-il que :
    - Si votre page n'est pas archivée, uniquement l'utilisateur qui modifie la page pourra y accéder
    - Si votre page n'est archivée qu'en version mineures, uniquement les administrateur (ou contributeur, ça dépend de paramètres) la verront.

    Pour savoir à quelle version se situe votre page, vous pouvez faire un clique droit dessus dans SharePoint Designer (via le menu de navigation à gauche), puis cliquer sur "Version History" ('Historique des versions" en français ?).
    Pour archiver votre page, clique droit, archiver. Si les versions mineures et majeures (publiées) sont activées, alors SharePoint Designer vous proposera l'une des 2 options.
    Vous pouvez aussi le faire depuis l'interface web en allant sur la bibliothèque de document hébergeant votre page.

    Bonne nuit (ou bon matin)
    Cordialement,
    Sylvain
    jeudi 8 octobre 2009 22:20
    Auteur de réponse
  • Bonjour,
    je vous remercie pour ces informations, effectivement l'option de versioning est tres interessante et indisponsable, cependant le  probleme de la page avec le message " impossible d'afficher la page " qui apparait en changeant d'utilisateurs existe toujours et je ne vois pas ou est la cause !
      
    Bonne journée .
    Lucie :)
    vendredi 9 octobre 2009 10:54
  • Bonjour,

    Première Question : Est-ce que c'est un site avec la publication activée ?
    Si vous ne savez, pas, une astuce c'est que si l'URL de la page d'accueil contient "/pages/..." alors, c'est certainement un site avec la publication activée

    Pouvez vous vérifier si la MasterPage (et la page layout si la fonction de publication est activée) sont bien publiées ?

    Pour en être sur, allez sur cette url :
    http://{RACINE_DU_SITE}/_catalogs/masterpage
    Sur la masterpage du site, cliquez sur "Afficher l'historique".
    Pareil pour la page layout
    Si la dernière version est en 0.X c'est qu'il n'y a pas de version publiée.

    Bon aprem,
    Sylvain
    vendredi 9 octobre 2009 12:32
    Auteur de réponse
  • Bonsoir,

    Alors pour votre premiére question: l'URL de la page d'accueil contient bien /pages/ donc j'imagine que la publication est activée!

    ensuite, j'ai été sur l'URL que vous m'avez transmise , concernant la master page sa version est 1.0 ya affiché aussi 1.1 et 1.2 pour une date plus recente que celle des version précedentes!

    pareil pour la defaultlayout sa version est 1.0 et y'a affiché aussi 1.1 pour une date plus recente que celle de 1.0 !!

    pouvez vous me décrypter tout ça svp :)

    Merci d'avance 

    Lucie
     
    vendredi 9 octobre 2009 21:54
  • Bonsoir,

    Supposons que vous êtes en version X.Y :
    X représente le nombre de versions majeures
    Y représente le nombre de versions mineures (à patir de la dernière version majeure)

    Donc quand il y a affiché version 1.2 c'est que la page a une version majeure (publiée) qui est la version 1.0, et que la page en est à sa deuxième modification mineure (.2)

    Les lecteurs voient la dernière version principale (1.0) et les admins voient la dernière version mineure (1.2).
    A chaque fois que vous modifiez puis archivez un fichier, le numéro de version augmente.

    Bref, toujours pour ces 2 fichiers cliquer sur "Archiver" si c'est présent,
    Cliquer sur "Publier une version principale" si c'est présent,
    Cliquer sur "Approuver/Rejeter" si c'est présent et faites Approuver.

    Le but, c'est qu'à la fin, dans la colonne "Statut d'approbation", ça soit marqué "Approuvé".

    Et là, ça marche ?

    Bonne soirée,
    Sylvain
    • Marqué comme réponse starrr dimanche 11 octobre 2009 18:55
    vendredi 9 octobre 2009 22:16
    Auteur de réponse
  • Bonsoir,

    j'ai suivi les étapes là et y'a marqué dans la colonne " statut d'approbation " , " Approuvé"
    et ça a reglé le probleme au niveau de l'authentification puisque je ne reçois plu le message " impossible d'afficher la page"

    je vous remercie infiniment pour vos réponses et votre aide :)

    Cependant un petit soucis s'est engendré : lorsque j'accéde a la page principal du portail avec un autre identifiant ( employé ) hors l'administrateur; la baniere que j'ai crée ( une animation avec flash ) ne s'affiche plus , c'est à dire qu'elle s'affiche lorsque je me connecte en tant qu'administrateur mais pas lorsque je me connecte en tant qu'autre ..

    aurez-vous une idée qui pourai régler ce soucis ??

    Merci encor.

    Cordialement
    Lucie  
    dimanche 11 octobre 2009 18:48
  • Bonsoir,

    Pour votre nouveau souci, là encore c'est que votre animation flash n'est surement pas archivée / publiée / approuvée.
    Donc, allez dans la blibliothèque de document ou se trouve votre animation flash (via votre navigateur web).
    Et Archivez / publiez / approuvez votre élément.

    Si vous utilisez cette collection de site comme environnement de DEV, vous pouvez très bien enlever tout ce mécanisme de publication / validation.
    Il suffit d'aller dans les paramètres de la liste en question et d'aller dans "Paramètre de version" puis désactiver l'approbation et ne créer que des versions principales par exemple.

    Bonne semaine,
    Sylvain
    dimanche 11 octobre 2009 23:44
    Auteur de réponse
  • Bonjour,

    Je viens de vérifier mon animation elle est déja archivée, meme dans l'option parametres de version de la bibliothéque d'image , l'approbation est désactivée.

    je ne vois pas ou est le probleme, 

    Cordialement 
    Lucie 
    mardi 13 octobre 2009 05:59
  • Bonjour,

    Il peut y avoir plusieurs explications :
    Soit un élément contenant le Flash n'est pas visible, soit c'est le flash en lui même qui n'est pas visible.

    Dans tous les cas, c'est surement un problème de droits, soit un problème d'archivage / publication.
    - Ou le Flash est-il inséré ? Dans une webart ? dans une page layout ... ?
    - La sécurité de l'élément Flash est-elle différente  ?
    - D'une façon générale, dans une page, pour voir les éléments qui risquent de poser problème, il y a un outil pour ça :
    Passer en mode Edition, puis "Outils", puis "Vérifier les éléments non publiés".


    Cordialement,
    Sylvain
    mercredi 14 octobre 2009 04:35
    Auteur de réponse
  • Bonjour,

    mon animation flash , je l'ai insérer en éditant du code dans le sharepoint designer , je n'ai pas touché à la sécurité de l'animation .
    alors j'ai fais outils puis " vérifier les éléments non publié " et y'a le logo de l'entreprise qui est entouré de pointillé rouge ainsi que le compteur du nombre de visiteur mais pas l'animation flash .

    j'ai fais " afficher l'état de la page " et j'ai eu cet affichage :
    Vous consulter une version extraite de la page
    version actuelle de la page: il existe une version publiée 14.0 qui est visible par tous les utilisateurs
    Date de publication : aucune date
    Date de fin : aucune date
    Il n'y a aucune version brouillon disponible

    y'aurait-il quelque chose d'anormal ?

    Merci d'avance.

    Lucie
    mercredi 14 octobre 2009 05:59
  • je viens de revérifier mon portail avec un autre utilisateur et je remarque que meme le compteur du nombre de visiteur ainsi que la bande de texte déroulante , ne s'affichent pas

    chez les utilisateurs autres que l'administrateur. je pense qu'ya un rapport entre les 3 ( animation que j'ai ajouté en éditant du code , bande deroulante et compteur que j'ai ajouté

    en insérant des composants web dans le designer !!

    qu'en pensez vous ?

    Merci et bonne journée

    mercredi 14 octobre 2009 06:21
  • Bonjour,

    Je n'ai pas de solution miracle.
    Juste une question :
    Le flash et les autres composants, vous les avez rajoutés dans quelle page ? Dans la masterPage ? Dans la page layout ? Dans la page en elle même ?

    Je m'explique :
    En fonctionnement MOSS Publishing (ce qui semble être votre cas), ce qu'on appelle "la page", n'est qu'un ensemble de "Méta données" : contenu de zones de texte, titre....
    Les pages reposent sur des pages layout qui structurent le contenu. Ces pages layout reposent sur des master pages qui structurent l'ensemble de la page.
    Il y a donc 3 niveaux :
    - Page (données)
    - Page Layout (structure les données dans la page)
    - Master Page (structure l'ensemble des zones dans la page)

    Tout ça pour dire que je peux pas vous dire ce qui ne va pas si je ne sais pas ou ont été ajouté ces différents composants.

    Le problème vient surement d'un des éléments suivants ( qui n'est peut être pas archivé / publié  / sécurité différente.)
    - Composant (pour le fichier flash par exemple ou des images....)
    - Page
    - Page Layout
    - master page


    Bonne journée,
    Sylvain
    jeudi 15 octobre 2009 22:05
    Auteur de réponse
  • Bonjour,

    Alors effectivement j'ai ajouté mes composants dans la master page .

    Cordialement.
    vendredi 16 octobre 2009 10:55
  • Bonjour,

    Dans ce cas, la masterpage est-elle bien publiée/appouvée ?
    Si c'est le cas alors le problème vient forcément de l'élément référencé dans la masterpage :
    - Soit l'élement n'est pas archivé / publié / approuvé,
    - soit la sécurité de l'élément est différente de celle appliquée sur le site.
    ...
    Ou sont enregistrés les flashs et autres éléments ?

    Bonne semaine
    Sylvain
    dimanche 18 octobre 2009 20:24
    Auteur de réponse
  • bonjour,

    oui la master page est bien publiée et approuvée .

    le flash est enregistré dans une bibliothéque d'images et les autre élément c'est des composants web donc je les ai intégré directement sans les enregistrer ni quoi que ce

    soit , je pense meme qu'il n'est pas possible de les enregistrer ni de les approuver puisque c'est des composant web .

    Bonne journée.
    Lucie
    mardi 20 octobre 2009 05:38
  • Bonjour,

    Quel casse tête !
    Puisque la master page est publiée et approuvée ( la version est bien X.0 , X étant un entier?), c'est que le souci est au niveau de l'élément intégré, je ne vois pas d'autres explications possibles.
    Dans ce cas, pour le Flash, pouvez vous regarder la sécurité de l'élément -> Gérer les autorisations et vérifier que les lecteurs y ont bien accés ?
    Pour le composant, de quel type est-il ? Fait-il référence à un élément d'une liste ou à une image ?

    Bonne soirée,
    Sylvain
    mardi 20 octobre 2009 22:11
    Auteur de réponse