locked
Notifications Push RRS feed

  • Question

  • Bonjour,

    J'essaie de faire fonctionner les notifications push depuis un serveur PHP vers une appli Windows Phone 8.1.

    L'appli ouvre bien un canal et l'envoie à mon serveur (format https://db3.notify.windows.com/?token=...), j'obtiens bien un access_token pour mon appli avec mon client ID et le secret, mais lorsque j'envoie le xml, j'ai une réponse "Invalid Channel URL".

    Le site http://31daysofwindows8.com/push me fait la même chose.

    Comment l'URI du canal peut-elle être incorrecte si elle est fournie par le serveur Microsoft ?

    Merci


    ben2paris

    lundi 9 février 2015 12:10

Toutes les réponses

  • Bonjour,

    Votre application windows phone est-elle enregistrée sur le store ?

    Il faut que votre application soit liée au Windows store app pour que les notifications push fonctionnent.

     Plus d'infos :

    To associate your app with the Windows Store
    1. In  Solution Explorer, right-click  your project and then select Store > Associate App with the Store.

    2. In the Associate Your App with the Windows Store dialog box, click Next. You'll  be prompted to sign in to the Windows Store.

    3. On the Sign In page, sign in to the Windows Store and then click Next.

    4. On the Select an app name for this package page, select the App Name you have reserved. You can also click Reserve Name to go to the Windows Store to reserve one.

    5. After an app name is selected, click Next.

    6. On the summary page, review the values that you have selected. If it looks good, click Associate. Otherwise, click Previous to go back and fix any errors. Clicking Associate automatically downloads the publisher display name and other values into the app package manifest.

    Cordialement,


    Kevin BEAUGRAND, Modis FRANCE
    Merci de bien vouloir "Marquer comme réponse", les réponses qui ont résolu votre problème.

    • Marqué comme réponse ben2paris lundi 9 février 2015 13:21
    • Non marqué comme réponse ben2paris mardi 24 février 2015 11:27
    lundi 9 février 2015 12:45
  • Oui, c'est le cas, elle est associée, d'où mon questionnement...

    Merci


    ben2paris

    lundi 9 février 2015 12:48
  • Bonjour,

    Pouvez-vous nous donner une copie de la requête et de la réponse obtenue (via Fiddler par exemple) ?

    (En obfusquant le token).

    Cordialement,


    Kevin BEAUGRAND, Modis FRANCE
    Merci de bien vouloir "Marquer comme réponse", les réponses qui ont résolu votre problème.

    lundi 9 février 2015 13:07
  • Bonjour,

    J'ai ré essayé pour la 10ème fois au moins, de lier mon app au store, et ça a fonctionné, désolé pour le dérangement.

    Merci


    ben2paris

    lundi 9 février 2015 13:21
  • J'ai crié victoire trop vite. En test, depuis Visual Studio, tout va bien. Ensuite, je crée le pachage et je le publie sur le store, et là, Invalid Channel URL...

    Donc en développement, ça fonctionne, en production, non :(

    Des idées ?


    ben2paris

    lundi 9 février 2015 16:30
  • Bonjour,

    Même question que tout à l'heure :

    Pouvez-vous nous donner une copie de la requête et de la réponse obtenue (via Fiddler par exemple) ?

    (En obfusquant le token).

    Et question subsidiaire, cela fonctionne-t'il toujours en DEV  ?

    Cordialement,


    Kevin BEAUGRAND, Modis FRANCE
    Merci de bien vouloir "Marquer comme réponse", les réponses qui ont résolu votre problème.


    lundi 9 février 2015 16:40
  • Bonsoir,

    Je ne sais pas comment faire, je teste avec le site mentionné dans mon 1er post.

    Merci


    ben2paris

    lundi 9 février 2015 22:40