none
Compact 4.0 et EF4 RRS feed

  • Question

  • Bonjour ,

    je voudrais travailler avec SQL Server Compact 4.0 et Entity framework.

    J'ai installé les outils suivants ;

    Windiws 7 , VS 2010 SP1 , SQL Server compact 4.0 et ADO.Net entity frameworrk 4.1 . Mais quand je veus creer un edmx ou faire un code first , je ne vois jamais le sql server compact 4.0 , seule le 3.5 est proposé.

    Pourtant la librairy me dit que cela est possible ( vois ci dessous )

    Améliorations apportées aux API

    • Intégration d'ADO.NET Entity Framework 4.0 (.NET Framework 4)

      SQL Server Compact 4.0 prend en charge le modèle de programmation « code-first » d'ADO.NET Entity Framework. Par ailleurs, les colonnes qui disposent de clés générées par le serveur, comme identity ou rowguid, sont également prises en charge dans SQL Server Compact 4.0 si elles sont utilisées avec ADO.NET Entity Framework 4 (il s'agit de la version d'ADO.NET Entity Framework publiée avec .NET Framework 4).

    J'oublie peut etre quelquez chose.

    merci de votre aide  Anthride 

    • Déplacé Ciprian Duduiala jeudi 23 février 2012 11:04 (Origine :SQL Server pour les développeurs)
    mardi 21 février 2012 08:47

Réponses