none
Neutraliser le menu "ouvrir avec l'explorateur windows" dans le menu "actions" d'une bibliotheque RRS feed

  • Question

  • Bonjour a vous tous
    Savez vous s'il existe un moyen de supprimer le menu "ouvrir avec l'explorateur  windows" dans le menu "actions" d'une bibliotheque ? J'ai un souci à ce niveau car j'ai attribué des droits en lecture seule sur un dossier de ma bibliotheque : c'est donc ok pour le groupe correspondant --> le clic droit sur nom du repertoire de propose que les trois sous menus :
    - afficher les proprietes
    - historique
    - m'avertir

    Mais si j'active le menu "ouvrir avec l'explorateur  windows" dans le menu "actions" , la j'ai acces à l'enesmble du repertoire et je peux supprimer tout ce que je veux ...
    Y a t il moyen de supprimer ce menu ? Faut il creer une webpart expres ?
    Merci d'avacne
    Bonne journée

    ALain
    jeudi 3 décembre 2009 09:13

Réponses

  • Bonjour,

    Je pense que le problème vient plutot de la façon de tester : Faisiez vous "Se connecter en tant que..." pour tester avec un autre utilisateur ?

    Lorsque vous cliquez sur "Ouvrir avec l'explorateur Windows", SharePoint lance une nouvelle fenêtre Explorer.
    Cette nouvelle fenêtre explorer tourne avec le compte votre session windows, et non de votre session SharePoint.

    Pour tester dans des conditions réelles, déconnectez vous de votre session windows, et reconnectez vous avec un compte qui n'a que des droits en lecture.
    Sinon, vous pouvez aussi faire un "Run as" sur un explorateur windows, et via les favori réseau, accéder à la bibliothèque de document.

    Quand un utilisateur n'a que des accés en lecture, peu importe la façon de se connecter à la liste (Explorateur Windows, Navigateur Web, Code ....), il ne devrait jamais avoir la possibilité de supprimer un élément.

    Bonne journée,
    Sylvain
    • Proposé comme réponse Sylvain ReverdyEditor vendredi 4 décembre 2009 00:20
    • Marqué comme réponse algeox vendredi 4 décembre 2009 06:09
    vendredi 4 décembre 2009 00:20
    Auteur de réponse

Toutes les réponses

  • Bonjour,

    Je pense que le problème vient plutot de la façon de tester : Faisiez vous "Se connecter en tant que..." pour tester avec un autre utilisateur ?

    Lorsque vous cliquez sur "Ouvrir avec l'explorateur Windows", SharePoint lance une nouvelle fenêtre Explorer.
    Cette nouvelle fenêtre explorer tourne avec le compte votre session windows, et non de votre session SharePoint.

    Pour tester dans des conditions réelles, déconnectez vous de votre session windows, et reconnectez vous avec un compte qui n'a que des droits en lecture.
    Sinon, vous pouvez aussi faire un "Run as" sur un explorateur windows, et via les favori réseau, accéder à la bibliothèque de document.

    Quand un utilisateur n'a que des accés en lecture, peu importe la façon de se connecter à la liste (Explorateur Windows, Navigateur Web, Code ....), il ne devrait jamais avoir la possibilité de supprimer un élément.

    Bonne journée,
    Sylvain
    • Proposé comme réponse Sylvain ReverdyEditor vendredi 4 décembre 2009 00:20
    • Marqué comme réponse algeox vendredi 4 décembre 2009 06:09
    vendredi 4 décembre 2009 00:20
    Auteur de réponse
  • Bonjour Sylvain et merci pour cette confirmation.
    A force de tester, je m'étais effectivement rendu compte que l'option se connecter en tant qu'utilisateur différent, réagit différement que lorsque'on modifie la session windows ...
    Bonne journée à vous et merci
    Alain
    vendredi 4 décembre 2009 06:09