none
Une application winform qui ne s'affiche plus RRS feed

  • Question

  • Bonjour,

    Je suis en Windows 10 et je travaille avec le FrameWork 4.5.2. j'ai développé une application WinForm en VB.NET. Dans Visual Studio, elle s'exécute sans problème. Mais lorsque je l'exécute par l'explorateur Windows, elle ne s'affiche plus. Je dis "plus", car elle s'affichait correctement jusqu'il y a quelques jours. J'en avais arrêté le développement. 

    Avez-vous un conseil à me donner pour que mon application s'affiche de nouveau ? 

    Merci beaucoup, 

    Cordialement. 

    Paul Van Walleghem

    mardi 28 mars 2017 18:25

Réponses

  • Je pense avoir trouvé l'erreur. En tous cas, le formulaire de la solution B s'affiche de nouveau. J'ai enlevé la liaison de la propriété "Location" du formulaire avec le paramètre de l'application qui lui réservé.

    Cordialement

    jeudi 30 mars 2017 10:00

Toutes les réponses

  • Bonjour,
    Recevez-vous une message d'erreur?

    Cordialement,
    Nina

    Microsoft propose ce service gratuitement, dans le but d'aider les utilisateurs et d'élargir les connaissances générales liées aux produits et technologies Microsoft. Ce contenu est fourni "tel quel" et il n'implique aucune responsabilité de la part de Microsoft.

    mercredi 29 mars 2017 13:54
    Modérateur
  • Pas tout le temps. Mais ce matin, j'en ai (enfin) eu un. C'était:

    "Expiration du délai d'attente. Le délai s'est écoulé avant obtention d'une connexion du pool. Ceci est probablement dû au fait que toutes les connexions regroupées sont en cours d'utilisation et que la taille du pool a été atteinte."

    Je crains plutôt une erreur d'architecture de mon programme. je vais essayer d'être clair.

    En fait, j'ai 2 solutions Visual Studio qui sont chacune compilée en exécutable. Comme dans la solution A se trouvent beaucoup de fonctions nécessaires à la solution B (notamment toutes celles qui concernent l'accès à la base de données), la solution B fait référence à la A et y appelle les fonctions dont elle a besoin. Je précise que A ne fait pas référence à B.

    Ce système fonctionnait très bien jusqu'à il y a quelques jours. je ne touchais plus au code et j'utilisais quotidiennement l'application.

    Puis, le formulaire de B ne s'est plus affiché. Son icône apparaît bien dans la barre des tâches. Il est répertorié dans le gestionnaire de Windows. Mais où est-il? Et pourquoi s'est-il affiché et qu'il ne s'affiche plus?

    Pouvez-vous m'aider à résoudre cette énigme?

    Merci.

    mercredi 29 mars 2017 20:38
  • Je pense avoir trouvé l'erreur. En tous cas, le formulaire de la solution B s'affiche de nouveau. J'ai enlevé la liaison de la propriété "Location" du formulaire avec le paramètre de l'application qui lui réservé.

    Cordialement

    jeudi 30 mars 2017 10:00