none
Problème d'accès à l'isolatedstore pendant un retour à l'appli RRS feed

  • Question

  • En fait j'ai remarqué que lorsque je sauvegarde l'état de l'application dans l'IsolatedStorageSettings.ApplicationSettings, jusque que je désactive puis re-active l'application, toute tentative de ma part de lire cet IsolatedStorageSettings.ApplicationSettings se soldera par une zone avec 0 key.

    Et ce pas forcément que dans la fonction "Application_Activated", mais quelle que soit la page, du moment que c'est après une réactivation.
    Pourtant dans l'exemple de code fourni par Microsoft ça fonctionne bien, avec les mêmes commandes, exactement.

    J'ai fais tous les tests que j'ai pu, et je me tire vraiment les cheveux dessus :S

    Vous avez déjà rencontré ce cas ?

    Merci beaucoup d'avance

    mardi 6 septembre 2011 23:51

Réponses

  • Je pense que c'est surtout que tes données ne sont pas sauvegardé :)

     

    Fais attention à :

    - la limite de l'ApplicationSettings est de 2Mbits

    - que tu as bien des objets serializable (avec des mots clés [DataContract] [DataMember] notamment

    - attention à l'héritage, il faut ajouter les [KnownType]


    S'il vous plaît n'oublier pas de marquer la ou les réponses qui aident à résoudre votre problème. Pour que la discussion puisse être marquée comme résolue
    • Marqué comme réponse Neo33ASM mercredi 7 septembre 2011 15:19
    mercredi 7 septembre 2011 14:46
    Modérateur

Toutes les réponses

  • Je pense que c'est surtout que tes données ne sont pas sauvegardé :)

     

    Fais attention à :

    - la limite de l'ApplicationSettings est de 2Mbits

    - que tu as bien des objets serializable (avec des mots clés [DataContract] [DataMember] notamment

    - attention à l'héritage, il faut ajouter les [KnownType]


    S'il vous plaît n'oublier pas de marquer la ou les réponses qui aident à résoudre votre problème. Pour que la discussion puisse être marquée comme résolue
    • Marqué comme réponse Neo33ASM mercredi 7 septembre 2011 15:19
    mercredi 7 septembre 2011 14:46
    Modérateur
  • je vais vérifier la limite de taille, sinon j'ai bien créé des objets sérializable, et par contre je vois pas ce qu'est un knowntype
    mercredi 7 septembre 2011 15:03
  • encore une fois tu as vu juste, c'est la limite de taille qui est apparemment dépassée...

    je dois donc créer un fichier à la place de settings ?

    mercredi 7 septembre 2011 15:17