none
[MOSS 2007] Probleme de Webpart Utilisateurs de Site RRS feed

  • Question

  • Normalement avec ce Webpart on a les possilibités de :
    - Afficher les personnes et groupes disposant d'autorisations directes à ce site
    - Afficher les personnes dans le groupe de membres de ce site
    - Afficher les personnes dans le groupe : ( choisir, un utisateur ou un groupe de AD ).
    Cette Webpart,selon ce que j'ai compris, permet d'afficher l'état "en ligne " , des personnes affichées !
    Mon problème, c'est que j'arrive à affcher les personnes mais sans pouvoir afficher leurs statuts en ligne ou pas !!!! . Est-ce normale ?? ( j'utilise un site espace de travail )
    vendredi 25 mai 2007 14:42

Toutes les réponses

  • Bonjour

     

    Les statuts en ligne fonctionnent de pair avec LCS (Live Communications Server), le "MSN d'entreprise".

     

    De plus, il faut que le site soit marqué comme Trusted ou en Local intranet pour que le script affiche correctement les états de disponibilité.

    vendredi 25 mai 2007 19:39
  • Le site et en local " intranet " !! Mais, MSN d'Entreprise je ne l'ai pas installé !! Est-ce obligation d'Installer MSN Entreprise ?? Pourquoi sur le WSS 2, ça marche sans prob et sans installer MSN ??
    lundi 28 mai 2007 07:28
  • Normalement il y a l'intégration avec Exchange qui permet de voir le planning et différentes infos, mais l'information de présence en elle-même ne devrait être disponible qu'avec LCS.

     

    J'ai quand même un doute du coup, mais je ne trouve que peu d'information dessus (et sur le seul test que j'ai pu réaliser seule la personne ayant une adresse SIP et testé Communicator avait une "pastille" pour la présence).

     

    Donc si qqun est en mesure d'infirmer ou non cette info, je suis preneur !

    lundi 28 mai 2007 12:35
  • Salut,

     

    Par rapport à mon utilisation personelle, je confirme vos infos. L'indication de présence semble indépendante d'Exchange, elle s'active seuelkment quand MSN est ouvert avec un compte @monEntreprise.fr

    lundi 28 mai 2007 14:37
  • Salut,

    Donc, je dois installer MSN Entreprise ??  ou bien, c'est une config à faire ??

    Merci.

    lundi 28 mai 2007 14:39
  • Salut,

     

    J'ai juste MSN Messenger, mon collègue a MSN Live et ça marche très bien Wink

     

     

    mardi 29 mai 2007 13:42
  • Et l'email utilisé dans SharePoint est votre adresse Live du coup non ?
    mardi 29 mai 2007 14:16
  • Oui tout a fait, nous nous sommes créés des comptes MSN Live avec nos adresse de session (login@notreentreprise.fr)
    mercredi 30 mai 2007 13:06
  • Ok, c'est pour cela alors, je comprends mieux, je traine tjrs de vieux Live ID en hotmail.

     

    Dans ce cas, si l'entreprise ne bloque pas MSN et si les gens sont prêts à s'y inscrire, c'est effectivement le bon moyen d'arriver à la notification de présence.

     

    Merci Rocc pour ces informations supplémentaires !

    mercredi 30 mai 2007 13:14
  • Oui bien entendu, il faut pas que l'entreprise bloque MSN. Dans la mienne c'est le cas, j'ai donc opté pour cette solution, plutot que MSN Entreprise
    mercredi 30 mai 2007 13:30
  •  Rocc A écrit:
    L'indication de présence semble indépendante d'Exchange, elle s'active seuelkment quand MSN est ouvert avec un compte @monEntreprise.fr

    Je ne sais pas si par @monEntreprise.fr, vous parliez forcément de l'adresse utilisée en interne pour la messagerie... Mais après avoir fait quelques tests, j'arrive finalement à avoir la présence active avec des adresses quelconque comme @mail.com ou autre en renseignant l'adresse SIP sur SharePoint, et effectivement en utilisant des comptes Live.

    L'objectif étant que les employés puissent continuer à utiliser leurs comptes MSN usuels.

     

    Ce qui s'annonce bien, c'est que ça a également l'air de marcher entre utilisateurs de zones différentes ! Smile

    mercredi 13 juin 2007 19:08
  • Salut,

    Ah je n'avais pas testé car je ne connais pas trop ce paramètre. Est il configurable dans l'Active Directory ? Est ce que chaque utilisateur peut le modifier en allant dans son site perso (MySite) ?

    Merci d'avance
    jeudi 14 juin 2007 10:01
  • Oui, ce paramètre est configurable.

    Pour ce faire, il faut aller dans la configuration du SSP, puis dans UserProfiles&Properties, ViewProfileProperties, et editer SIPAddress pour :

    1) autoriser les utilisateurs à éditer les valeurs de la propriété

    2) mapper la propriété à une source de données (par exemple avec mon AD, j'ai pris "ipPhone")

    Bien que le (1) a l'air de bien fonctionner, j'ai quelques soucis avec le (2) où SharePoint n'a pas l'air de prendre en compte les modifs que je fais dans l'AD.... (après importation de profiles)

     

      Cependant, j'ai auparavant fait marcher la détection de présence pour Outlook, c'est pourquoi j'aimerais être sûr que cette dernière manip n'est pas "utile"... (cf. article) Donc si vous pouviez tester de votre coté ! Smile

    jeudi 14 juin 2007 18:27
  • Bonjour,

     

    Sur WSS 3 (peut-être aussi sur MOSS) il suffit d'aller dans Personnes et groupes, de cliquer sur la personne en question ou sur votre profil, d'éditer les propriétés et dans "Adresse SIP" mettre l'adresse msn.

    jeudi 19 juillet 2007 08:23
  • Bonjour à tous !

    Je me permets de remonter cette discussion plutôt que d'en créer une nouvelle.

    J'utilise WSS 3.0 et j'ai placé un WebPart « Utilisateurs du site » sur la page d'accueil d'un site qui sera accessible sur internet par des utilisateurs divers (pas de la même entreprise).
    J'ai créé deux utilisateurs avec des adresses mail qui sont leurs adresses de connexion à Windows Live Messenger. Je les connecte chacun sur un poste sur lequel est installé Office 2003, car j'ai lu que c'était nécessaire.
    Le premier essai ne fonctionnait pas, puis j'ai appris qu'il fallait que l'adresse mail soit dans le champ « adresse SIP », ce que j'ai fait.
    Dans ce second cas, j'ai bien des pastilles qui se mettent devant les noms des utilisateurs. Mais... les utilisateurs sont marqués toujours hors-ligne même lorsqu'ils sont connectés au site (et Live Messenger est bien lancé sur les postes clients, au cas où ce serait nécessaire, je ne sais pas...)

    J'ai alors cru qu'il fallait Office Communicator et j'allais abandonner, mais je vois ici que certains ont réussi à le faire fonctionner sans, a priori.

    Pouvez-vous m'aider sur ce point s'il vous plaît ? Ce serait génial que ça fonctionne, mais je ne vois pas comment faire...

    Merci !! 
    mercredi 3 septembre 2008 17:03
  • En complément de mon message précédent : est-ce que le fonctionnement est différent entre WSS et MOSS ?

    Merci !
    mercredi 3 septembre 2008 17:08
  • Pour que la lisaison entre sharepoint et office communicator ou MSN fonctionne il faut le service pack 2 d'office 2003, sinon les puces restent grises...

     

    lundi 29 septembre 2008 15:39