none
Probléme d'affichage avec crystal report RRS feed

  • Discussion générale

  • je travaille sur un projet de gestion des ventes qui vas me permettre  d'imprimmer des factures, j'utilise le crystal report pour afficher ces factures, et je veux afficher le prix et le montant d'article vendue , le probleme ici c'est que l'execution marche tres bien mais lors l'affichage de crystal report viewer des caractéres de " #" s'affichent à la place  du champ " prix d'article " qeulqu'un m'aide svp et merci d'avance.
    • Type modifié Aurel Bera mercredi 23 juillet 2014 07:14 disc
    mercredi 16 juillet 2014 14:58

Toutes les réponses

  • Bonjour

    Comment vous calculez le champ "prix d'article"?

    Vous passez correctement les paramètres vers le rapport pour calculer ce champ?

    Voir cet article sur ce sujet :

    Printing Reports in Windows Forms


    Aurel BERA, MSFT
    MSDN Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE.
    S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    jeudi 17 juillet 2014 08:44
  • désolè je suis en retard

    non monsieur , " prix d'article" est un champ de table de ma base données et lorsque je veux afficher les prix des articles dans mon rapport , tous ces prix s'affichent sous formes des caractéres "#" , j'ai essayé de changer le type de   " prix d'article " dans la table " articles"  il a été float et maintenant décimal, mais le résultat est lui même .      merci beaucoup


    • Modifié mokialge lundi 21 juillet 2014 02:52
    lundi 21 juillet 2014 02:47
  • Bonjour

    Sauf erreur de ma part Crystal Report affiche # dans le cas où le champ n'est pas correctement liée a la source de données. 
    Essayez de supprimer ce champ et de le ré-ajouter (évidement, prenez une sauvegarde en avant).
    Les autres informations s'affichent bien?

    Bien cordialement,


    Aurel BERA, MSFT
    MSDN Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE.
    S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    lundi 21 juillet 2014 08:07
  • merci beaucoup ça marche bien , mais maintenant j'ai un autre problème, lorsque j'affiche ma facture ( crystal report ) le cristal m'affiche juste la première enregistrement c'est à dire le premier article avec ses propres informations comme le prix et le quantité vendue ..etc ( la facture peut avoir plusieurs articles) .

    j'ai essayé de tester la requête sql , mais elle marche très bien sur le SGBD . merci d'avance

    samedi 26 juillet 2014 01:30