none
<!--Application Resources--> RRS feed

  • Question

  • bonjour a toutes et a tous,

    voila, dans mon app, j'utilise le mode trial décris ici:

    http://www.silverlightshow.net/items/Windows-Phone-7-Creating-Trial-API-Applications.aspx

    C'est une appli phonegap, ca devrais fonctionner.

    Mon probleme:

    Dans la page app.xalm par exemple:

    je declare:

     xmlns:local="clr-namespace:nomdeassembly">

    puis une ressource:

    <Application.Resources>
            <local:ApplicationLicense x:Key="LicenseInfo" />
          </Application.Resources>
    

    Lesdit ApplicationLicense est un .cs qui est dans le projet et qui contiens ceci:

    using Microsoft.Phone.Marketplace;
    namespace nomassembly
    {
        public class ApplicationLicense
        {
            public bool IsInTrialMode
            {
                get
                {
    #if TRIAL
                    return true;
    #else
                    LicenseInformation license = new LicenseInformation();
                    return license.IsTrial();
    #endif
                }
            }
        }
    }

    j'enregistre bien le tout, je lance la build et dans la page App.xalm, j'ai droit a un jolie:

    Erreur 1 Le type 'local:ApplicationLicense' est introuvable. Assurez-vous qu'il ne manque aucune référence d'assembly et que tous les assemblys référencés ont été générés. C:\Users\patrice\documents\visual studio 2010\Projects\xxx\xxxxx\App.xaml 10 10 nomassembly

    et j'ai ca aussi pour une chose du meme genre dans la page mainpage.xalm

    J'y ai passer un bon moment, je suis quasi sur que c'est un truc vraiment idiot que j'ai oublier ou mal integrer.....mais tete dans le guidon je vois plus rien :)

    Merci de votre precieuse aide :)

    Patrice

    mercredi 26 septembre 2012 15:32

Réponses

  • bon dans la serie les mystere de vs....

    je ferme le capot de l'ordi vs ouvert, pour aller preparer le repas, il se met en veille.....

    je rallume et la y a plus d'erreur, tout est ok......

    pppffffff

    Patrice

    • Marqué comme réponse pbaranx mercredi 26 septembre 2012 17:56
    mercredi 26 septembre 2012 17:56

Toutes les réponses

  • Question con (chuis pas du tout un cador en WP) : tu as essayé de déclarer ta classe et ta méthode en "static" pour voir si ça change quelque chose ?
    mercredi 26 septembre 2012 15:41
  • je pense que je vais finir pas esseyer comme ca.....

    C'est juste que j'aimerais avoir le fin mot de l'histoire si c juste dans la facon de declarer :)

    mercredi 26 septembre 2012 15:55
  • est ce que tout ca est dans le même projet ? Si ce n'est le cas il faut rajouter l'assembly comme :

       xmlns:custom="clr-namespace:SDKSample;assembly=SDKSampleLibrary">


    S'il vous plaît n'oublier pas de marquer la ou les réponses qui aident à résoudre votre problème. Pour que la discussion puisse être marquée comme résolue

    mercredi 26 septembre 2012 16:00
    Modérateur
  • oui oui, tout est dans le meme projet.

    • Marqué comme réponse pbaranx mercredi 26 septembre 2012 17:54
    • Non marqué comme réponse pbaranx mercredi 26 septembre 2012 17:55
    mercredi 26 septembre 2012 16:06
  • bon dans la serie les mystere de vs....

    je ferme le capot de l'ordi vs ouvert, pour aller preparer le repas, il se met en veille.....

    je rallume et la y a plus d'erreur, tout est ok......

    pppffffff

    Patrice

    • Marqué comme réponse pbaranx mercredi 26 septembre 2012 17:56
    mercredi 26 septembre 2012 17:56