none
Récupération du nom d'utilisateurs windows en cours RRS feed

  • Question

  • Bonjour

    Je travail sur un site web asp.net j’utilise l’authentification mode forms mon besoin c’est de récupérer le nom d’utilisateur Windows  connecté

    J’ai essai avec 
                    HttpContext.Current.Request.ServerVariables["AUTH_USER"]
                    System.Security.Principal.WindowsIdentity

    Et  me retourne l’utilisateurs du IIS

    Aussi j’ai utilisé

    AppDomain.CurrentDomain.SetPrincipalPolicy(

    PrincipalPolicy.WindowsPrincipal);

    WindowsPrincipal myPrincipal = (Thread.CurrentPrincipal  as WindowsPrincipal);

    myPrincipal.Identity.Name

    et ca marche pas

     Merci de me aider



    Med Tems
    • Modifié Med Tems mardi 7 juillet 2009 16:33
    mardi 7 juillet 2009 16:30

Réponses

  • Il s'agit bien d'un site Intranet que vous mettez en place? C'est à dire que le serveur est bien sur le même réseau que les clients destinés à utiliser le site?

    Si oui,

    Si vous possedez un Proxy, je pense qu'il faut que vous configuriez le poste client pour faire en sorte qu'il ne passe pas par votre proxy. Pour ce faire, dans les options d'IE, onglet Connexions, bouton Paramètres réseau, bouton Avancé, encadré "Exception", ajoutez l'adresse de votre site, ou plus généralement *.votredomaine afin que les accès aux sites de votre réseau ne passent plus par le proxy. Vous devirez alors vous trouver en zone Intranet lors de la connexion à votre site.
    • Proposé comme réponse t0x1 mercredi 8 juillet 2009 09:50
    • Marqué comme réponse Med Tems mercredi 8 juillet 2009 10:06
    mercredi 8 juillet 2009 09:50

Toutes les réponses

  • Bonjour,

    L'identité d'exécution du thread se configure dans IIS.
    Pour que l'utilisateur retourné corresponde à l'utilisateur de la personne navigant sur la page web, il faut que l'authentification Windows soit activée dans les propriétés de sécurité de IIS. Si la personne utilise Internet Explorer, avec des paramètres standard, son identification sera automatiquement propagée lors de la connection au site. Si l'utilisateur n'est pas reconnu, la connexion anonyme est utilisée si elle est activée dans IIS.

    La consigne :

    <system.web > <identity impersonate ="true" /> </system.web >

    doit également être présente dans le web.config.

    Cordialement,

    t0x1
    • Proposé comme réponse t0x1 mercredi 8 juillet 2009 07:22
    mardi 7 juillet 2009 19:19
  • Merci pour votre réponse,
    la variable  impersonate ="true"  est déja présent, et aussi l'authentification Windows mais le nevigateur toujour me redemande d'authentifier a l'aide du fenetre d'authentification , moi je veux qu'il prend automatiquement l'utilisateur windows connécté (transparant)

    merci
    Med Tems
    mercredi 8 juillet 2009 09:37
  • L'utilisateur utilise-t-il Internet Explorer?
    Lorsque l'utilisateur navigue sur le site, dans quelle zone se trouve-t-il? (c'est ecrit dans la barre de statut en bas), Il faut que la zone soit Intranet local.

    mercredi 8 juillet 2009 09:41
  • la zone c'est Internet,
    comment je peu changer la zone du navigation pour qu'il soit Intranet local pour les navigateur client a partire du serveur

    Med Tems
    mercredi 8 juillet 2009 09:46
  • Il s'agit bien d'un site Intranet que vous mettez en place? C'est à dire que le serveur est bien sur le même réseau que les clients destinés à utiliser le site?

    Si oui,

    Si vous possedez un Proxy, je pense qu'il faut que vous configuriez le poste client pour faire en sorte qu'il ne passe pas par votre proxy. Pour ce faire, dans les options d'IE, onglet Connexions, bouton Paramètres réseau, bouton Avancé, encadré "Exception", ajoutez l'adresse de votre site, ou plus généralement *.votredomaine afin que les accès aux sites de votre réseau ne passent plus par le proxy. Vous devirez alors vous trouver en zone Intranet lors de la connexion à votre site.
    • Proposé comme réponse t0x1 mercredi 8 juillet 2009 09:50
    • Marqué comme réponse Med Tems mercredi 8 juillet 2009 10:06
    mercredi 8 juillet 2009 09:50
  • Merci ça a marché
    Med Tems
    mercredi 8 juillet 2009 10:07