none
Problème - des relations étrangères non trouvées dans mon DataBase.edmx RRS feed

  • Discussion générale

  • Bonjour,

     

    Après la génération du modèle (Model1.edmx) de ma bases de données, je ne trouve pas tous mes clés étrangères, je peut dire la majorité des clés,

    ma base contient vers 120 tables,  est ce que la taille du schéma de ma base a une influence sur le résultats du processus,

     

    merci pour votre réponse,

     

     


    • Modifié Ishak23 mercredi 6 juillet 2011 12:55
    • Type modifié Ciprian Duduiala mardi 12 juillet 2011 06:06 attente de feedback
    mardi 5 juillet 2011 16:37

Toutes les réponses

  • Bonjour,

     

    Jai pas encore trouvé la réponse,

     

    j'ai fait une petite base de données qui ne contient que deux tables avec une seule relation (père - enfant),

    les deux tables existent dans la base de données d 'origine (avec les 120 tables),

    bon, là je trouve la relation étrangère dans le modèle généré (Model1.edmx) et dans son Designer lui associé,

     

    pour quoi ?

    quelqu’un a une réponse à mon problème, ?!

     

    mercredi 6 juillet 2011 12:53
  • Bonjour,

     

    Après la génération du modèle (Model1.edmx) de ma bases de données, je ne trouve pas tous mes clés étrangères, je peut dire la majorité des clés,

    ma base contient vers 120 tables,  est ce que la taille du schéma de ma base a une influence sur le résultats du processus,

     

    j'ai fait une petite base de données qui ne contient que deux tables avec une seule relation (père - enfant),

    les deux tables existent dans la base de données d 'origine (avec les 120 tables),

    bon, là je trouve la relation étrangère dans le modèle généré (Model2.edmx) et dans son Designer lui associé,

    pour quoi ?

    quelqu’un a une réponse à mon problème, ?!

    mercredi 6 juillet 2011 12:57
  • Bonjour,

    Ce n’est pas clair pour moi qu’est-ce qu’il manque dans votre modèle. Dans le premier message vous dites que vous ne pouvez pas trouver tous les clés étrangères (et il est normale d’être comme ça) et puis vous parlez de la relation étrangère entre les tables. Pouvez-vous clarifier cet aspect pour nous ? Merci d’avance !

     

    Cordialement,

    Cipri

     


    Suivez MSDN sur Twitter   Suivez MSDN sur Facebook


    Ciprian DUDUIALA, MSFT  
    •Nous vous prions de considérer que dans le cadre de ce forum on n’offre pas de support technique et aucune garantie de la part de Microsoft ne peut être offerte.

    vendredi 8 juillet 2011 08:01
  • Bonjour,

    Je m'excuse pour le retard,

    En faite, la base de données sur le quel je travail (120 tables) contient plusieurs relation (vers les 300 relations étrangères), Installée sur SQL Server 2008 Express 10.50.1671,

    - le problème est le suivant: après la génération du modèle (Model1.edmx), à partir de cette Base, je ne trouve pas tous mes relations étrangères, plus de la moitie sont perdus.

    s'il y a quelqu'un a la possibilité de jeté un oie  sur maBaseDeDonnée.bak voici mon email "b.ishak23@gmail.com" et je peut le lui envoyer,

    merci d'avance,

     

    mercredi 20 juillet 2011 10:47