none
Problème d'affichage d'un contrôle utilisateur RRS feed

  • Question

  • Bonjour,

    J'ai créé un contrôle utilisateur sur VS2015 il y a quelques temps alors que mon système d'exploitation était Windows 8.

    Je viens de changer de PC qui lui tourne sous Windows 10. Je réinstalle VS2015, recommence à travailler et je m'aperçois que mon contrôle utilisateur s'affiche bizarrement, les contrôles ne sont plus positionnés correctement. Le plus bizarre c'est qu'en mode programmation quand je positionne mon contrôle sur ma forme, il apparaît correctement. Mais quand je lance l'application les positions diffèrent.

    Je me suis dis qu'avec les manipulations effectuées lors du transfert d'un pc à un autre, il se peut qu'il y ait eu un problème. Enfin bref je décide de tout casser et de recréer mon contrôle. Malheureusement rien n'y fait. Je pense qu'il y a un souci à cause des différences graphique entre Windows 10 et Windows 8, mais comment régler cela? Je dis cela car en plus de ce problème je m'aperçois d'autres problèmes graphiques. Exemple le texte des boutons qui n'est pas bien centré.

    Avez-vous une solution à mon problème? Dans mon contrôle il y a un bouton, un ovalshape et un label.

    Cordialement.

    mardi 2 février 2016 07:29

Réponses

  • Bonjour

    AchLog a communiqué un problème similaire le 9/02/2016

    Il y a parfois un problème de résolution des écrans.
    Vous pouvez modifier le mode de mise à l'échelle des fenêtres.
    Par défaut, les fenêtres winform règlent leur mise à l'échelle par rapport à la taille des polices de caractères.

    Propriété:
    AutoScaleMode ==> Font
    Faites plusieurs tests en modifiant cette valeur.

    Il me semble que c'est un bug récent de Windows10.
    Je programme sur une Surface 2 pro sous Windows 10 et un écran 27"  sans aucun souci.

    Regardez la discussion
    https://social.msdn.microsoft.com/Forums/fr-FR/22e53c6e-552d-42ab-af8b-fb29ba265358/problme-daffichage-de-fentres-winform?forum=netdevelopmentfr

    Cordialement
    Gérard


    jeudi 11 février 2016 13:53

Toutes les réponses

  • Bonjour, Pierrick CASTEL,

    Avez-vous régénéré votre application, une fois la mise à jour accomplie ?
    Je vous remercie par avance de votre retour.

    Cordialement,
    Teodora


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    jeudi 11 février 2016 13:33
    Modérateur
  • Bonjour

    AchLog a communiqué un problème similaire le 9/02/2016

    Il y a parfois un problème de résolution des écrans.
    Vous pouvez modifier le mode de mise à l'échelle des fenêtres.
    Par défaut, les fenêtres winform règlent leur mise à l'échelle par rapport à la taille des polices de caractères.

    Propriété:
    AutoScaleMode ==> Font
    Faites plusieurs tests en modifiant cette valeur.

    Il me semble que c'est un bug récent de Windows10.
    Je programme sur une Surface 2 pro sous Windows 10 et un écran 27"  sans aucun souci.

    Regardez la discussion
    https://social.msdn.microsoft.com/Forums/fr-FR/22e53c6e-552d-42ab-af8b-fb29ba265358/problme-daffichage-de-fentres-winform?forum=netdevelopmentfr

    Cordialement
    Gérard


    jeudi 11 février 2016 13:53