none
Désactiver les fonctions Swipe sous Windows 10 RRS feed

  • Discussion générale

  • Bonjour,

    Je me permets de m'adresser à vous afin d'obtenir un peu d'aide.

    J'ai développé une application que j'ai installée sur une tablette sous Windows 10 (Lenovo mix 2).

    Mon application fonctionne en plein écran sans barre d'état... et donc sans la fameuse petite croix pour quitter l'application.

    Ce que je souhaite c'est qu'il soit impossible de quitter cette application sauf en utilisant un clavier et/ou souris.

    Pour cela je souhaiterai désactiver les swipes ou balayages (celui du bord gauche vers le centre qui active le switcher et celui du bord droit vers le centre qui ouvre le centre des notifications).

    Auriez-vous une solution pour m'aider à "verrouiller" ces éléments (clés dans la base de registre, applications...) ?

    Je me souviens sous Windows 8/8.1 d'une fonction pour "désactiver les bords", mais je souhaiterai rester sous W10, surtout que d'ici peu les machines vendues en seront toutes équipées.

    Par avance merci pour votre aide.


    jeudi 3 septembre 2015 22:52

Toutes les réponses

  • Bonjour, Steeve76450,

    Postez, s'il vous plaît, un exemple de cette fonction pour "désactiver les bords", déjà utilisée sous Windows Windows 8/8.1.

    Je vous remercie par avance de votre retour.

    Cordialement,
    Teodora


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    vendredi 4 septembre 2015 13:14
    Modérateur
  • Bonsoir Teodora,

    Voici un lien montrant comment accéder à ce paramètre (désolé d'avoir utilisé à tort le mot fonction pour désigner ce paramètre) :

    http://protuts.net/desactiver-coins-actifs-windows-8-1/

    Mon compte MSDN n'étant pas validé j'ai dû mettre le lien sous forme de texte car il m'est pour le moment impossible d'insérer un lien.

    On peut désactiver le balayage du bord gauche vers le centre, mais pas la barre des charms (pour cette dernière une solution par ajout d'une clé dans la base de registre existerai, je ne l'ai jamais essayée).


    vendredi 4 septembre 2015 19:46
  • Bonjour, Steeve76450,

    Veuillez tester les solutions proposées dans le thread en bas:
    Desktop apps on top of Metro
    Je vous remercie par avance de votre retour.

    Cordialement,
    Teodora


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    vendredi 11 septembre 2015 14:12
    Modérateur
  • Bonjour Teodora,

    Mon application est une application desktop.

    Je n' ai aucun problème pour qu' elle soit au premier plan. Je souhaite juste empêcher le fait de pouvoir ouvrir le switcher et le centre des notifications par les balayages.

    Et ce thread ne répond malheureusement pas à mon problème.

    vendredi 11 septembre 2015 16:47
  • Bonjour, Steeve76450,

    Le thread est-il toujours d'actualité?
    Je vous remercie par avance de votre retour.

    Cordialement,
    Teodora

    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    mercredi 30 septembre 2015 23:48
    Modérateur
  • Bonjour Teodora,

    Ma question étant toujours sans réponse, ce thread est donc toujours d'actualité.

    Cordialement,

    Steeve

    jeudi 1 octobre 2015 22:00
  • Avez vous trouvé une solution?

    Cordialement

    Brice

    mardi 2 août 2016 14:33
  • Malheureusement toujours pas...
    mercredi 3 août 2016 22:13
  • Je pense que la réponse est la : http://www.tenforums.com/tutorials/48507-edge-swipe-screen-enable-disable-windows-10-a.html

    L'article fournit un fichier qui modifie le registre, le tutoriel est plutôt claire.

    mardi 8 novembre 2016 16:58
  • Bonjour LudoBoy54,

    Je vous remercie d'avoir partagé cette solution avec la communauté du forum.

    Cordialement,
    Teodora


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    vendredi 9 décembre 2016 16:23
    Modérateur