none
Problème de mise à jour en mode design RRS feed

  • Question

  • Bonjour,

    Je travaille en Visual Studio 2013, version 12.0.31101.00 avec update 4, avec un serveur Team Foundation server 2013, et la suite DevExpress Winform.

    Je rencontre un problème depuis quelques temps, qui se reproduit de plus en plus régulièrement : lorsque je modifie une formulaire en mode design (changement d'une propriété, ajout ou modification d'un contrôle...), le visuel est bien mis à jour, mais le fichier designer.vb n'est pas mis à jour, et en lançant l'application, je ne retrouve aucune de mes modifications.

    Je suis de plus en plus régulièrement obligé de fermer le designer de mon formulaire, puis le réouvrir, pour être sûr que mes modifications soient prises en comptes.

    Bizarrement, mes collègues de travail qui ont la même version de visual studio, avec la même version de DevExpress, et travaillent sur les mêmes applications partagées en team foundation ne rencontrent pas ce souci.

    Etes-vous au courant d'un tel bug ? Il y aurait-il un correctif ou une manipulation à faire pour corriger cela ?

    Merci d'avance pour ces précisions.

    Cordialement.


    pieret

    mercredi 27 avril 2016 15:56

Toutes les réponses

  • Bonjour, glaudioman,

    Pouvez-vous désactiver l'option "Tout obtenir lors de l'ouverture d'une solution ou d'un projet" pour régler le problème de mise à jour en mode design ?
    Je vous remercie par avance de votre retour.

    Cordialement,
    Teodora


    Votez! Appel à la contribution TechNet Community Support. LE CONTENU EST FOURNI "TEL QUEL" SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. S'il vous plaît n'oubliez pas de "Marquer comme réponse" les réponses qui ont résolu votre problème. C'est une voie commune pour reconnaître ceux qui vous ont aidé, et rend plus facile pour les autres visiteurs de trouver plus tard la résolution.

    jeudi 28 avril 2016 12:01
    Modérateur
  • Bonjour,

    Merci pour votre retour.

    Cette option est déjà désactivée.

    Par contre, en modification, j'ai l'option "demander un verrouillage à l'extraction". Cela peut-il jouer ?

    Cordialement.


    pieret

    Edit : Mes collègues ont les mêmes options, mais ne rencontrent pas ce problème...
    • Modifié glaudioman jeudi 28 avril 2016 13:20 Complément
    jeudi 28 avril 2016 13:17
  • Bonjour,

    Mon problème n'est toujours pas réglé, et plus aucun retour depuis une semaine...

    Existe-t-il un correctif pour ce problème ? Cela commence à devenir très problématique de travailler sur Visual studio... Je suis obligé de fermer et ré-ouvrir en designer mon formulaire après chaque modification pour être sur que je ne travaille pas dans le vide...

    Suis-je bon pour reformater mon poste ?

    Cordialement.


    pieret

    vendredi 6 mai 2016 13:35